.htaccess & 10.5 apache2

eXcuvator

Mitglied
Thread Starter
Mitglied seit
31.05.2007
Beiträge
201
Moin,

ich krieg den 10.5-eingebauten apache2 nicht dazu, meine lokalen .htaccess zu akzeptieren. Selbst wenn ich da totalen Murks reinschreibe, bekomme ich keinen 500er Fehler, er ignoriert sie schlechtweg.

Auszug aus der vhosts:
<VirtualHost *:80>
DocumentRoot "/Users/excuvator/Sites/thegl/html/"
ServerName tgl.localhost
</VirtualHost>

<Directory "/users/excuvator/Sites/thegl/html">
#
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs/2.2/mod/core.html#options
# for more information.
#
Options Indexes FollowSymLinks MultiViews

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride All

#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all

</Directory>
 

eXcuvator

Mitglied
Thread Starter
Mitglied seit
31.05.2007
Beiträge
201
Hatte ich keinen Eintrag zu gefunden, aber nun selbst einen oben in die vhosts erstellt:

AccessFileName .htaccess

Keine Besserung.
 

eXcuvator

Mitglied
Thread Starter
Mitglied seit
31.05.2007
Beiträge
201
So etwas hatte ich garnicht drin. Sobald ich RewriteBase / angebe, funktioniert der komplette vhost "tgl.localhost" nicht mehr, nur noch "localhost". Es kommt "Verbindung fehlgeschlagen".
 
D

dms

Das meinte ich nicht. :) War etwas schlecht verlinkt, sorry. Hatte mir die Suche so ausgespuckt.
fort(?)schritt 1:
mein webserver verarbeitet zumindest schonmal die .htaccess-datei, indem ich folgendes an die /etc/apache2/users/username.conf gehaengt habe:

<Directory "/Users/username/Sites/">
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>
 

eXcuvator

Mitglied
Thread Starter
Mitglied seit
31.05.2007
Beiträge
201
ja, hat auch nix gebracht (in meinem Fall die vhosts.conf, aber das macht ja nix. Ist ja quasi das gleiche, was oben steht, nur ohne die Kommentare.

Wenn ichs in Verbindung mit RewriteBase hab, kommt "Verbindung Fehlgeschlagen", wenn ichs solo hab, "Not Found".
 

maceis

Aktives Mitglied
Mitglied seit
24.09.2003
Beiträge
16.879
Wo liegt denn Deine .htaccess genau?

Wenn Sie am richtigen Platz liegt, könnten noch unpassend gesetzte Zugriffsrechte Dein Problem erklären.
Wenn der Webserver die Datei nicht lesen darf, kann er sie auch nicht beachten.
 

eXcuvator

Mitglied
Thread Starter
Mitglied seit
31.05.2007
Beiträge
201
Sie liegt in <Directory "/users/excuvator/Sites/thegl/html">.
Ach, und chmod 777 .htaccess hatte ich bereits gemacht.
 
Zuletzt bearbeitet:

maceis

Aktives Mitglied
Mitglied seit
24.09.2003
Beiträge
16.879
<Directory "/users/excuvator/Sites/thegl/html">

Mal großes U versucht?
 

eXcuvator

Mitglied
Thread Starter
Mitglied seit
31.05.2007
Beiträge
201
Wunderbar :D

Ich dachte bei Mac OS wäre groß- und kleinschreibung egal? Na,was solls :)
 
Oben