Hilfe: Probleme nach FileVault

spandolf

Registriert
Thread Starter
Mitglied seit
07.11.2008
Beiträge
2
Macbook Pro, 17", 2,6 GHz Intel

Hallo miteinander,

....nun erstmal chronologisch meine Aktionen vor dem Absturz:

1. Neues Hauptkennwort eingerichtet
2. Private Dateien mit FileVault verschlüsselt.
3. Den Namen der BENUTZER-Datei(die mit dem Häuschen davor) geändert. Was ich wohl nicht hätte machen sollen..

...Situation nach herunterfahren und wieder starten:

1. das normale Kennwort wird nicht mehr erkannt.
2. Nach dreimaliger falscher Eingabe kam die Aufforderung:

Geben Sie das Hauptkennwort ein, um das Kennwort des Benutzers ´ zurück zu setzen und FileVault aufzuheben.

3. Nachdem ich das Hauptkennwort eingegeben habe (was ich ja vorher erstellt hatte), kam folgende Meldung:

Wenn Sie das Kennwort für diesen Benutzeraccount ändern wird ein neuer Schlüsselbund für das Sichern von Kennwörtern erstellt.

Der vorhergehende Schlüsselbund des Benutzers ist noch vorhanden. Wenn Sie das vorherige Kennwort haben können Sie auf den vorherigen Schlüsselbund und die enthaltenen Informationen und Kennwörter zugreifen.


4. Nachdem ich diese Meldung mit OK bestätigt habe, erscheint folgende Dialogbox:

Neues Kennwort:
Wiederholen:


5. Hiermit ist dann Schicht im Schacht...da ich aber einen Gastaccount eingerichtet hatte kann ich zwar mit dem Rechner arbeiten, habe aber keinerlei Rechte.

Meine Frage ist, wie ich wieder die Herrschaft über den Rechner erringen kann??

Grüße Michael
 

Ulfrinn

Aktives Mitglied
Mitglied seit
30.01.2005
Beiträge
6.716
Den Namen der BENUTZER-Datei(die mit dem Häuschen davor) geändert. Was ich wohl nicht hätte machen sollen..
Richtig. Mehr dazu hier.
 
Zuletzt bearbeitet von einem Moderator:

spandolf

Registriert
Thread Starter
Mitglied seit
07.11.2008
Beiträge
2
hallo Ulfrinn,

danke für den Link. Den hatte ich schon heute nachmittag gefunden...leider funktioniert das bei mir nicht weil: ..
ich zitiere...Nun müssen wir uns als erstes durch Anlicken des Schloss-Symbols und Eingabe von Zugangsdaten eines Administrators authentifizieren...

ich kann mich aber nicht mehr als admin einloggen weil diese daten anscheinend in den privaten dateien abgelegt werden. diese wiederum habe ich verschlüsselt und dann den dateinamen geändert. ich kann jetzt tausendmal meine bisherigen benutzerdaten eingeben. das system kennt sie nicht. und als gast habe ich leider nicht die nötigen rechte dazu...was mach ich jetzt nur??

grüße michel
 

Ulfrinn

Aktives Mitglied
Mitglied seit
30.01.2005
Beiträge
6.716
ich kann mich aber nicht mehr als admin einloggen weil diese daten anscheinend in den privaten dateien abgelegt werden.
Nein, die Anmeldeinformationen werden nicht im Benutzerverzeichnis gespeichert. Aufgaben mit Administratorrechten solltest Du vom Gastkonto aus erledigen können, indem Du, wenn Du dazu aufgefordert wirst, die Anmeldedaten von Deinem defekten Konto eingibst (altes und neues Kennwort probieren).
 

Tom Bola

Mitglied
Mitglied seit
04.10.2008
Beiträge
64
Ich habe bei mir jetzt FileVault aktiviert, was mich aber interessiert, ist, ob meine Festplatte mit 128 oder 256 Bit verschlüsselt worden ist?
Falls die Einstellung auf 128 Bit gesetzt worden ist, wie kann ich sie auf 256 Bit umändern?
 

Ulfrinn

Aktives Mitglied
Mitglied seit
30.01.2005
Beiträge
6.716
Ich habe bei mir jetzt FileVault aktiviert, was mich aber interessiert, ist, ob meine Festplatte mit 128 oder 256 Bit verschlüsselt worden ist?
Deine Festplatte wird mit FileVault in keiner Weise verschlüsselt. Vielmehr ist Dein Benutzerordner fortan in einer verschlüsselten Abbilddatei gespeichert.

Allerdings solltest Du FileVault schnellstmöglich wieder deaktivieren. Die Funktion ist schlicht und ergreifend nicht ausgereift und deshalb alles andere als sicher. Außerdem kann ein Systemabsturz zu einem totalen Verlust der Benutzerdaten führen.
 

Tom Bola

Mitglied
Mitglied seit
04.10.2008
Beiträge
64
Deine Festplatte wird mit FileVault in keiner Weise verschlüsselt. Vielmehr ist Dein Benutzerordner fortan in einer verschlüsselten Abbilddatei gespeichert.

Allerdings solltest Du FileVault schnellstmöglich wieder deaktivieren. Die Funktion ist schlicht und ergreifend nicht ausgereift und deshalb alles andere als sicher. Außerdem kann ein Systemabsturz zu einem totalen Verlust der Benutzerdaten führen.
#Ist dieser Benutzerordner mit 128 oder 256 verschlüsselt?

#Ich habe ein Backup
 

chris25

Aktives Mitglied
Mitglied seit
10.08.2005
Beiträge
4.925
Allerdings solltest Du FileVault schnellstmöglich wieder deaktivieren. Die Funktion ist schlicht und ergreifend nicht ausgereift und deshalb alles andere als sicher. Außerdem kann ein Systemabsturz zu einem totalen Verlust der Benutzerdaten führen.
Seit der Verwendung von Sparsebundles in Leopard haben diese Schreckensmeldungen meiner Meinung nach aber abgenommen, oder?
 

Ulfrinn

Aktives Mitglied
Mitglied seit
30.01.2005
Beiträge
6.716
Seit der Verwendung von Sparsebundles in Leopard haben diese Schreckensmeldungen meiner Meinung nach aber abgenommen, oder?
Ich denke nicht, daß das ursächlich zusammenhängt. Und selbst wenn das Datenverlustrisiko mit Sparsebundles geringer ist, ist es noch immer sehr groß. Sparsebundles haben hauptsächlich einen anderen Vorteil, nämlich daß Time Machine bei einer Änderung nicht eine riesige monolitische Datei sichern muß, sondern nur einzelne kleine.
 

Ulfrinn

Aktives Mitglied
Mitglied seit
30.01.2005
Beiträge
6.716
#Ist dieser Benutzerordner mit 128 oder 256 verschlüsselt?
Schau selbst im Terminal:
Code:
hdiutil imageinfo /Users/.Dein_Kurzname/Dein_Kurzname.sparsebundle
 

Tom Bola

Mitglied
Mitglied seit
04.10.2008
Beiträge
64
Schau selbst im Terminal:
Code:
hdiutil imageinfo /Users/.Dein_Kurzname/Dein_Kurzname.sparsebundle
Mein Benutzerordner heißt Test

hdiutil imageinfo /Users/.test/test.sparsebundle

So habe ich den Befehl ausgeführt und bekam eine Fehlermeldung
 

Elchmann

Mitglied
Mitglied seit
17.03.2005
Beiträge
694
Schau selbst im Terminal:
Code:
hdiutil imageinfo /Users/.Dein_Kurzname/Dein_Kurzname.sparsebundle
Wenn ich diesen Befehl auf ein verschlüsseltes Image anwende, steht da nur "Encrypted: true", aber nicht die Stärke der Verschlüsselung.

Ich hatte übrigens (von Anfang an, seit Panther) nie Probleme mit FileVault, verwende aber trotzdem für schützenswerte Dateien meines Hauptkontos (mit dem Festplattendienstprogramm) selbst erstellte verschlüsselte Images, deren Paßwörter (Sätze!) nicht im Schlüsselbund abgelegt werden. So habe ich u.a. auch die Kontrolle, ob wirklich mit 256 Bit verschlüsselt wird.

Laut (veraltetem? Eintrag in der) "Mac Hilfe" verschlüsselt FileVault mit 128 Bit.
 

Ulfrinn

Aktives Mitglied
Mitglied seit
30.01.2005
Beiträge
6.716
Wenn ich diesen Befehl auf ein verschlüsseltes Image anwende, steht da nur "Encrypted: true", aber nicht die Stärke der Verschlüsselung.
Unter Leopard? Bei mir wird eine ganze Reihe an Informationen ausgegeben, angefangen mit:
Format: SPRS
Backing Store Information:
Encryption: AES-256
Class Name: CEncryptedEncoding
 

Elchmann

Mitglied
Mitglied seit
17.03.2005
Beiträge
694
Unter Leopard? Bei mir wird eine ganze Reihe an Informationen ausgegeben, angefangen mit...
Ja, das scheint am Format (SPRS) bzw. den Einstellungen zu liegen. Wenn ich ein mitwachsendes Sparseimage erstelle, bekomme ich auch diese Infos angezeigt, bei einem mitwachsenden Sparsebundle (UDSB) nicht.
 
Oben