Gentoo Portage "emerge system" Problem

  1. Galdo

    Galdo Thread StarterMacUser Mitglied

    Mitglied seit:
    29.09.2004
    Beiträge:
    591
    Zustimmungen:
    0
    Hallo,

    ich habe mich genau an die Anleitung gehalten, die im Netz zur Portage Installation auf Macos 10.3 zu finden ist.

    Leider habe erhalte ich nach einem "emerge system" folgenden Fehler:

    iBook-Galdo:/Users/galdo root# emerge system
    Calculating system dependencies /
    !!! All ebuilds that could satisfy "sys-apps/coreutils" have been masked.
    !!! One of the following masked packages is required to complete your request:
    - sys-apps/coreutils-5.0-r6 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.0-r2 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.1-r1 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.1-r2 (masked by: missing keyword)
    - sys-apps/coreutils-5.2.1 (masked by: missing keyword)

    For more information, see MASKED PACKAGES section in the emerge man page or
    section 2.2 "Software Availability" in the Gentoo Handbook.
    !!! (dependency required by "sys-apps/debianutils-1.16.7-r4" [ebuild])


    !!! Problem with ebuild sys-apps/debianutils-1.16.7-r4
    !!! Possibly a DEPEND/*DEPEND problem.

    !!! Depgraph creation failed.​

    Wäre nett,

    wenn mir jemand einen Tipp geben könnte!

    Vielen Dank

    Galdo
     
    Galdo, 19.11.2004
  2. Rakor

    RakorMacUser Mitglied

    Mitglied seit:
    05.11.2003
    Beiträge:
    2.785
    Zustimmungen:
    3
    Servus in Mannem :)

    Naja er sagt dir, dass coreutils gemasked ist... Hast du den portagetree aktualisiert?
     
    Rakor, 19.11.2004
  3. Galdo

    Galdo Thread StarterMacUser Mitglied

    Mitglied seit:
    29.09.2004
    Beiträge:
    591
    Zustimmungen:
    0
    Wie gesagt, ich hab mich genau an die Anleitung gehalten und hab dementsprechend auch ein "emerge sync" durchgeführt.

    Bin aber gerade am probieren, und mache nochmal ein sync. Vielleicht klappts ja dann :)

    Ich will den gentoo-portage :p (auf x86 läufts ja auch)
     
    Galdo, 19.11.2004
  4. Rakor

    RakorMacUser Mitglied

    Mitglied seit:
    05.11.2003
    Beiträge:
    2.785
    Zustimmungen:
    3
    Tja, ich hab mit Portage auf PPC auch keine Erfahrung... aber bei allen installationen auf x86 ist es bisher anstandslos gegangen...

    Installierst du nur das Portage für OSX oder ein Gentoo? AFAIK ist Portage für OSX noch in Entwicklung... evtl solltest du überlegen ob du masked Packete erlaubst (wenn es eh nur mal zum Test ist).

    BTW: Was sagt denn ein

    $ emerge -p system

    ?
     
    Rakor, 19.11.2004
  5. ignatz

    ignatzMacUser Mitglied

    Mitglied seit:
    02.06.2004
    Beiträge:
    225
    Zustimmungen:
    2
    ich mein ich kenn mich jetzt auch nicht so super mit portage auf OSX aus, aber ich würd jetzt einfach mal aus alter gewohnheit vorschlagen:

    echo "sys-apps/coreutils" > /etc/portage/package.unmask
    echo "sys-apps/coreutils ~macos" > /etc/portage/package.keywords

    letzteres nurfalls entsprechendes keyword überhaupt existiert, als ich mir das vor Monaten mal angeschaut hatte, gabs selbiges eben noch nicht. Ansonsten kann man sich teilweise auch mit ~ppc abhelfen (sollte man aber nicht übertreiben, da man gefahrläuft sich in den depencies zu verfangen)
     
    ignatz, 19.11.2004
  6. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.160
    Zustimmungen:
    3.885
    probier doch einfach mal ein "emerge -i" auf eins der sys-apps/coreutils pakete deiner wahl
     
    oneOeight, 23.11.2004
Die Seite wird geladen...
Ähnliche Themen - Gentoo Portage emerge
  1. industrie13
    Antworten:
    0
    Aufrufe:
    415
    industrie13
    25.11.2007
  2. Jan-Michael
    Antworten:
    3
    Aufrufe:
    820
    Jan-Michael
    14.03.2006
  3. CaT
    Antworten:
    6
    Aufrufe:
    606
  4. tom555
    Antworten:
    1
    Aufrufe:
    545