Frage zu TRIM und APFS

benmuetsch

Mitglied
Thread Starter
Registriert
04.12.2008
Beiträge
56
Hallo zusammen,

habe nach der neulichen Diskussion um NVMe tatsächlich gestern meinem cMP eine cleane Neuinstallation von Mojave verpasst (zuvor noch auf Sierra).

Läuft auch soweit alles ganz gut, auch wenn mit Mojave etwas weniger snappy vorkommt, als Sierra und High Sierra es sind.

Da sich Mojave ja nicht direkt per USB installieren lässt (Nvidia Kepler Graka), war das Vorgehen wie folgt:

- alle internen HDs und SSDs ausgebaut
- USB Stick mit High Sierra gebootet und auf eine Hilfs-SSD mit 120GB installiert (diese einfach temporär unter dem DVD LW angeschlossen)
- In High Sierra den Mojave Installer heruntergeladen und die eigentlich interne 2,5" SATA SSD (Crucial M4) per USB Adapter schonmal formatiert (APFS)
- Crucial SSD ebenfalls wieder eingebaut und von High Sierra aus den Mojave Installer gestartet, dann auf die 512GB Crucial installiert

Also as clean as it can get.. was ich bislang immer gemacht hab ist erstmal alle verfügbaren Updates installieren und dann sofort sudo trimforce enable. Funktioniert soweit auch, nur wird die Bootzeit selbst mit cleanem System extrem lang. Ohne TRIM: 40sec, mit TRIM ca 3min.

Natürlich findet man über das Problem diverse Foreneinträge hier und auch in anderen Foren.

Wozu es nur leider irgendwie nirgends eine konkrete Aussage gibt ist, ob es nun seit APFS ein Problem ist, TRIM einfach deaktiviert zu lassen für SATA SSDs.

Wie macht ihr das so?

Grüße,

Ben
 

Mr. Gulliver

Mitglied
Registriert
09.02.2018
Beiträge
328
Wozu es nur leider irgendwie nirgends eine konkrete Aussage gibt ist, ob es nun seit APFS ein Problem ist, TRIM einfach deaktiviert zu lassen für SATA SSDs.
TRIM spaltet seit der Einführung die Mac Community. Manche aktivieren es, manche nicht. Die SSDs haben mittlerweile sehr gute Controller und auch eine gute Garbage Collection. Meiner Meinung braucht man es daher nicht. Und da du keine Probleme dazu gefunden hast, scheint es wohl auch nicht so wichtig zu sein, dass man einen spürbaren Unterschied bemerken würde, falls man es nicht aktiviert hat.
 

Macschrauber

Aktives Mitglied
Registriert
08.02.2014
Beiträge
7.996
die Garbage Collection von Trim wird beim Booten ausgeführt. Kann man schön unter Verbose Boot sehen. Je nachdem wieviel die zu tun hat dauert das eine Weile. Einfach in den Workflow mit einarbeiten und den Rechner vor dem Kaffee holen hochfahren :)

NVMe dauert sowieso etwas länger zum Booten weil die am letzten in der Kette abgefragt wird.
 

benmuetsch

Mitglied
Thread Starter
Registriert
04.12.2008
Beiträge
56
die Garbage Collection von Trim wird beim Booten ausgeführt. Kann man schön unter Verbose Boot sehen. Je nachdem wieviel die zu tun hat dauert das eine Weile. Einfach in den Workflow mit einarbeiten und den Rechner vor dem Kaffee holen hochfahren :)

NVMe dauert sowieso etwas länger zum Booten weil die am letzten in der Kette abgefragt wird.

Also TRIM aktivieren? Wenn sich an der Datenstruktur der SSD nichts mehr so viel ändert, sollte der Bootvorgang ja iwann auch schneller gehen. Es ist btw eine normale SATA SSD, keine NVMe.

Verbose ist bei mir leider nicht, da kein Boot Screen.. :(
 

Macschrauber

Aktives Mitglied
Registriert
08.02.2014
Beiträge
7.996
dann pack doch RefindPlus dazwischen, wenn die Kepler einen Gop Treiber hat dann gibt's nen Bootscreen und andere Schmankerl wie SIP ein- und Ausschalten.
 

benmuetsch

Mitglied
Thread Starter
Registriert
04.12.2008
Beiträge
56
Also was die Bootzeit angeht.. ich installiere gerade die ganzen AudioUnits / Plugins neu.. das ist völlig inakzeptabel mit TRIM..
Bis zu 3min... das kann nicht im Sinne des Erfinders sein. Wenn ich mal Kunden dahab und neustarten muss.. ist ja peinlich.

Also entweder TRIM aus.. oder ne andere Lösung. Hilft es mir, wenn ich ne originale Apple SSUBX mit PCIE Adapter statt der Crucial SATA SSD verbaue als Boot Drive?
 

oneOeight

Aktives Mitglied
Registriert
23.11.2004
Beiträge
58.692
Ich frag mich wie Trim da einen Einfluss haben soll.
Das wird an sich nur aufgerufen, wenn etwas gelöscht wird.

Du musst übrigens nicht neustarten, Benutzer abmelden und anmelden reicht auch, um die Plugins neu zu laden bei AU.
 

benmuetsch

Mitglied
Thread Starter
Registriert
04.12.2008
Beiträge
56
Ich hab ja selbst kein Plan. Nur Abmelden reicht oft nicht. Manchmal muss man auch mal rebooten.
Ich sehe nur:
- TRIM aus: Mac Pro bootet in 40sec und ist sehr flott
- TRIM an: Mac Pro bootet in 3min und ist generell ein bisschen behäbig


Ich kenne das Problem selbst nicht. Ich benutze diese SSD seit vielen Jahren und das Problem war mit Yosemite/ El Capitan / Sierra nonexistent. ( TRIM jeweils manuell aktiviert )
 

Indio

Aktives Mitglied
Registriert
16.06.2004
Beiträge
1.953
kann sein das das bootROM nicht am letzten stand ist
da hatte sich doch in der richtung irgendwas verändert in den 14x versionen, oder @Macschrauber ?
 

Macschrauber

Aktives Mitglied
Registriert
08.02.2014
Beiträge
7.996
Nach dem Power On Selftest (dem Gong) hat das Bootrom seine Schuldigkeit im Prinzip getan.

Natürlich könnte aller möglicher Mist im Nvram stehen, aber das kanns bei jeder Version.

Um das generell auszutesten könnte man NACH BACKUP DER FIRMWARE WEGEN DEN HARDWARE IDS eine generische 144er Firmware mit leeren NVRam Streams flashen und vergleichen.

Wenn das einen Erfolg gibt dann hilft ein neu Aufbauen der Firmware mit dem darin enthaltenen NVRam Bereich.

Die generische Firmware kann man nicht verwenden weil die Seriennummer und die IDs fehlen. Es funktionieren dann keine Apple Dienste und die ein oder andere Software kann nicht validiert werden.
 

Indio

Aktives Mitglied
Registriert
16.06.2004
Beiträge
1.953
wobei aber bekannt ist das zB die WD SN550 im cMP nicht funktioniert
und daher kann diese liste nicht auf alle modellreihen angewandt werden.
 
Oben