Foto App: "verknüpfte Datei ist offline"

Diskutiere das Thema Foto App: "verknüpfte Datei ist offline". Hallo Apple Fans, bitte um eine qualifizierte Antwort, falls jemand das Problem kennt: macOS...

karlie

Mitglied
Thread Starter
Mitglied seit
28.10.2007
Beiträge
132
Hallo Apple Fans,
bitte um eine qualifizierte Antwort, falls jemand das Problem kennt:
macOS Catalina 10.15.4
iMac 27" 2017, 16GB, 2TB

Alle Fotos befinden sich auf der internen Festplatte (einige Tausend). Die Fotos werden NICHT in die Mediathek kopiert, sondern nur verlinkt. Wird ja auch von Fotos optional so angeboten.

In der jeweiligen Album-Fotovorschau haben sämtliche Bilder oben rechts ein kleines Quadrat, fährt man mit der Maus drüber erscheint "verknüpte Datei", klickt man darauf öffnet sich der Ordner in dem sich diese Datei befindet.
Beim größten Teil der Fotos und zwar bei den älteren hat das kleine Quadrat einen roten Schrägstrich und es erscheint "verknüpfte Datei ist offline", die Datei wird auch nicht gefunden. Kurioserweise kann das Foto in seiner vollen Auflösung geöffnet und auch per Ziehen mit der Maus auf den Desktop kopiert werden. D.h. Fotos kennt die Verlinkung doch.

Anmerkung:
Das Problem besteht auch in Mojave, nur daß hier der Link nicht gefunden und stattdessen ein verkleinertes Vorschaubild geöffnet wird. Schließt man Fotos und öffnet es wieder, ist der Link plötzlich da. Es sieht so aus, als kann Fotos nur eine bestimmte Anzahl von Links speichern? Schließen und Öffnen bringt bei Catalina nichts.

Danke für eine Antwort.
 

Lor-Olli

Mitglied
Mitglied seit
24.04.2004
Beiträge
8.993
Dieses spezielle Problem ist mir bisher nicht untergekommen, allerdings kenne ich ähnlich Probleme mit einigen anderen Programmen.
Die Fragen die sich ergeben:
- Die Fotos sind nicht online verfügbar (nur lokal), die icloud ist aber aktiv (z.B. wg. iPhone und Co.)
- die Fotos, oder einige waren nicht zufällig schon mal auch (!) online gespeichert? (z.B. wenn das iPhone die cloud nutzt)
- die icloud war aktiv und wurde dann aber deaktiviert?

Catalina verknüpft ganz gerne alles mit der icloud, wenn man die cloud nicht völlig ignoriert (wie ich…), meine Frau hatte mit einigen Musikstücken ein ähnliches Problem (nicht gefunden, aber dennoch lokal gespeichert). Sie hat sich beholfen, indem sie iTunes / Musik, komplett neu aufgesetzt hat. Hielt ich für übertrieben, hat aber geholfen…
 

karlie

Mitglied
Thread Starter
Mitglied seit
28.10.2007
Beiträge
132
Hallo Lor-Olli,

danke für die Antwort.
Mit der Cloud mache ich bewußt gar nichts, auch nicht mit Reinkopieren in die Mediathek, ich möchte meine Fotos selbst verwalten.
Das ist richtig, die Cloud war nach der Catalina Installation eingeschaltet, habe ich sofort wieder ausgeschaltet. Kann mir aber nicht vorstellen, daß tausende von Fotos und zwar nur die älteren betroffen sind.

Ich habe mit Command/Option und klick auf Fotos den Reparaturvorgang durchgeführt und dabei die gesamte Mediathek zerschossen, das muß ein Fehler sein. Ein Restore von Timemachine hat mich gerettet.

Als nächstes werde ich versuchen nur das Betriebssystem neu drüber zu installieren.
Schönen Gruß
 

karlie

Mitglied
Thread Starter
Mitglied seit
28.10.2007
Beiträge
132
Nach der Neuinstallation vom OS war das gleiche Verhalten wie unter Mojave s.o.. Nach kurzer Initialisierungsphase wieder das Problem, die Bilder lassen sich öffnen, rauskopieren, nur der verlinkte Pfad wird nicht gefunden (ohne Meldung) und der rote Schrägstrich ist sichtbar. Für mich eindeutig ein Fehler, der hoffentlich behoben wird.
 
  • Gefällt mir
Reaktionen: dg2rbf
Oben