Firefox: private Daten löschen

  1. LiteraDur

    LiteraDur Thread StarterMacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    128
    Zustimmungen:
    7
    Liebe Leute,

    eine Frage zu Firefox 1.5:

    Wenn man über das Menü "Extras" den Punkt "Private Daten löschen" aufruft, gibt es die Möglichkeit, die Option "Vor dem Löschen von privaten Daten fragen" zu wählen. Bei mir ist diese Option aktiviert, sie lässt sich allerdings nicht deaktivieren (ist nur grau angezeigt). Auch nicht über die "Einstellungen" im "Firefox"-Menü. Wie kann ich die Option abstellen?

    Bevor ich gesteinigt werde: ich habe die Suche hier benutzt und nichts gefunden. Liegt's an mir?

    Vielen Dank für die Hilfe,
    LiteraDur
     
    LiteraDur, 17.01.2006
  2. sheep

    sheepMacUser Mitglied

    Mitglied seit:
    21.03.2005
    Beiträge:
    1.223
    Zustimmungen:
    24
    Menü "Firefox" --> "Einstellungen" --> "Datenschutz"

    Dort auf den Button "Einstellungen" (unten rechts) klicken und "Vor dem Löschen von privaten Daten nachfragen" ausknippsen.
     
    sheep, 18.01.2006
  3. LiteraDur

    LiteraDur Thread StarterMacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    128
    Zustimmungen:
    7
    Vielen Dank für die Antwort. Aber leider funktioniert es nicht. Auch in "Einstellungen" - "Datenschutz" - "Einstellungen" bleibt der Eintrag "Vor dem Löschen von privaten Daten nachfragen" grau und ich kann ihn nicht deaktivieren. Dagegen kann ich in dem Eintrag direkt darüber ("Private Daten löschen, wenn Firefox beendet wird") problemlos das Häkchen aktivieren und wegnehmen.

    Vielleicht hängt das Problem irgendwie mit den (mir nicht recht verständlichen) Zugriffsrechten von OS 10.3.9 zusammen? Habe ich auch schon versucht, mit dem Festplattendienstprogramm und Onyx die Zugriffsrechte zu reparieren: Nichts. Als Admin bin ich auch angemeldet, mir sollte also alles erlaubt sein.

    Trotzdem vielen Dank
    LiteraDur
     
    LiteraDur, 18.01.2006
  4. sheep

    sheepMacUser Mitglied

    Mitglied seit:
    21.03.2005
    Beiträge:
    1.223
    Zustimmungen:
    24
    Dann gib mal in die Adressleiste ein: "about:config". Dort suchst du nach dem Eintrag "privacy.sanitize.promptOnSanitize". Der muss auf "false" gesetzt werden, um das Nachfragen abzuschalten, ich würde aber fast vermuten, dass der bei dir fehlen könnte (daher grau hinterlegt). Lege ihn in diesem Fall einfach an, indem du ins Fenster rechtsklickst und "Neu" --> "Boolean" wählst und als Eigenschaftsname "privacy.sanitize.promptOnSanitize" eingiebst. Dann setzt du ihn auf "false".

    Ich hoffe, das hilft...
     
    sheep, 18.01.2006
  5. LiteraDur

    LiteraDur Thread StarterMacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    128
    Zustimmungen:
    7
    Vielen Dank, das hilft schon weiter: den Eintrag "privacy.sanitize.promptOnSanitize" gab es schon; er stand auf "true". Ich habe ihn auf "false" gestellt und Firefox fragt nicht mehr nach, wenn ich die privaten Daten lösche (die Einstellung dafür in "Datenschutz" - "Einstellungen" bleibt aber grau und aktiviert). Wenn ich aber Firefox beende und neu starte, ist die Einstellung in der config wieder auf "true". Wohin muss ich "about:config" speichern, damit die Einstellung erhalten bleibt? (Wahrscheinlich eine dusselige Frage, aber was soll's).
     
    LiteraDur, 18.01.2006
  6. sheep

    sheepMacUser Mitglied

    Mitglied seit:
    21.03.2005
    Beiträge:
    1.223
    Zustimmungen:
    24
    Da ist irgendwas faul. Einstellungen, die man über about:config vornimmt, werden (selbstverständlich) automatisch gespeichert und bleiben somit auch nach einem Neustart von FF erhalten. Irgend etwas scheint die Einstellung beim Starten oder Beenden zurückzusetzen.

    Lösche (mit Vorteil vorher Backup machen) doch mal die Datei org.mozilla.firefox.plist unter Library/Preferences in deinem Homeverzeichnis und starte dann FF neu. Das Löschen der plist hilft bei vielen programmspezifischen Problemen, ich hoffe mal, auch hier :).
     
    sheep, 18.01.2006
  7. Aronnax

    AronnaxMacUser Mitglied

    Mitglied seit:
    08.01.2005
    Beiträge:
    1.560
    Zustimmungen:
    139
    nur mal am Rande - nicht dort, sondern hier:
    Benutzer/../Library/Application Support/Firefox/Profiles/xxxxxxxx.default/prefs.js
    werden genau diese Einstellungen gespeichert
     
    Aronnax, 18.01.2006
  8. LiteraDur

    LiteraDur Thread StarterMacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    128
    Zustimmungen:
    7
    Vielen Dank an sheep und an Aronnax! Als ich beide Tipps befolgte, kam ich auf die sehr einfache Lösung meines Problems:

    Wenn bei den "Einstellungen" - "Datenschutz" - "Einstellungen" das Häkchen vor "Gespeicherte Passwörter" gesetzt wird, wird automatisch weiter unten das Häkchen vor "Vor dem Löschen von privaten Daten fragen" gesetzt und die Einstellung erscheint nur noch in grau. Ich kann die Option also nicht deaktivieren. Es sei denn, ich deaktiviere zuerst wieder "Gespeicherte Passwörter".

    Ich hab's erst gemerkt, als ich "pref.js" in den Papierkorb geschoben hatte und deshalb alle Einstellungen neu vornehmen musste.

    Manchmal ist der Weg zu einer einfachen Lösung ziemlich umständlich. Nochmals vielen Dank für eure Hilfe!

    LiteraDur
     
    LiteraDur, 18.01.2006
Die Seite wird geladen...