Firefox - cmd+klick im scrollen mit 2 finger beim trackpad nicht möglich, da sich alles zoomt

msilver

Neues Mitglied
Thread Starter
Registriert
09.11.2016
Beiträge
37
hi,
alle paar wochen habe ich etwas in firefox vor mir, wo ich so 300 links in tabs öffnen muss (nein, keine prons ^^), leider aber geht der flow verloren.

ich nutze ein trackpad und das scrollen und zoomen ist ja jeweils mit dieser 2 finger geste verbunden. (scrollen 2 finger, zoomen cmd+2finger)

wenn ich nun scrolle, da viele viele links, halte ich eben die cmd gedrückt und scrolle weiter um weiter tabs zu öffnen, leider aber geht das nicht.

nun möchte ich nicht deswegen meine maus raus holen, weil hier würde das ja gehen.
 

Lor-Olli

Aktives Mitglied
Registriert
24.04.2004
Beiträge
9.361
Allen Ernstes? 300 tabs…
Zu allerst würde ich mal diese Tabs öffnen und dann die Aktivitätsanzeige anschauen > vor allem Speicher, Cache, eventuell auch Netzwerk wenn die tabs aktiv sind… Der swap (Speicher, die Grafik unten) dürfte reichlich groß sein, selbst wenn Du viel RAM verwendest. Irgendwann wird so auch der schnellste Rechner lahm (OK, unser MacPro mit 128 GB RAM und fixer SSD nicht, aber da gehe ich mal nicht von aus…)
 

msilver

Neues Mitglied
Thread Starter
Registriert
09.11.2016
Beiträge
37
firefox ist da clever. nur tabs die ich betrachte, sind offen, alle anderen sind im "noch nicht geladen" modus. daher geht der rechner nicht in die knie.
 

Tealk

Mitglied
Registriert
05.09.2020
Beiträge
264
Ok interessant, soweit ich überall lese funktioniert preference browser.tabs.unloadOnLowMemory nur auf Windoof
 

agrajag

Aktives Mitglied
Registriert
25.08.2004
Beiträge
4.126
Oder man benutzt ein Addon wie Auto Tab Discard. Ich hab aktuell 1491 "offene" Tabs. Von denen sind aber nur max. 10 wirklich aktiv. Der Wust an Tabs ist allerdings auch nur mit Sidebery zu bewältigen. :)

Die Option mousewheel.with_control.action (in about:config) kann man auf 1 setzen, um das Zoomen via CTRL-Scroll zu deaktivieren. Allerdings funktioniert das wohl nicht mit dem Touchpad. Scheinbar löst das Touchpad einen anderen Event aus.
 

agrajag

Aktives Mitglied
Registriert
25.08.2004
Beiträge
4.126
Hier ist meine userChrome.css:

Code:
/*
* Do not remove the @namespace line -- it's required for correct functioning
*/
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

/*
  * Hide tab bar, navigation bar and scrollbars
  * !important may be added to force override, but not necessary
  * #content is not necessary to hide scroll bars
  */
#TabsToolbar {
  visibility: collapse;
}

#sidebar-header {
  display: none;
}
/* #navigator-toolbox { visibility: collapse; } */

/* browser { margin-right: -14px; margin-bottom: -14px; } */

#nav-bar toolbarspring {
  min-width: 32px !important;
  max-width: 32px !important;
}

Via about:profiles kannst du dir den Profil-Ordner im Finder öffnen. Im Ordner chrome findest du dann die userChrome.css. Falls sie noch nicht existiert, musst du eine anlegen.

Edit: boah, kann man irgendwie die automatische interpretation von ASCII-Smileys abschalten? Der Smiley steht für Doppelpunkt und p.
 
Zuletzt bearbeitet:
Oben