Finder: kein Netzwerk, kein Connect auf SMB-Server möglich

snboris

Mitglied
Thread Starter
Dabei seit
25.01.2020
Beiträge
96
Reaktionspunkte
33
Hallo zusammen..

ganz merkwürdiges Problem.
Von heute auf morgen funktioniert das Verbinden im Finder mit Netzwerklaufwerken auf diversen anderen Server nicht mehr.
Los ging es, das in der Seitenleiste des Finders kein Netzwerk mehr zu sehen ist.
Bei 'Gehe zu->mit Server verbinden' gebe ich wie bisher immer 'smb://<ip_des_servers>/<freigabename> ein.
Dann kommt nur noch die Fortschrittsanzeige und mehr nicht.
Die Server lassen sich alle anpingen und von anderen Rechnern aus auch verbinden.
Mit mount_smbfs vom Terminal aus klappt das Connecten auch.
Es ist, als ob jemand den internen SMB-Client vom Finder entfernt hätte.
Hatte heute deswegen schon mal auf 13.2 upgedatet - das hat aber auch nix gebracht.

Kennt da jemand die Ursache oder noch besser eine Lösung?

Danke
 
ja nach Server kann es ein, dass der sich einen geänderten mDNS-Namen zuweist. Erkennbar, am einer angehängten Ziffer am Servernamen. Das liegt regelmäßig daran, dass das DHCP-Lease zu lang ist und der Server zwischendurch runterfährt o.ä. oder nich ruhe dort der avahi-daemon nicht restartet.

Für so einen Fall ist die Lösung einfach den avahi-daemon auf dem Server neu starten.

Das ist aber nur eine der möglichen Ursachen.

Ansonsten prüfe mal die üblichen Netzwerkthemen, wie Firewall, VPN, VPN-Profile und andere "Optimierungstools" und Helferlein.
 
Danke.. das war ein guter Tipp.
Avahi-Service auf einem der Server neu gestartet.
Jetzt klappt das "Gehe zu->Verbinden mit Server" auch wieder.
Allerdings sehe ich im Finder in der Seitenleiste immer noch kein Netzwerk.
Wenn ich unter Orte auf Mac Studio klicke taucht das Netzwerk in der rechten/zentralen Teil des Finders auf.
Lässt sich allerdings nicht öffnen - bzw. ist leer.
 
???

Unter "Orte" siehst du also den Begriff "Netzwerk", aber wenn du da drauf gehst, erscheinen die server nicht? Ja?

Falls du die Server nicht siehst, ist dein avahi fehlerhaft konfiguriert und announciert die Samba-Freigaben nicht. Da gibt#s etlich Gründe dafür und das kommt halt auf dein Server-System an.

Banal könnte es sein, dass kein *.service-file existiert (dann musst du aber in Samba das mdns announcing abschalten), oder dass avahi einfach nicht das entsprechende Netzwerkinterface bedient (openmediavault ist da etwas seltsam konfiguriert, zumindest war das bei mir mal der Fall und hat mir etliche Tage gekostet das raus zu finden)
 
Nein ich sehe den Begriff "Netzwerk" unter "Orte" nicht.
Wenn ich aber unter "Orte" auf meinen Rechner klicke, dann erscheint "Netzwerk" rechts zusammen mit den anderen Platten:

1675162767734.png


Wenn ich dann darauf klicke, ist alles leer.

Wo sollte das service-file sein? Auf dem Mac oder auf den Samba-Servern?
Da es mehrere Server sind, halt ich das für den Server für wenig wahrscheinlich.
OMV läuft da auch nicht - das ist immer nur ein ganz simples Samba, woran auch in den letzten Tagen/Wochen nichts dran geändert wurde.
Bei den anderen Macs im Netz funktioniert das auch alles noch einwandfrei - nur beim Studio nicht.
 
Nein ich sehe den Begriff "Netzwerk" unter "Orte" nicht.

und du bist sicher, dass du die Orte auch eingeblendet hast. gehe mal mit der Maus auf das Wort Orte und warte kurz. dann kannst du ein "einblenden" oder ein Dreieck sehen. (bin gerade nicht am Mac)

Mach mal nen screenshot, wenn du Maus über dem Wort Orte steht
 
Jaja.. da ist schon alles eingeblendet - sonst würde ich ja meinen Rechner auch nicht sehen:
1675165406129.png

In den Finder-Einstellungen für die Seitenleiste sollte auch alles richtig gesetzt sein:

1675165467120.png
 
... öffne mal die Finder-Einstellungen mit der Seitenleiste und dann mach über das Apfel-Menu -> Sofort beenden -> Finder
 
So.. hab eben mal versucht, mich mit einem anderen User anzumelden.. und siehe da: da sehe ich das Netzwerk.
Und als ich mich dann wieder mit meinem normalen User angemeldet habe, war auch dort das Netzwerk wieder zu sehen.

Zweitbester Fall in der IT: es geht und man weiß nicht warum.

Vielen dank trotzdem für die Unterstützung
 
Zurück
Oben Unten