film.avi --> film.ts mit untertitel wie?

Dieses Thema im Forum "Sonstige Multimedia Hard- und Software" wurde erstellt von mollerboller, 14.03.2008.

  1. mollerboller

    mollerboller Thread Starter MacUser Mitglied

    Beiträge:
    27
    Zustimmungen:
    1
    Mitglied seit:
    28.02.2006
    also ich habe eine datei

    film.avi auf englisch auf meinem Computer

    mit ffmpegx auf mpeg.ts codiert

    diese datei via netzwerk auf meine festplatte in der satbox geschickt und geguckt ! soweit so gut funktioniert....!


    jetzt aber möchte ich noch untertitel (in deutsch) hinzufügen.

    sprich: eine datei untertitel.srt der datei film.ts beim codieren hinzufügen klappt leider nicht.....


    auf dem computer untertitel.srt und film.avi funktioniert einwandfrei solange die beiden im selben ornder sind...

    jemand eine idee ?

    gruss m
     
  2. mollerboller

    mollerboller Thread Starter MacUser Mitglied

    Beiträge:
    27
    Zustimmungen:
    1
    Mitglied seit:
    28.02.2006
    hallo?
     
  3. mollerboller

    mollerboller Thread Starter MacUser Mitglied

    Beiträge:
    27
    Zustimmungen:
    1
    Mitglied seit:
    28.02.2006
    hallo?
     
  4. rudolf07

    rudolf07 MacUser Mitglied

    Beiträge:
    130
    Zustimmungen:
    20
    Mitglied seit:
    30.09.2007
    Habe mal deine beschriebene "Versuchsanordnung" nach gebaut. Also ein normales .avi-File (xvid), englisch und deutsche Subs (.srt). Benutze wie du FFmpeg, die ensprechende .srt habe ich unter Filter markiert und die weiteren Einstellungen auf default gelassen. Nachfolgende Bilder zeigen meine Einstellungen. Jetzt rechnet der Apfelknecht!
    Fröhliche Ostern! :cake:
    Update: Geht nicht, Mist!
     

    Anhänge:

  5. McHard

    McHard MacUser Mitglied

    Beiträge:
    585
    Zustimmungen:
    77
    Mitglied seit:
    29.11.2006
    So wie es scheint, kann ffmpeg keine separaten Untertitel (aus .srt) in die .ts Datei einfügen.:rolleyes:
    Das funktioniert wohl nur mit mpeg2enc (in ffmpegX) mit der Option "Mit mplayer dekodieren".
    Die Untertitel werden dann jedoch permanent ins Bild gerendert.

    Erstelle also zuerst aus AVI und .srt Datei eine DVD oder mpeg2 mit mpeg2enc
    (Unter Ziel: DVD mpeg2enc)
    -Die .srt Untertitel unter "Filter" > "load subs" hinzufügen.
    -Mit "Play" prüfen ob sie korrekt erkannt werden.
    -Unter Optionen: "Mit mplayer dekodieren" auswählen.

    Die DVD oder mpeg2 Datei mit MPEG Streamclip anschl. in eine .ts Datei konvertieren.

    Gruss
     
  6. tuxie

    tuxie MacUser Mitglied

    Beiträge:
    73
    Zustimmungen:
    0
    Mitglied seit:
    16.07.2004
    Hallo
    Ich habe das mit ffmpegX probiert und es geht einfach nicht das die Untertitel im Film sind.
    Ich habe auf dem Desktop einen Ordner wo der Film (avi) und die Untertitel Datei (.srt) drin sind.
    Ich habe den Film ausgewählt und dann alles für die Untertiteldatei : bei Untertitel häckchen gemacht, Textcodierung ASCII, .srt ausgewählt, unter Optionen mit mplayer dekodieren.
    Was mache ich falsch oder fehlt bei dem Film etwas, was kann ich noch machen?

    Gruss Tuxie
     
  7. mollerboller

    mollerboller Thread Starter MacUser Mitglied

    Beiträge:
    27
    Zustimmungen:
    1
    Mitglied seit:
    28.02.2006
    gute frage bin auch noch nicht weiter
     
  8. tuxie

    tuxie MacUser Mitglied

    Beiträge:
    73
    Zustimmungen:
    0
    Mitglied seit:
    16.07.2004
    kann es sein das in dem avi irgendwelche zeitcodes fehlen das er das bei mir nicht erkennt?
     
  9. tuxie

    tuxie MacUser Mitglied

    Beiträge:
    73
    Zustimmungen:
    0
    Mitglied seit:
    16.07.2004
    NOSP_KEY
    das kommt wenn ich versuch es trotzdem zu Codieren
     
  10. McHard

    McHard MacUser Mitglied

    Beiträge:
    585
    Zustimmungen:
    77
    Mitglied seit:
    29.11.2006
    Die deutsche Option "Untertitel" (VOB Subtitles) ist etwas irreführend. Hiermit erzwingt man nur die Möglichkeit direkt von einer DVD oder VOB-Datei Untertitel zu nutzen (Burn) oder in andere Formate zu konvertieren (.sub zu .srt oder .idx). Diese Funktion erwartet eine bestimmte Struktur oder Format, in der die Untertitel vorliegen müssen, welche bei einem AVI so nicht vorhanden ist.

    in diesem Fall (AVI) ist es nicht notwendig die Funktion "Untertitel" zu aktivieren.

    Es ist eigentlich ausreichend die .srt Datei nur zu laden (unter "Laden" oder "Load subs). Um zu prüfen, ob die Untertiteldatei erkannt wurde, über "Play"
    den Film abspielen, was jedoch noch nicht auf eine erfolgreiche Enkodierung schließen lässt!

    Nur mit der Option "Mit MPlayer dekodieren" wird der Untertiteltext direkt auf den Film gerendert, ohne diese Option wird der autorisierten DVD einfach eine Untertitel-Textdatei hinzugefügt. Diese Untertitel lassen sich dann bei einer DVD im Player wahlweise ein-oder ausblenden.

    Wenn man also vor hat, die Untertitel direkt auf den Film zu rendern, ist es auch wichtig, dass die Funktion "Burn" eingestellt ist.

    Auf der Homepage von ffmpeX gibt es weitere Infos.

    Habe jetzt eine ganze Weile versucht eine Untertitelspur (.srt) auf den Film zu Rendern, ohne Erfolg. Habe dann die Film- und die Untertiteldatei mit gleichem Namen versehen (keine Umlaute oder Sonderzeichen verwenden), und in den selben Ordner verschoben, dann von ffmpegX, die deutsche Lokalisierung deaktiviert (nur noch die die Englische aktiviert, über Apfel-I). Programm neugestartet, danach hat es funktioniert...:confused:

    Hier eine kurze Untertitel Datei (.srt) zum Testen. Text in TextEdit kopieren , in reinen Text umwandeln und dann mit der Endung .srt speichern.

    1
    00:00:05,200 --> 00:00:10,549
    TEXT BEI 5 SEKUNDEN

    2
    00:00:11,479 --> 00:00:15,549
    TEXT BEI 11 SEKUNDEN

    3
    00:00:16,479 --> 00:00:20,549
    TEXT BEI 16 SEKUNDEN

    4
    00:00:21,439 --> 00:00:25,840
    TEXT BEI 21 SEKUNDEN

    5
    00:00:26,840 --> 00:00:30,030
    TEXT BEI 26 SEKUNDEN
     
Die Seite wird geladen...

Diese Seite empfehlen