Fehler im Dateisystem

  1. ecksofa

    ecksofa Thread StarterMacUser Mitglied

    Mitglied seit:
    25.10.2005
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,
    folgendes Problem darf ich mein Eigen nennen:

    Vor einiger Zeit habe ich auf meinem iMac (Intel Core Duo) das Mac OS X (mittlerweile 10.4.8) neu installiert. Dabei wurde eine Kopie des alten Systems angelegt.
    Da nun die Neuinstallationfehlerfrei lief, wollte ich die Kopie vom alten System löschen. Dabei blieb ein Verzeichnis übrig, welches laut "ls" etwa 500 MB groß ist, aber keinen Inhalt hat und auf das es noch einen zweiten Hardlink gibt. Die Suche nach weiteren Dateien mit gleichem I-Node blieb jedoch erfolglos.
    Laut "du" belegt das Verzeichnis 0 Byte. Löschen lässt es sich trotzdem nicht, da es laut "rm" nicht leer ist.
    Daraufhin habe ich von der Installations-CD gebootet, und per Festplatten-Dienstprogramm das Volume überprüft.
    Antwort: "Schlüssel nicht sortiert. Das Volume muss repariert werden. Der zugrundeliegende Prozess meldete einen Fehler beim Beenden.".
    Daraufhin Volume reparieren. Bei etwa 1/4 des Statusbalkens kam die
    Antwort: "B-Baum wird wiederhergestellt. ... Das Volume konnte nicht repariert werden. Fehler: Der zugrundeliegende Prozess meldete einen Fehler beim Beenden."
    Seitdem rödelt er nach dem Einschalten bei grauem Bildschirm etwa 1-2 Minuten auf der Platte rum und schaltet sich dann einfach wieder ab.
    Mehrfache Versuche von "Volume reparieren" schlugen alle mit der gleichen Fehlermeldung fehl.

    Frage: Wie komme ich (insofern die Platte nicht kaputt ist) möglichst schnell wieder an meine Daten ran?

    Gruß
    ecksofa
     
    ecksofa, 28.11.2006
  2. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.168
    Zustimmungen:
    3.887
    boote mal in den single user modus mit apfel+s...
    dann der anleitung mit dem fsck folgen
     
    oneOeight, 29.11.2006
  3. ecksofa

    ecksofa Thread StarterMacUser Mitglied

    Mitglied seit:
    25.10.2005
    Beiträge:
    2
    Zustimmungen:
    0
    Im Single-User Mode hat er zwar bei "fsck -fy" auch wieder den Reparaturvorgang abgebrochen, aber danach lies er sich wieder booten. Inwieweit noch alle Daten okay sind, hab ich noch nicht gecheckt. Werd mir jetzt schnellstmöglich eine externe Platte besorgen und ein Backup machen.

    Vielen Dank!

    Hat dieser Vorgang eigentlich irgendwas anderes gemacht, als der Reparaturvorgang vom Festplatten-Dienstprogramm. Oder war das nur Zufall, dass dieses Repair ein bisschen weiter gekommen ist, als die Versuche zuvor?

    ecksofa
     
    ecksofa, 29.11.2006
Die Seite wird geladen...
Ähnliche Themen - Fehler Dateisystem
  1. -wolf-
    Antworten:
    3
    Aufrufe:
    90
  2. guentherkg
    Antworten:
    1
    Aufrufe:
    91
  3. RonSom1976
    Antworten:
    6
    Aufrufe:
    198
    RonSom1976
    25.06.2017
  4. pedram3344
    Antworten:
    1
    Aufrufe:
    182
    Maulwurfn
    13.06.2017
  5. kvn1992
    Antworten:
    3
    Aufrufe:
    769
    Retnueg
    11.09.2015