Externe Festplatte nicht für alle User benutzbar machen

  1. Lofgard

    Lofgard Thread StarterMacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    1.024
    Zustimmungen:
    28
    Hallo!

    Ich weiß, diesen Thread gab es schon, ich finde aber keinen aktuellen (Panther). Falls jemand einen Tip hat, wonach ich suchen soll, wäre ich auch sehr dankbar.

    Also: Ich habe eine externe Firewire Platte mit drei Partitionen die mehr oder weniger immer im System hängen und es sollen nicht alle User darauf zugreifen dürfen. Eigentlich nur ich und sonst keiner.

    Die Zugriffsrechte habe ich mit der Dateiinfo dementsprechend angepasst und Zugriffsrechte werden auf dem Volume nicht ignoriert etc. siehe Screenshot.

    und im Terminal sieht das so aus:

    Last login: Sat Jan 14 12:28:52 on console
    Welcome to Darwin!
    Claudia:~ lof$ cd /volumes
    Claudia:/volumes lof$ ls -l
    total 8
    drwx------ 24 lof unknown 816 13 Jan 17:37 Archiv
    drwx------ 18 lof unknown 612 14 Jan 12:42 Eingang
    lrwxr-xr-x 1 root admin 1 14 Jan 12:28 OSX -> /
    drwxrwxr-t 27 root admin 918 14 Jan 00:15 OSY
    Claudia:/volumes Lofgard$

    Ist doch alles so wie es sein soll (es geht nur um “Archiv” und “Eingang”), aber ander User können immer noch auf die Laufwerke zugreifen und da irgendwas verändern.

    Ich hab im Terminal jetzt noch keine Rechte geändert und habe auch etwas Angst vor “RF” bzw “auf alle Unterobjekte anwenden”, denn wenn die Unterobjekte mal von den Volumes woanders hingehen, sollen ja wieder alle und jeder darauf zugreifen können.

    Danke!
    Lofgard.

    Was jetzt am ehesten hier in die Richtung geht ist das hier:
    http://www.macuser.de/forum/showthread.php?t=12101&highlight=festplatte+benutzer+rechte
    aber das bezieht sich wohl auf 10.2 oder?
    außerdem hilft mir das konkret nicht weiter…
    auch das Anwenden auf alle Unterobjekte brachte nicht den gewünscheten Erfolg…
     

    Anhänge:

    • info.jpg
      Dateigröße:
      58 KB
      Aufrufe:
      23
    Lofgard, 14.01.2006
  2. Lofgard

    Lofgard Thread StarterMacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    1.024
    Zustimmungen:
    28
    Habe die Zeit mal zum Weitersuchen benutzt, aber da gibt es nix… echt.
     
    Lofgard, 14.01.2006
  3. Gerundium

    GerundiumMacUser Mitglied

    Mitglied seit:
    22.10.2005
    Beiträge:
    1.997
    Zustimmungen:
    69
    Sieht auf den ersten Blick richtig aus. Das Problem besteht jedoch darin, dass die Zugriffsrechte auf externen Platten ignoriert werden (Standardeinstellung).

    Die sinnvollste Lösung ist sicher das Anlegen verschlüsselter Images auf den beiden Partitionen. Dann kommst du auch nicht in Schwierigkeiten, wenn ein Spaßvogel die Platte an einen anderen Rechner anschließt.

    Ansonsten kannst du es wahrscheinlich mit "vsdbutil" ("vsdbutil -h" für Erklärungen) hinbiegen.
     
    Gerundium, 14.01.2006
  4. Lofgard

    Lofgard Thread StarterMacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    1.024
    Zustimmungen:
    28
    hm. Danke.

    Usage: vsdbutil [-a path] | [-c path ] [-d path] [-i]
    where
    -a adopts (activates) on-disk permissions on the specified path,
    -c checks the status of the permissions usage on the specified path
    -d disowns (deactivates) the on-disk permissions on the specified path
    -i initializes the permissions database to include all mounted HFS/HFS+ volumes


    …sieht so aus, als wäre i mein Buchstabe. Aber was ist die Permissions Database? Läuft die sowieso?
     
    Lofgard, 14.01.2006
  5. Hamsterbacke

    HamsterbackeMacUser Mitglied

    Mitglied seit:
    30.09.2005
    Beiträge:
    1.464
    Zustimmungen:
    42
    Oder verschlüsselten Ordnern. Genau dafür gibt es sowas.

    Gruß, Gerhard
     
    Hamsterbacke, 14.01.2006
  6. Gerundium

    GerundiumMacUser Mitglied

    Mitglied seit:
    22.10.2005
    Beiträge:
    1.997
    Zustimmungen:
    69
    @Lofgard

    So wie ich das verstehe, ist mit der Option "-i" ein Zurücksetzen in den Standardzustand gemeint (aka Werkseinstellungen), entspricht also dem Löschen aller vorgenommenen Änderungen innerhalb der Datenbank.
    Das könnte man vor dem Aktivieren ("-a") laufen lassen.

    @Hamsterbacke
    So oder so, Hauptsache verschlüsselt.
     
    Gerundium, 14.01.2006
  7. Lofgard

    Lofgard Thread StarterMacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    1.024
    Zustimmungen:
    28
    also so:

    Claudia:~ lofgard$ sudo vsdbutil -a /volumes/Eingang

    bewirkt aber gar nichts. Andere Benutzer können immer noch auf das Laufwerk zugreifen.

    Tut mir leid, aber mit dem Terminal hab ich es nicht so.

    Verschlüsseln muß jetzt nicht sein. Es geht mir nur darum, andere Benutzer vom versehentlichen Verändern der Laufwerksinhalte abzuhalten.

    obwohl:

    Claudia:~ lofgard$ sudo vsdbutil -c /volumes/Eingang

    sagt:

    Permissions on '/volumes/Eingang' are enabled.

    Werd mal neustarten.
    Neustart hat auch nichts gebracht. Ja wie denn? Permissions sind enabled aber trotzdem kann ein anderer Benutzer auf dem Volume munter Dateien löschen.

    Stand ist:

    Claudia:/volumes lofgard$ ls -l
    total 8
    drwx------ 24 lof unknown 816 13 Jan 17:37 Archiv
    drwx------ 18 lof unknown 612 14 Jan 18:44 Eingang
    lrwxr-xr-x 1 root admin 1 14 Jan 19:11 OSX -> /
    drwxrwxr-t 27 root admin 918 14 Jan 14:45 OSY
    Claudia:/volumes lofgard$
     
    Lofgard, 14.01.2006
  8. Gerundium

    GerundiumMacUser Mitglied

    Mitglied seit:
    22.10.2005
    Beiträge:
    1.997
    Zustimmungen:
    69
    Und wenn du vorher die Datenbank zurück setzt?

    --
    Mal zum Verständnis
    Es sei:
    lofgard : Admin
    secundo : Normaler Benutzer
    lofgard aktiviert innerhalb seines Accounts die Zugriffsrechte

    Was zeigt denn das Informationsfenster bezüglich Ignorieren von Zugriffsrechten an, wenn secundo eingeloggt ist und das Informationsfenster zur Festplatte öffnet?
     
    Gerundium, 14.01.2006
  9. Lofgard

    Lofgard Thread StarterMacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    1.024
    Zustimmungen:
    28
    So. Operation geglückt. Ich habe die Rechte über Dateiinfo aus dem Useraccount abgestellt, der die Rechte nicht haben soll. Fertig.

    Die Informationen des anderen Users zeigten ihn selber als Besitzer der Laufwerke.

    Danke für die Hilfe!
     
    Lofgard, 14.01.2006
  10. Gerundium

    GerundiumMacUser Mitglied

    Mitglied seit:
    22.10.2005
    Beiträge:
    1.997
    Zustimmungen:
    69
    Eben.

    Jetzt dürfte der User die Partition auch nicht mehr sehen, richtig?
     
    Gerundium, 14.01.2006
Die Seite wird geladen...
Ähnliche Themen - Externe Festplatte alle
  1. iKiel
    Antworten:
    6
    Aufrufe:
    197
  2. VatroxVamu
    Antworten:
    3
    Aufrufe:
    130
    oneOeight
    14.07.2017
  3. brammler
    Antworten:
    7
    Aufrufe:
    1.427
    brammler
    18.08.2011
  4. begga
    Antworten:
    1
    Aufrufe:
    441
    BirdOfPrey
    24.03.2008
  5. splintah
    Antworten:
    2
    Aufrufe:
    2.036
    splintah
    20.01.2006