Excel - wverweis problem!

deko

Mitglied
Thread Starter
Mitglied seit
31.07.2006
Beiträge
190
moin!
also ich versuche grade in excel mit wverweis ein problem zu lösen, kriege es aber nicht hin und verstehe nicht was hier hackt!?

vereinfacht anbei die tabelle samt funktion
Bild 3.png

leider erhlate ich nur #NV, anstatt von der aussage "Alt" !
--> wverweis soll mir eigentlich den wert 1 vergleichen (suchkriterium A3), dann die matrix durchforsten (C2:E5) , falls es den vergleichswert dort findet die zeile 1 ausgeben (zeilenindex 1) und das nur exakt (also: falsch)

wieso funktioniert das nicht, was mache ich falsch?

danke für eure hilfe!
gruss,
deko
 

donhulio

Mitglied
Mitglied seit
06.06.2005
Beiträge
608
so wie du die formel eingegeben hast sucht sie in der 1. zeile der matrix c2:e5 nach "1". und würde dir wenn in der zeile eine "1" vorkäme den inhalt der 1. zeile (das wäre dann wieder "1" ;-)) zurückgeben..
die formel ist komplett falsch..
 

MacTom

Mitglied
Mitglied seit
22.07.2007
Beiträge
194
Im Anhang mal eine mögliche Lösung des Problems.
Leider habe ich hier im Büro nur sehr unzureichende Mittel zur Verfügung.
Das Koordinatensystem musst du dir dazu denken ;)
 

Anhänge

deko

Mitglied
Thread Starter
Mitglied seit
31.07.2006
Beiträge
190
Im Anhang mal eine mögliche Lösung des Problems.
Leider habe ich hier im Büro nur sehr unzureichende Mittel zur Verfügung.
Das Koordinatensystem musst du dir dazu denken ;)
DANKE MACTOM! ...das sieht schon ziemlich gut aus und hab ich als total leie auch verstanden ;) ... geht das aber auch, wenn die "ausgabe" (alt,jung,etc) nicht seitlich links steht, sondern wie in meinem beispiel oben? - das ist nämlich der fall in der bestanddatei.
 

MacTom

Mitglied
Mitglied seit
22.07.2007
Beiträge
194
Naja, der WVERWEIS sucht waagerecht, der SVERWEIS senkrecht.
Für deine Matrix ist der SVERWEIS besser.
Die Titel (alt, jung, neu) lese ich ja mit der WENN Funktion aus. Ist also eigentlich egal, wo die stehen.
Hier nochmal die Exteltabelle (nachdem ich ein Programm für Screenshots für meinen Rechenknecht im Büro gefunden habe ;) )

excel1.png
 

deko

Mitglied
Thread Starter
Mitglied seit
31.07.2006
Beiträge
190
die zahlen 1,2 und 3 in den verweisklammern stehen doch für die spalten d,e und f, oder?

..ich denke/hoffe ich habe deine erklärung für meinen fall richtig umgesetzt (siehe fotos), das ganze ist etwas komplizierter, da auf 2 sheets und grösseren bereichen.. - aber eigentlich stimmt´s doch, oder?
-->excel liest mir nur die erste spalte korrekt aus wie im foto ( = eröffnungsfeier..) , wenn ich den suchwert "001" in der "tech"spalte einsetze, erhalte ich als ergebnis #NV. wenn ich nix eingebe übriegens auch.
Bild 1.jpg Bild 6.png
 

MacTom

Mitglied
Mitglied seit
22.07.2007
Beiträge
194
Die Zahlen sind der Zeilenindex, also die horizontalen Zeilen in der Matrix (nicht der Tabelle)
Deine Tabelle scheint aber doch eher ein Fall für den SVERWEIS zu sein, oder?

Dass du, wenn du keine Eingabe machst, #NV erhälst ist normal. Um das abzufangen müsstest du eine Option einbauen in der Art: Wenn A3="" dann schreibe "Keine Eingabe"

In der Anlage mal ein Beispiel für den SVERWEIS

excel2.png
 
Zuletzt bearbeitet:

deko

Mitglied
Thread Starter
Mitglied seit
31.07.2006
Beiträge
190
Deine Tabelle scheint aber doch eher ein Fall für den SVERWEIS zu sein, oder?
ja, und in dem beispiel was ich vorgehend angehangen habe, habe ich den Sverweis ja auch genutzt! also selbst interpretiert nach deinem beispiel von gestern mittag.
hast du dir die lange formel von mir mal angesehen? ..wo da der fehler liegen könnte? ich finde ihn nicht!

---vielleicht ist auch nicht ganz klar, was ich eigentlich machen will!? :
in der tabelle "timetable" werden 3stellige nummer eingegeben, die symbolisch für freiwillige helfer stehen.
in der tabelle "volunteers" sollen nun sortiert nach den nummer "001 , 002, 003, ...." die entsprechenden arbeiten der freiwilligen (hier eröffnunsgparty zb) aufgelistet werden, mit tag und uhrzeit. -----> den "response" ERÖFFNUNG gibt er mir ja schon wie man sehen kann, aber wenn ich 001 in die 2.spalte TECH eingebe, kommt halt trotz der (richtigen??)formel ein #nv bei raus und nicht als response TECH.
 
Zuletzt bearbeitet:

deko

Mitglied
Thread Starter
Mitglied seit
31.07.2006
Beiträge
190
formel update

also das ist jetzt meine aktuelle formel, um die ersten 3 spalten nach "001" zu durchforsten:

=WENN(SVERWEIS(volunteers!A4;timetable!O3:O7;1;FALSCH)=volunteers!A4;timetable!O2;WENN(SVERWEIS(volunteers!A4;timetable!P3:p7;1;FALSCH)=volunteers!A4;timetable!P2;WENN(SVERWEIS(volunteers!A4;timetable!Q3:Q7;1;FALSCH)=volunteers!A4;timetable!Q2;"nix")))

es liest die splate O einwandfrei, spalte P und Q hingegen nicht; fehler #NV

ich raffs einfach nicht :confused:
 

deko

Mitglied
Thread Starter
Mitglied seit
31.07.2006
Beiträge
190
es muss irgendwas mit der verschachtelung von WENN und SVERWEIS zu tun haben!
bis zu dem 1. punkt SONST_WERT, scheint die formel gut zu funktionieren, aber egal was dahinter kommt wird zu #NV .

wieso?? kann man die beiden nicht kombinieren?? oder was mache ich falsch???


HHIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIILLLFEEEEEEEEEEEEEEEEEEEEEEEEEEE :confused:
 
Oben