Benutzerdefinierte Suche

Excel macht schlapp!!!

  1. WiKainZwaida

    WiKainZwaida Thread StarterMacUser Mitglied

    Mitglied seit:
    21.04.2006
    Beiträge:
    131
    Zustimmungen:
    0
    Hy!


    Vorwort:

    Kann leider nicht prüfen, ob es sich bei meinem Problem um eine Eigenheit des Mac OS Excel handelt. Benutze das Programm schon seit Ewigkeiten ohne Probleme, aber erst seit kurzem und seither ausschließlich auf meinem Mac.


    Schilderung:

    In meiner aktuellen Excel-Datei sind einige Formeln leider recht lang geraten (dafür ist anschließend die Bedienung so komfortabel :) ). Seit meinem lecker Mittagessen (also 14 Uhr => über 5 Stunden) rätselte ich nun, weshalb einige trotz korrekter Eingabe nicht funktionierten. Ließ man Teile von ihnen in anderen Zellen berechnen und verwies auf diese, funktionierte die Sache schnörkellos. Aber baute man die komplette Formel in eine Zelle, tauchten Fehlermeldungen auf.


    The Answer:

    Ab einer bestimmten Anzahl geöffneter Klammern (in meinem Fall 8), macht Excel schlapp.

    Beispiel:

    =WENN(1=1;WENN(2=2;WENN(3=3;WENN(4=4;WENN(5=5;WENN(6=6;WENN(7=7;WENN(8=8;"Ok!"))))))))

    => funktioniert!

    =WENN(1=1;WENN(2=2;WENN(3=3;WENN(4=4;WENN(5=5;WENN(6=6;WENN(7=7;WENN(8=8;wenn(9=9;"Ok!")))))))))

    => funktioniert nicht! Wie Ihr seht, bleibt der letzte WENN-Befehl auch direkt in Kleinschrift, weil er gar nicht mehr erkannt wird.


    Frage:

    Gibt es eine Lösung und existiert diese Beschränkung auch bei Excel für PC?


    Schöne Grüße und vielen Dank im Voraus!!!
     
    WiKainZwaida, 07.07.2006
  2. WiKainZwaida

    WiKainZwaida Thread StarterMacUser Mitglied

    Mitglied seit:
    21.04.2006
    Beiträge:
    131
    Zustimmungen:
    0
    Oder hab ich nen Virus???

    Dieses Leerzeichen im 5. "WENN" habe ich nicht eingegeben :)

    Das Leerzeichen erschien eben schon in der Vorschau und nun auch im letztendlichen Post.

    Hab extra drauf geachtet!

    Heute versteh ich meinen Rechner nicht :)
     
    WiKainZwaida, 07.07.2006
  3. HäckMäc_2

    HäckMäc_2MacUser Mitglied

    Mitglied seit:
    26.04.2005
    Beiträge:
    4.208
    Zustimmungen:
    288
    Diese Beschränkung gibt es bei Excel2000 (für Win) auch.

    Versuche es doch mal mit der Funktion "Verweis"
     
    HäckMäc_2, 07.07.2006
  4. WiKainZwaida

    WiKainZwaida Thread StarterMacUser Mitglied

    Mitglied seit:
    21.04.2006
    Beiträge:
    131
    Zustimmungen:
    0
    Ok, dann muss ich wohl einen Teil der Formel in ne andere Zelle auslagern... aber irgendwie unpraktisch. Wieso diese Beschränkung???

    Wegen dem Tip mit Verweis... so sieht des Dingen aus :)

    =
    SUMME(INDIREKT(
    "'"&VERWEIS(C$1;A!$Q$4:$Q$8;A!$P$4:$P$8)&"Wertpapiere'!b"&
    ZEILE(INDEX(INDIREKT("'"&VERWEIS(C$1;A!$Q$4:$Q$8;A!$P$4:$P$8)&"Wertpapiere'!$B$39:$B$48");VERGLEICH("aus Periode "&C1;INDIREKT("'"&VERWEIS(C$1;A!$Q$4:$Q$8;A!$P$4:$P$8)&"Wertpapiere'!$a$39:$a$48");0)))&
    ":"&
    "b"&
    WENN(ZEILE(INDEX(INDIREKT("'"&VERWEIS(C$1;A!$Q$4:$Q$8;A!$P$4:$P$8)&"Wertpapiere'!$B$39:$B$48");VERGLEICH("aus Periode "&C1;INDIREKT("'"&VERWEIS(C$1;A!$Q$4:$Q$8;A!$P$4:$P$8)&"Wertpapiere'!$a$39:$a$48");0)))-7<39;39;ZEILE(INDEX(INDIREKT("'"&VERWEIS(C$1;A!$Q$4:$Q$8;A!$P$4:$P$8)&"Wertpapiere'!$B$39:$B$48");VERGLEICH("aus Periode "&C1;INDIREKT("'"&VERWEIS(C$1;A!$Q$4:$Q$8;A!$P$4:$P$8)&"Wertpapiere'!$a$39:$a$48");0)))-7)))



    Da ist nicht mehr viel mit Optimieren :)

    Leider...


    Vielen Dank für die schnelle Antwort!!
    Schönen Abend an alle!
     
    WiKainZwaida, 07.07.2006
Die Seite wird geladen...
Ähnliche Themen - Excel macht schlapp
  1. Appelmus
    Antworten:
    4
    Aufrufe:
    212
    Appelmus
    13.06.2017
  2. mogano
    Antworten:
    12
    Aufrufe:
    395
  3. Dieschonwieder
    Antworten:
    0
    Aufrufe:
    123
    Dieschonwieder
    24.05.2017
  4. rainer11
    Antworten:
    5
    Aufrufe:
    296
  5. Galinka
    Antworten:
    5
    Aufrufe:
    920
    papalapapp
    04.12.2008