Excel - bestimmte Zeilen addieren per WENN DANN

S

StruppiMac

Aktives Mitglied
Thread Starter
Dabei seit
18.05.2006
Beiträge
2.862
Punkte Reaktionen
39
Hi,
ich habe eine Excel-Liste, in der viele Zeilen sind die so aufgebaut sind:

DATUM, BETRAG, EINGANG/AUSGANG

Ich möchte nun in einer extra Zelle die Summe aller Beträge für alle Zeilen geben, in der bei EINGANG/AUSGANG "EINGANG" steht.

Per WENN DANN müsste es gehen, geht aber nur für eine Zeile. Oder gib es da eine Eingene Funktion?

Gruß und Danke
 
J

joachim14

Aktives Mitglied
Dabei seit
08.02.2005
Beiträge
7.294
Punkte Reaktionen
436
Du legst doch eine Rechenformel so fest, dass das Ergebnis in einer Zelle auftaucht.
Die Rechenformel kann aber auch kopiert werden und in mehrere andere Zellen eingesetzt werden.
War das die Frage?
 
S

StruppiMac

Aktives Mitglied
Thread Starter
Dabei seit
18.05.2006
Beiträge
2.862
Punkte Reaktionen
39
Ja, aber ich will nur 1 Summenfeld - wenn ich die Formel kopiere, dann Summiert er mit ein Betrag einer Zeile in eine Zelle - die 2. Zeile dann in eine andere Zelle usw.

DATUM, BETRAG, EINGANG/AUSGANG
11.1.99, 12, EINGANG
12.1.99, 10, EINGANG
14.1.99, 20, AUSGANG

Jetzt hätte ich gern eine Zelle: EINGÄNGE und die soll 22 enthalten.

Wenn ich mit WENN DANN arbeite, kann ich nur sagen "WENN in C1 = EINGANG DANN ZELLE2 = 12" - ich benötige aber eine Art "Zähle alle Beträge zusammen, in denen hintendran EINGANG steht" - nur das bekomme ich mit WENN DANN nicht hin
 
M

morena

unregistriert
Dabei seit
10.05.2006
Beiträge
67
Punkte Reaktionen
1
StruppiMac schrieb:
DATUM, BETRAG, EINGANG/AUSGANG
11.1.99, 12, EINGANG
12.1.99, 10, EINGANG
14.1.99, 20, AUSGANG

Hallo!

Des Rätsel's Lösung ist die Funktion SUMMEWENN. :)

Ich nehme mal zur Erklärung folgende Aufteilung an:
  • Spalte A = Datum
  • Spalte B = Betrag
  • Spalte C = Kategorie (also Eingang/Ausgang)

Bei der Verwendung der Funktion SUMMEWENN musst du 3 Dinge definieren:

  1. Bereich: Das sind alle Zeilen in der Spalte C, die die Kategorie enthalten.
  2. Suchkriterium: Entweder eine Zelle, in der "Eingang" steht oder der Text "Eingang". Wenn du ihn tippst, die " bitte nicht vergessen.
  3. Summe_Bereich: Alle Zeilen in der Spalte A, die die Zahlen enthalten.

Könnte also so aussehen:

=SUMMEWENN(C2:C4;"EINGANG";B2:B4)

HTH. ;)
/morena
 
S

StruppiMac

Aktives Mitglied
Thread Starter
Dabei seit
18.05.2006
Beiträge
2.862
Punkte Reaktionen
39
SUMMEWENN :faint: Das was's
Danke!! Ich dachte, dass war WENN - aber war SUMMEWENN *uff*
 
M

morena

unregistriert
Dabei seit
10.05.2006
Beiträge
67
Punkte Reaktionen
1
StruppiMac schrieb:
SUMMEWENN :faint: Das was's
Danke!! Ich dachte, dass war WENN - aber war SUMMEWENN *uff*

WENN... DANN... ist eh knapp dran, kann aber keinen Bereich durchsuchen.
:)

Und entschuldige die langatmige Erklärung, ich wollte sicher sein, dass man das "schriftlich" auch noch versteht.

Freut mich, dass ich helfen konnte.
Schönen Abend!

/morena
 

Ähnliche Themen

I
Antworten
4
Aufrufe
458
IReacT
I
B
Antworten
80
Aufrufe
2.654
tbo
I
Antworten
6
Aufrufe
328
ischbins
I
Oben