ettercap Problem

  1. pfannkuchen2001

    pfannkuchen2001 Thread StarterMacUser Mitglied

    Mitglied seit:
    17.02.2006
    Beiträge:
    2.421
    Zustimmungen:
    37
    Hallo,

    ich habe ettercap ettercap NG-0.7.3 via finkinstalliert, und es läuft prima - keinerlei compilier probleme. selbst die GTK Gui läuft.
    nun aber zu meinem Problem:
    wenn ich anfange zu scannen (arp) dann bekomme ich tausende errormessages wie diese hier:
    Code:
    SEND L3 ERROR: 28 byte packet (0800:01) destined to 192.168.11.4 was not forwarded (libnet_write_raw_ipv4(): -1 bytes written (Invalid argument)
    was ist da falsch? hat jemand eine ahnung?
    ich hab schon google, http://ettercap.sourceforge.net/ und insecure.org abgesucht, aber ohne erfolg.

    ich habe 10.4.8 am laufen...

    also: vorschläge?
     
    pfannkuchen2001, 06.12.2006
  2. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.163
    Zustimmungen:
    3.887
    für raw packages muss man root sein, d.h. starte es mal mit sudo...
     
    oneOeight, 06.12.2006
  3. pfannkuchen2001

    pfannkuchen2001 Thread StarterMacUser Mitglied

    Mitglied seit:
    17.02.2006
    Beiträge:
    2.421
    Zustimmungen:
    37
    hab ich!

    ich glaube, das es irgendwas damit zu tun hat, das mein kernel raw ips forwardet, und ettercap auch?
    --> noch andere vorschläge?

    Hannes

    PS.: ich hab ne intelmaschine, macht das vielleicht (mal wieder) probleme? eher nicht oder?
    PPS.:
    ettercap sagt folgendes:
    hilft das?
     
    pfannkuchen2001, 06.12.2006
  4. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.163
    Zustimmungen:
    3.887
    dann guck mit sysctl halt nach...
     
    oneOeight, 06.12.2006
  5. pfannkuchen2001

    pfannkuchen2001 Thread StarterMacUser Mitglied

    Mitglied seit:
    17.02.2006
    Beiträge:
    2.421
    Zustimmungen:
    37
    hmm
    ich weis nicht so recht, aber
    bedeutet doch, das er das nicht tut?

    noch ne idee?

    EDIT ach neee, ipv4.... ...hmm dazu steht nix da.
     
    pfannkuchen2001, 06.12.2006
  6. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.163
    Zustimmungen:
    3.887
    net.inet.ip.forwarding: 0
    net.inet.ip.fastforwarding: 0

    taucht bei dir nicht auf? ;)
     
    oneOeight, 06.12.2006
  7. pfannkuchen2001

    pfannkuchen2001 Thread StarterMacUser Mitglied

    Mitglied seit:
    17.02.2006
    Beiträge:
    2.421
    Zustimmungen:
    37
    doch, tuts.

    also alles eigendlich richtig, also falscher lösungsansatz...
    andere idee?
     
    pfannkuchen2001, 06.12.2006
  8. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.163
    Zustimmungen:
    3.887
    tja, arp poisoning aka spoofing ist ja auch böse und das soll man nicht ;)
     
    oneOeight, 06.12.2006
  9. pfannkuchen2001

    pfannkuchen2001 Thread StarterMacUser Mitglied

    Mitglied seit:
    17.02.2006
    Beiträge:
    2.421
    Zustimmungen:
    37
    hmm
    das ist doch aber keine lösung eines Problems?!
    und so lange ich das mit meinen eigenen rechnern mache, ist das alles andere als böse!

    Hannes
     
    pfannkuchen2001, 06.12.2006
  10. blackpirat

    blackpiratMacUser Mitglied

    Mitglied seit:
    26.09.2006
    Beiträge:
    69
    Zustimmungen:
    0
    Hallo, ich bin ein Newbee im Umgang mit MacOSX. Wie installiere ich Fink und Ettercap? Besten Dank für eure Tipps...
     
    blackpirat, 26.12.2006
Die Seite wird geladen...