1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ethereal Probleme.

Dieses Thema im Forum "Mac OS - Unix & Terminal" wurde erstellt von dabegi, 06.07.2005.

  1. dabegi

    dabegi Thread Starter MacUser Mitglied

    Mitglied seit:
    29.06.2005
    Beiträge:
    553
    Zustimmungen:
    67
    Hallo an alle.

    Hoffe mal ihr habt lust einen Unix Noob wie mir weiter zu helfen...

    Also mein Mac OS Tiger ist mit X11 installiert worden. Jetzt würde ich dringend Ethereal brauchen also hab ich gelesen das das am einfachsten mit Fink geht... Gut Fink heruntergeladen, installiert und über den Fink Commander Ethereal installiert...

    Dann Xterm aufgemacht... als su eingeloggt und /sw/bin/ethereal eingeben...

    Dann kommt folgender Fehler:

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified


    (ethereal:17480): Gtk-WARNING **: cannot open display:



    Wie gesagt ich kenn mich in Unix so gut wie gar ned aus...

    Kann mir vielleicht jemand helfen?

    mfg Begi
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.705
    Zustimmungen:
    4.042
    xhost +localhost
     
  3. dabegi

    dabegi Thread Starter MacUser Mitglied

    Mitglied seit:
    29.06.2005
    Beiträge:
    553
    Zustimmungen:
    67
    Sorry aber was meinst du damit...

    Wie ich oben schon 2 mal geschrieben habe: Unix Anfänger... sorry
     
  4. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.705
    Zustimmungen:
    4.042
    das sollst du im xterm tippen, bevor du du /sw/bin/ethereal tippst...
     
  5. dabegi

    dabegi Thread Starter MacUser Mitglied

    Mitglied seit:
    29.06.2005
    Beiträge:
    553
    Zustimmungen:
    67
    begibook:/Users/Begi root# xhost +localhost
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    xhost: unable to open display ":0.0"
     
  6. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.705
    Zustimmungen:
    4.042
    probier das mal vor dem su...
     
  7. dabegi

    dabegi Thread Starter MacUser Mitglied

    Mitglied seit:
    29.06.2005
    Beiträge:
    553
    Zustimmungen:
    67
    hast recht vor dem su geht es ...

    nur beim starten von ethereal bekomm ich dann (egal ob su oder nicht) einen haufen fehler...

    (ethereal:19295): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported

    (ethereal:19295): Gdk-CRITICAL **: file gdkpixbuf-render.c: line 293 (gdk_pixbuf_render_pixmap_and_mask_for_colormap): assertion `GDK_IS_PIXBUF (pixbuf)' failed

    ** (ethereal:19295): WARNING **: No builtin or dynamically loaded modules
    were found. Pango will not work correctly. This probably means
    there was an error in the creation of:
    '/sw/etc/pango/pango.modules'
    You may be able to recreate this file by running pango-querymodules.

    (ethereal:19295): GLib-GObject-CRITICAL **: file gobject.c: line 1561 (g_object_ref): assertion `G_IS_OBJECT (object)' failed

    ** (ethereal:19295): CRITICAL **: file pango-engine.c: line 68 (_pango_engine_shape_shape): assertion `PANGO_IS_FONT (font)' failed

    ** ERROR **: file shape.c: line 75 (pango_shape): assertion failed: (glyphs->num_glyphs > 0)
    aborting...
    Abort trap






    Weißt du dazu vielleicht auch noch was?
     
  8. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.705
    Zustimmungen:
    4.042
    da stimmt was nicht mit pango bzw dem gtk...
    hat fink die ganzen pakete mit installiert und hast du den richtigen X11 placeholder gewählt in fink?
     
  9. dabegi

    dabegi Thread Starter MacUser Mitglied

    Mitglied seit:
    29.06.2005
    Beiträge:
    553
    Zustimmungen:
    67
    hab mal die pango sachen im fink nachinstalliert... Jetzt startet Ethereal ganz kurz und dann kommt:



    begibook:~ Begi$ /sw/bin/ethereal

    (ethereal:20047): GdkPixbuf-WARNING **: Can not open pixbuf loader module file '/sw/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (ethereal:20047): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported

    (ethereal:20047): Gdk-CRITICAL **: file gdkpixbuf-render.c: line 293 (gdk_pixbuf_render_pixmap_and_mask_for_colormap): assertion `GDK_IS_PIXBUF (pixbuf)' failed

    (ethereal:20047): GdkPixbuf-WARNING **: Can not open pixbuf loader module file '/sw/etc/gtk-2.0/gdk-pixbuf.loaders': No such file or directory

    (ethereal:20047): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported

    ** ERROR **: file toolbar.c: line 192 (ethereal_stock_icons): assertion failed: (pixbuf)
    aborting...
    Abort trap




    Ich hab nichts anderes gemacht als um obersten beitrag... Also placeholder keine Ahnung...

    Hoffe ich strapaziere dich noch nicht zu viel. Hoffe du kannst mir noch einmal weiter helfen!
     
  10. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.705
    Zustimmungen:
    4.042
    ist wohl eher ein problem der configuration.
    probier mal das "pango-querymodules" aus...