Entfernte Anmeldung / SSH geht nicht mehr

  1. floura

    floura Thread Starter

    Hallo werte Community,
    ich wollte mich letztens mal wieder über ssh auf meinem iBook anmelden. Doch es kommt immer die Fehlermeldung: "Connection closed by 192.168.178.21"
    In dem Systemeinstellungen ist es aktiviert und in der Firewall auch. Leider kann ich nicht sagen seit wann es nichtmehr geht da ichs schon länger nichtmehr gebraucht hab.

    Ich hoffe ihr könnt mir helfen...

    Gruß floura
     
    floura, 10.03.2007
  2. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    benutze doch einmal beim verbinden den Schalter -v (oder sogar -vv).
    Dann kommen Statusmeldungen aus denen man vielleicht die Ursache ablesen kann.

    Welche Systeme laufen auf den beteiligten Rechnern?
     
    maceis, 10.03.2007
  3. floura

    floura Thread Starter

    Code:
    web26@dach:/$ ssh -vv floura@192.168.178.21
    OpenSSH_4.2p1 Debian-7ubuntu3.1, OpenSSL 0.9.8a 11 Oct 2005
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to 192.168.178.21 [192.168.178.21] port 22.
    debug1: Connection established.
    debug1: identity file /home/web26/.ssh/identity type -1
    debug1: identity file /home/web26/.ssh/id_rsa type -1
    debug1: identity file /home/web26/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.2
    debug1: match: OpenSSH_4.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.2p1 Debian-7ubuntu3.1
    debug2: fd 3 setting O_NONBLOCK
    debug1: SSH2_MSG_KEXINIT sent
    Connection closed by 192.168.178.21
    
    auf dem iBook auf das ich zugreifen will: OS X 10.4.8
    und auf den Rechner von dem ich zugreifen will: Ubuntu
     
    floura, 10.03.2007
  4. Zapfenzieher

    ZapfenzieherMacUser Mitglied

    Mitglied seit:
    31.01.2007
    Beiträge:
    356
    Zustimmungen:
    20
    Gib mal "route" ein und poste das Ergebniss.
     
    Zapfenzieher, 11.03.2007
  5. floura

    floura Thread Starter

    Code:
    web26@dach:~$ route
    Kernel IP Routentabelle
    Ziel            Router          Genmask         Flags Metric Ref    Use Iface
    10.8.0.2        *               255.255.255.255 UH    0      0        0 tun0
    192.168.178.0   *               255.255.255.0   U     0      0        0 eth1
    10.8.0.0        10.8.0.2        255.255.255.0   UG    0      0        0 tun0
    default         fritz.box       0.0.0.0         UG    0      0        0 eth1
    
     
    floura, 11.03.2007
  6. floura

    floura Thread Starter

    Falls es hilft, folgendes wird ausgegeben wenn ich mich von meinem iBook aus nochmal anmelden will mit "ssh localhost":

    Code:
    sgw:~ floura$ ssh -vv localhost
    OpenSSH_4.2p1, OpenSSL 0.9.7l 28 Sep 2006
    debug1: Reading configuration data /etc/ssh_config
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to localhost [::1] port 22.
    debug1: Connection established.
    debug1: identity file /Users/floura/.ssh/identity type -1
    debug1: identity file /Users/floura/.ssh/id_rsa type -1
    debug1: identity file /Users/floura/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.2
    debug1: match: OpenSSH_4.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.2
    debug2: fd 3 setting O_NONBLOCK
    debug1: An invalid name was supplied
    Configuration file does not specify default realm
    
    debug1: An invalid name was supplied
    A parameter was malformed
    Validation error
    
    debug1: An invalid name was supplied
    Configuration file does not specify default realm
    
    debug1: An invalid name was supplied
    A parameter was malformed
    Validation error
    
    debug1: SSH2_MSG_KEXINIT sent
    Read from socket failed: Connection reset by peer
     
    floura, 11.03.2007
  7. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Schalt mal Dein VPN ab und schau nach, was dann passiert.
     
    maceis, 11.03.2007
  8. floura

    floura Thread Starter

    es passiert nichts:(
    VPN war vorher aber auch nicht an. Und ich habe es noch an einigen anderen Rechnern getestet mich an meinem iBook anzumelden. Ist überall das selbe. Kann also eigentlich auch nix mit dem VPN von dem Ubuntu Rechner zu tun haben...
    Viele Dank schonmal:)

    Hilft eventuell eine Neuinstallation von Mac OS X?
     
    floura, 11.03.2007
  9. Zapfenzieher

    ZapfenzieherMacUser Mitglied

    Mitglied seit:
    31.01.2007
    Beiträge:
    356
    Zustimmungen:
    20
    Anscheinend sind aber immernoch VPN-Einträge in der Routingtabelle. Versuche die mal mit "route del $target" zu löschen.

    edit: Oder den VPN-Dienst aus dem init-Level herausnehmen und neustarten.
     
    Zapfenzieher, 11.03.2007
  10. floura

    floura Thread Starter

    Ah sorry ich glaub das war ein Missverständnis. Ich habe route bei dem Rechner eingegeben von dem aus ich versucht habe mich einzuloggen, nicht an meinem iBook!

    route an dem iBook:
    Code:
    sgw:~ floura$ route    
    usage: route [-dnqtv] command [[modifiers] args]
    Danke für eure Bemühungen.
     
    floura, 11.03.2007
Die Seite wird geladen...
Ähnliche Themen - Entfernte Anmeldung SSH
  1. papa_ingo
    Antworten:
    0
    Aufrufe:
    1.187
    papa_ingo
    26.10.2011
  2. Winter
    Antworten:
    5
    Aufrufe:
    1.258
  3. Gravmac
    Antworten:
    10
    Aufrufe:
    1.069
  4. echolot1210
    Antworten:
    2
    Aufrufe:
    823
  5. celsius
    Antworten:
    1
    Aufrufe:
    943