Eigentümer aktivieren.

kisi

Neues Mitglied
Thread Starter
Mitglied seit
29.10.2006
Beiträge
29
Hallo!
Mein Problem ist, dass mir meine "DATEN" partition nicht mehr angezeigt wird. Im Festplattendiensprogramm wird sie mir allerdings angezeigt. Ich denke, das Problem liegt daran, dass kein Eigentümer aktiviert ist. Wie kann ich den eigentümer für die Festplatte wirder einstellen?
 

Rony23

Neues Mitglied
Mitglied seit
10.12.2010
Beiträge
6
... DAS wüsste ich jetzt gerade im Moment auch gerne! ... ich kann auf keiner meiner 3 internen Festplatten mehr zugreifen. Sie werden zwar angezeigt, aber beim Anklicken der Festplatte wird gesagt, dass ich nicht die Zugriffsrechte habe...

VG
Rony23
 

StarSirius

unregistriert
Mitglied seit
04.01.2010
Beiträge
884
Wenn sie noch angezeigt werden, dann setze doch einfach die Zugriffsrechte. Mit dem Terminal geht das ganz einfach. Einfach als Administrator ein Terminal öffnen "sudo su" ohne "" eingeben, Administratorpasswort wie verlangt eingeben. Bei korrekter Eingabe bist du dann root und darfst somit alle Zugriffsrechte und Eigentümer/Gruppen bei Dateien und/oder Laufwerken ändern. danach mit "cd" in das Verzeichnis "/Volumes" wechseln (also "cd /Volumes" ohne "" eingeben). Dort sollten dann alle Datenträger und Partitionen zu finden sein. Mit "chown" kann dann der Eigentümer bzw. die Gruppe verändert werden und mit "chmod" dann die Zugriffsrechte für Eigentümer, Gruppe und jedermann angepasst werden. Zur Benutzung der Befehle einfach mal "man chown" bzw. "man chmod" eingeben (öffnet den entsprechenden Eintrag im "Handbuch", zum Verlasse einfach "q" drücken). Ach ja, noch eine Warnung: Als root darf man wirklich alles ändern und es wird auch nicht gewarnt, also Befehle lieber dreimal kontrollieren, bevor man diese ausführt. Außerdem wäre es natürlich nicht schlecht, wenn man weiß was der eingegebene Befehl genau bewirkt, nicht dass am Ende eine böse Überraschung wartet.
 

Rony23

Neues Mitglied
Mitglied seit
10.12.2010
Beiträge
6
.. da fängts schon an... wenn ich sudo su eingebe kommt vom system ganz einfach: Sorry. Kann mein Passwort eingeben, sonst passiert nichts...

aber danke schonmal für deinen schnellen rat. hoffe, du weisst auch woran das hier liegt... ?!
 

StarSirius

unregistriert
Mitglied seit
04.01.2010
Beiträge
884
Bitte etwas genauer. Wann kommt die Ausgabe "sorry"? Nach dem Absetzen des Befehls (Eingabe von "sudo su" und Enter drücken) und VOR Eingabe des Passworts, kann es eigentlich nicht sein. Und wenn es nach Eingabe des Passworts passiert (nachdem Enter gedrückt wurde), war das eingegebene Passwort falsch. Es werden bei der Eingabe des Passworts weder das Passwort noch Sterne oder andere Platzhalter angezeigt. Es steht dort einfach "Password:" gefolgt vom Cursor. Also nicht verwirren lassen.
 

madu

Aktives Mitglied
Mitglied seit
16.11.2005
Beiträge
4.681
Mehr passiert auch nicht - Du bist ab diesem Moment root für alle weiteren Befehle.
Höchste Vorsicht in diesem Modus, wenn Du kein Terminal-Crack bist!

Mach besser mal folgendes:
Festplattensymbol anklicken, cmd+i und dann im Infofenster unten gucken was Du (Dein aktueller Benutzer) für Benutzerrechte hast.
Wenn nötig, Deinen Benutzer auf Lesen + Schreiben setzen.

Sollte Dein Benutzername nicht in der Liste stehen, klick auf das "+" (evt. vorher rechts auf das Schloss klicken und identifizieren)
Dann wählst Du in dem neuen Fenster Deinen Benutzer aus und bestätigst.
Im Infofenster gibst Du nun Deinem Benutzer Schreib- + Leserechte.

PS: mit Eigentümer aktivieren (Titel Originalpost) hat das ganze übrigens nichts zu tun, sondern mit Zugriffsrechten
 

Rony23

Neues Mitglied
Mitglied seit
10.12.2010
Beiträge
6
hab jetzt einfach mal, weil ichs irgendwo gelesen habe sh -ls eingegeben, dann gings.
Hab auch schon rausgefunden, dass man den Root-Benutzer in den Verzeichnisdiensten aktivieren kann. Allerdings haben all meine Bemühungen zu KEINEM Ergebnis geführt.

Habe deine sämtlichen tips probiert ... und immer kommt sowas wie "permission denied".

Wenn ich deinen letzteren Tip mit Anklicken und Apfel-i probiere, und versuche die Rechte so zu ändern steht da bei allen Benutzern "Eigene" (System - admin - everyone ... kann meinen Benutzernamen mithilfe des + NICHT hinzufügen). Wenn ich Lesen &Schreiben anklicken möchte, springt es immer wieder zurücl auf "Eigene". Ich verstehe das nicht!
Mir kommts so vor, als ob ich selbst als root nicht alle Rechte hab. Sonst hätte ich ja schon was verändern können. wenn ich z.B: chmod 755 Time Machine-Backups (Natürlich mit "\" nach Time) eingebe, müsste doch was passieren?! Befinde mich natürlich in /Volumes. Dann kommt nur "Unable to change file mode on Time Machine-Backups: Operation not permitted". Wohlgemert als root. Das ist doch nicht normal... bin schon ein bisschen am verzweifeln...

VG
Rony23
 

Rony23

Neues Mitglied
Mitglied seit
10.12.2010
Beiträge
6
... aber "Eigentümer aktivieren" ist genau mein Problem. Im Festplattendienstprogramm sind all meine 3 internen Festplatten - außer die Systemplatte" mit NEIN gekennzeichnet, was "Eigentümer Aktiviert" angeht... ich muss da nur ein JA hinbekommen, und schon bin nich wieder glücklich...
hab auch schon die Option mit Apfel-i auf Festplatte und dann ganz unten bei "Eigentümer auf diesem Volume ignorieren" gemacht... ging auch nicht.
 

madu

Aktives Mitglied
Mitglied seit
16.11.2005
Beiträge
4.681
Mal eine Frage: welches System hast Du und wie sind die Platten formatiert?


Alle meine Platten (intern wie extern) ausser dem Startvolume haben den Eigentümer nicht aktiviert. Das ist imho ausser beim Startvolume die Standarteinstellung...
Eigentümer nicht aktiviert bedeutet, dass jeder darauf zugreifen darf.
 
Zuletzt bearbeitet:

Rony23

Neues Mitglied
Mitglied seit
10.12.2010
Beiträge
6
System: 10.6 ... 10.6.5 lädt gerade runter, weil ich das System neu aufgesetzt hatte. Dachte, so löst sich das Problem...

Alle Festplatten Mac Os X Extended Jornaled. Nur eine nicht Journaled, weil Recording-Festplatte.
 

madu

Aktives Mitglied
Mitglied seit
16.11.2005
Beiträge
4.681
Hier gibts noch einen Beitrag zum Thema Eigentümer mit einem Terminal-Tipp in Beitrag #7
Ich bin aber immer noch der Meinung, dass der Eigentümer nicht aktiviert sein muss.

Allerdings gerate ich hier langsam auf unsicheres Terrain und überlasse das Feld lieber jemandem, der besser Bescheid weiss, bevor ich falsche Tipps gebe. ;)

Auf was ich bei einer kurzen Suche noch gestossen bin ist BatCHmod
Vielleicht hilft das Dir weiter.

Viel Glück und gute Nacht :)
 
Oben