eclipse mit php-unterstützung installieren

Dieses Thema im Forum "Mac OS X Entwickler, Programmierer" wurde erstellt von catvarlog, 24.05.2005.

  1. catvarlog

    catvarlog Thread Starter MacUser Mitglied

    Beiträge:
    1.468
    Zustimmungen:
    1
    MacUser seit:
    30.01.2005
    kennt jemand eine gute doku, welche die installation von eclipse + php-eclipse auf mac os x beschreibt? phpeclipse.de hilft da nicht weiter. habe probleme mit der konfiguration des plug-ins (pfade). herzlichen dank für jede hilfe. cat
     
  2. g-sus23

    g-sus23 MacUser Mitglied

    Beiträge:
    139
    Zustimmungen:
    3
    MacUser seit:
    16.05.2005
    ich kann dir eclipse mit trustudio empfehlen , finde ich persönlich besser, und gibt es für neulinge auf der trustudio website direkt als Bundle , da kannst du eclipse direkt mit trustudio runterladen.

    Ansonsten dürfte das mit Eclipse 3.0 kein Problem sein, ich hab noch nie weder unter Linux, Windows XP noch Mac OS die Pfade konfigurieren müssen. Einfach den passenden Ordner im Plugins Verzeichniss erstellen und neu starten. Du müsstest sonst dein Problem etwas konkretisieren, was tut Eclipse und was tut es nicht ?
     
  3. catvarlog

    catvarlog Thread Starter MacUser Mitglied

    Beiträge:
    1.468
    Zustimmungen:
    1
    MacUser seit:
    30.01.2005
    herzlichen dank für den tipp. funktioniert. problem mit den pfaden hatte ich nur beim plugin "phpeclipse". dort stehen pfade, die mir recht ungewöhnliche erscheinen. z.B. /apache/php/php für den php-prozessor. da trustudio die besten features nur nach kauf einer lizenz aktiviert, werde ich mir phpeclipse noch mal genau ansehen.
     
  4. g-sus23

    g-sus23 MacUser Mitglied

    Beiträge:
    139
    Zustimmungen:
    3
    MacUser seit:
    16.05.2005
    hmm ... ist halt die frage wo der apache hininstalliert ist ...
    den korrekten pfad kannst du aber auf der shell mit dem befehl
    find / -name "php" suchen ... da dürfte er dir den korrekten pfad zu deinem php interpreter anzeigen

    zu trustudio : Ich sehs auch gerade, also meines kann noch nen bissel mehr, ist aber auch schon ne ältere version , kannst ja mal kurz was zu phpeclipse schreiben, wenn du es ausprobiert hast
     
    Zuletzt bearbeitet: 26.05.2005
  5. catvarlog

    catvarlog Thread Starter MacUser Mitglied

    Beiträge:
    1.468
    Zustimmungen:
    1
    MacUser seit:
    30.01.2005
    ja... nur ist /apache schon recht ungewöhnlich. jedenfalls für mich. würde mich interessieren, welche distro dort installiert.

    ja, wenns läuft :) BTW: ich finde die gui extrem hakelig und eclipse an sich recht langsam in bezug auf response bei irgendeiner aktion (z.B. speichern). ist das bei dir auch so langsam? habe nur jEdit als vergleich und das rennt wie ein pferdchen.
     
  6. g-sus23

    g-sus23 MacUser Mitglied

    Beiträge:
    139
    Zustimmungen:
    3
    MacUser seit:
    16.05.2005
    also das Problem hatte ich original immer unter Windows XP, seit ich auch Mac OS X gewechselt hab läuft eclipse so dermassen schnell ... Ich würd mal die Java Version überprüfen bzw ändern , das hat bei mir unter Windows echt ne Menge seinerzeit gebracht
     
  7. catvarlog

    catvarlog Thread Starter MacUser Mitglied

    Beiträge:
    1.468
    Zustimmungen:
    1
    MacUser seit:
    30.01.2005
    Code:
    java version "1.4.2_05"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-141.4)
    Java HotSpot(TM) Client VM (build 1.4.2-38, mixed mode)
    
    eigentlich nicht verkehrt, oder? jEdit läuft damit jedenfalls sehr zügig....
     
  8. g-sus23

    g-sus23 MacUser Mitglied

    Beiträge:
    139
    Zustimmungen:
    3
    MacUser seit:
    16.05.2005
    hmm , scho ... was hast du denn für eine Plattform ?
     
  9. catvarlog

    catvarlog Thread Starter MacUser Mitglied

    Beiträge:
    1.468
    Zustimmungen:
    1
    MacUser seit:
    30.01.2005
    PB 1,67 und 1,5 GB RAM dazu 10.3.9 - also eigentlich optimal
     
  10. g-sus23

    g-sus23 MacUser Mitglied

    Beiträge:
    139
    Zustimmungen:
    3
    MacUser seit:
    16.05.2005
    hmz , das sollte fluppen ...
    die java version hab ich auch ... irgendwelche CVS Plugins ausser dem normalen Eclipse CVS Plugin drin ?
     
Die Seite wird geladen...

Diese Seite empfehlen