Druckerfreigabe mit Snow Leopard Server funktioniert nicht richtig.

benjamin_d

Mitglied
Thread Starter
Dabei seit
05.03.2005
Beiträge
277
Punkte Reaktionen
15
Guten Tag Miteinander!

Ich habe hier einen Mac Mini Server mit der aktuellen Version von Snow Leopard Server laufen. Eine kleine Arbeitsgruppe nutzt verschiedene Dienste wie Dateifreigabe, einen Proxy usw...

Gestern Abend versuchte ich einen Samsung SCX-4200 MFP Laserdrucker für die ganze Arbeitsgruppe am Server freizugeben. Bisher hängt dieses Gerät an einem Client (Mit 10.6. drauf) und ist für das Netzwerk sowohl als Drucker, als auch als Scanner freigegeben. Das funktioniert auf dem Client problemlos.
---> Wenn ich diesen Drucker jedoch am Server freigebe, so wird dieser zwar per Bonjour im Netzwerk angekündigt, die Clients erkennen aber nicht das Modell (Obwohl der Treiber auf allen installiert ist) und sie können auch nicht drucken. Bei den 10.6 Clients heißt es dann "Timeout". Bei den 10.4 Clients verschwinden Druckaufträge einfach im Nirvana.

Ich habe schon ein wenig recherchiert und die Firewall des Servers komplett deaktiviert - da diese manchmal dazwischen funkt. Ich habe den Drucker über die Systemsteuerung des Servers installiert und im Server Admin dann für diesen Drucker die Freigabe mit IPP, SMB und LPR aktiviert.

Es macht übrigens keinen Unterschied, ob ich mit dem Hersteller Treiber oder einem PS oder PCL-Treiber auf dem Server und/oder Client arbeite. Das Fehlerszenario ist immer identisch.

Statt die Admin-Tools zu nutzen, habe ich den Drucker testweise auch mal nur in Cups konfiguriert und freigegeben. Mit dem gleichen Ergebnis.

Hat jemand einen Rat? Hat jemand dieses Problem schon einmal gelöst?

Grüße
Benjamin
 

Enti

unregistriert
Dabei seit
12.11.2008
Beiträge
120
Punkte Reaktionen
15
Versuch mal den Drucker am Server nur über IPP freizugeben und dann am Client entsprechend einzurichten. Ich hatte auf unserem Server auch ab und an das Problem, das zwar die Drucker, bzw. die Print Queues über den Server-Admin freigegeben waren, aber zusätzlich noch über CUPS (localhost:631) die Freigabe aktiviert werden musste.
Am Client richtest du dann die Drucker via IPP ein, d.h. bei "Adresse" gibst du den Servernamen ein und unter Warteliste dann "/printers/DEN_NAMEN_DEINER_PRINTQUEUE". Den Namen der printqueue siehst du entweder über den Server-Admin oder über CUPS.

Ach ja, das der Treiber nicht automatisch gefunden wird hat nix zu sagen. Das ist bei uns in 99% der Fälle so. Ist aber egal, den Treiber kann man ja auch manuell auswählen ;)
 

benjamin_d

Mitglied
Thread Starter
Dabei seit
05.03.2005
Beiträge
277
Punkte Reaktionen
15
Loesung gefunden

So, nun habe ich eine Loesung gefunden: Den Server mit richtig funktionierendem DNS-Server neu aufsetzen.

Offenbar ist auch der Druckerserver einer von den Diensten, welche nicht ordentlich laufen, wenn man keinen echten Domainnamen fuer seinen Server hat. Ich hatte mit der Maschine noch andere Probleme, eben weil ich an dieser Stelle "geschlampt" habe.
Wie man auf dem Server einen DNS-Server fuer das eigene Netzwerk "richtig" aufsetzt, das fand ich unter Anderem in dieser Anleitung:
http://www.wazmac.com/quickstarts/pdf/osx_server/snow_leopard/02_config_dns.pdf

Meinung: Apple sollte an seinem Setup-Assistenten ein wenig feilen, um diesen offenbar haeufig auftretenden Anfaengerfehler abzufangen.

Gruesse
Benjamin
 

Enti

unregistriert
Dabei seit
12.11.2008
Beiträge
120
Punkte Reaktionen
15
naja, lernen tut man nur durch Fehler und beim zweiten Mal passieren sie garantiert nicht mehr :)
 
Oben Unten