Dependencies von darwinports

Jiji

Mitglied
Thread Starter
Mitglied seit
25.02.2003
Beiträge
292
Ich bin mal am ausprobieren von darwinports und ich bin da auf etwas für mich sehr unschönes gestossen. Da ich grade nichts finde diesbezüglich bei google usw. frage ich mal hier. Wenn ich Subversion über darwinports installiere will mir darwinports erstmal apache installieren, obwohl das ja standardmäßig auf osx (hab tiger) installiert ist. Auch bei Perl, Ruby usw. installiert er erstmal seine eigene Version und benutzt nicht die von OSX. Das gefällt mir gar nicht und ich würde gerne, dass darwinports gefälligst die Sachen, die schon installiert sind auch nutzt. Gibt es da einen weg wie man das hinbekommen kann?
 

maceis

Mitglied
Mitglied seit
24.09.2003
Beiträge
16.844
Jiji schrieb:
...
Wenn ich Subversion über darwinports installiere will mir darwinports erstmal apache installieren,
...
eigenartig; wo subversion doch gar keine Abhängigkeit von apache hat:
Code:
port deps subversion
subversion has library dependencies on:
        expat
        neon
        apr
        apr-util
        db4
Bist Du Dir sicher, dass Du das nicht mit
Code:
apr             devel/apr       0.9.6           \
The apache group's portability library
verwechselst?
 

Jiji

Mitglied
Thread Starter
Mitglied seit
25.02.2003
Beiträge
292
Ja, hab ich tatsächlich. Bleibt noch die Frage, wie ich ihn davon abhalte Perl zu installieren, wenn Perl schon da ist. Da bin ich mir ziemlich sicher nichts verwechselt zu haben.
 

maceis

Mitglied
Mitglied seit
24.09.2003
Beiträge
16.844
Kann es sein, dass da nur Perl *Module* intalliert werden sollen?
Poste doch mal ein "port deps ***" von den Ports, bei denen Du das beobachtest hast.
 

Jiji

Mitglied
Thread Starter
Mitglied seit
25.02.2003
Beiträge
292
Das mit dem Perl ist mir bei GHC aufgefallen.

NieA:~ Jiji$ sudo port deps ghc
ghc has library dependencies on:
readline
gmp
ghc has runtime dependencies on:
perl5.8
Ich habe jetzt auch mal Subversion installiert und nun habe ich openssl sowohl in /usr/bin/ als auch in /opt/local/bin.

NieA:~ Jiji$ sudo port install subversion
---> Fetching apr
---> Attempting to fetch httpd-2.0.54.tar.bz2 from Index of /dist/httpd
---> Verifying checksum(s) for apr
---> Extracting apr
---> Configuring apr
---> Building apr with target all
---> Staging apr into destroot
---> Packaging tgz archive for apr 0.9.6_1+darwin_8
---> Installing apr 0.9.6_1+darwin_8
---> Activating apr 0.9.6_1+darwin_8
---> Cleaning apr
---> Fetching db4
---> Attempting to fetch db-4.3.28.tar.gz from http://downloads.sleepycat.com/
---> Verifying checksum(s) for db4
---> Extracting db4
---> Configuring db4
---> Building db4 with target all
---> Staging db4 into destroot
---> Packaging tgz archive for db4 4.3.28_0+darwin_8
---> Installing db4 4.3.28_0+darwin_8
---> Activating db4 4.3.28_0+darwin_8
---> Cleaning db4
---> Fetching expat
---> Attempting to fetch expat-1.95.8.tar.gz from http://easynews.dl.sourceforge.net/sourceforge/expat/
---> Verifying checksum(s) for expat
---> Extracting expat
---> Configuring expat
---> Building expat with target all
---> Staging expat into destroot
---> Packaging tgz archive for expat 1.95.8_1
---> Installing expat 1.95.8_1
---> Activating expat 1.95.8_1
---> Cleaning expat
---> Fetching libiconv
---> Attempting to fetch libiconv-1.10.tar.gz from ftp://ftp.gnu.org/gnu/libiconv
---> Verifying checksum(s) for libiconv
---> Extracting libiconv
---> Configuring libiconv
---> Building libiconv with target all
---> Staging libiconv into destroot
---> Packaging tgz archive for libiconv 1.10_1+darwin_8
---> Installing libiconv 1.10_1+darwin_8
---> Activating libiconv 1.10_1+darwin_8
---> Cleaning libiconv
---> Fetching apr-util
---> Verifying checksum(s) for apr-util
---> Extracting apr-util
---> Configuring apr-util
---> Building apr-util with target all
---> Staging apr-util into destroot
---> Packaging tgz archive for apr-util 0.9.6_1
---> Installing apr-util 0.9.6_1
---> Activating apr-util 0.9.6_1
---> Cleaning apr-util
---> Fetching zlib
---> Attempting to fetch zlib-1.2.3.tar.bz2 from zlib Home Site
---> Verifying checksum(s) for zlib
---> Extracting zlib
---> Configuring zlib
---> Building zlib with target all
---> Staging zlib into destroot
---> Packaging tgz archive for zlib 1.2.3_0
---> Installing zlib 1.2.3_0
---> Activating zlib 1.2.3_0
---> Cleaning zlib
---> Fetching openssl
---> Attempting to fetch openssl-0.9.8.tar.gz from OpenSSL
---> Verifying checksum(s) for openssl
---> Extracting openssl
---> Applying patches to openssl
---> Configuring openssl
---> Building openssl with target all
---> Staging openssl into destroot
---> Packaging tgz archive for openssl 0.9.8_2
---> Installing openssl 0.9.8_2
---> Activating openssl 0.9.8_2
---> Cleaning openssl
---> Fetching neon
---> Attempting to fetch neon-0.24.7.tar.gz from neon HTTP and WebDAV client library
---> Verifying checksum(s) for neon
---> Extracting neon
---> Applying patches to neon
---> Configuring neon
---> Building neon with target all
---> Staging neon into destroot
---> Packaging tgz archive for neon 0.24.7_0
---> Installing neon 0.24.7_0
---> Activating neon 0.24.7_0
---> Cleaning neon
---> Fetching subversion
---> Attempting to fetch subversion-1.2.3.tar.bz2 from http://subversion.tigris.org/tarballs/
---> Verifying checksum(s) for subversion
---> Extracting subversion
---> Applying patches to subversion
---> Configuring subversion
---> Building subversion with target all
---> Staging subversion into destroot
---> Packaging tgz archive for subversion 1.2.3_0
---> Installing subversion 1.2.3_0
---> Activating subversion 1.2.3_0
---> Cleaning subversion
 
Zuletzt bearbeitet von einem Moderator:

Josh83

Mitglied
Mitglied seit
29.11.2005
Beiträge
710
Hi alle

Ich versuche auch gerade, Subversion zu installieren. Zuerst habe ich es mit einem pkg Installer versucht (subversion-client-1.3.0.dmg), aber der Befehl svn war danach nicht verfügbar in der Konsole (das sollte er doch sein, oder?).
Nun versuche ich es auch per sudo port install subversion, und das dauert ewig lange und installiert auch all die seltsamen Sachen, wie oben schon beschrieben. Ist das normal so? Oder was soll ich machen?
 

oneOeight

Mitglied
Mitglied seit
23.11.2004
Beiträge
54.197
das 1.3 pkg wird dir das ganze nach /usr/local installiert haben, und wenn du /usr/local/bin nicht im path hast, dann findet der das kommando auch nicht...
 

Josh83

Mitglied
Mitglied seit
29.11.2005
Beiträge
710
Ah OK, herzlichen Dank. :)
 
Oben