Daten im Papierkorb können nicht gelöscht werden. 🪣

roger.rebel

Mitglied
Thread Starter
Dabei seit
15.10.2006
Beiträge
474
Punkte Reaktionen
38
Habe ein ziemlich dämliche Problem:

In meinem Papierkorb ist ein Ordner mit diversen Unterordnern, alle ohne Inhalt, die ich nicht löschen kann.

Gehe ich auf Papierkorb entleeren, kommt die Meldung "Der Vorgang konnte nicht abbgeschlossen werden, da das Objekt "... " in Verwendung ist. Kann diese Meldung dann Überspringen, Stoppen oder Fortfahren.

Gehe ich auf "Sofort löschen" fehlen mir angeblich die Rechte.

Was kann ich noch tun?

RR
 

roger.rebel

Mitglied
Thread Starter
Dabei seit
15.10.2006
Beiträge
474
Punkte Reaktionen
38
Sicher? Auch nicht bei ls -a im Terminal?

Was genau bedeutet das? Soll ich das im Terminal eingeben?

Und nein, Reboot reicht nicht.

Die Ordner stammen von einem Windows-PC, habe die Dateien auf den Mac übertragen.

:unsure:
 

fa66

Aktives Mitglied
Dabei seit
16.04.2009
Beiträge
16.177
Punkte Reaktionen
6.556
Was genau bedeutet das? Soll ich das im Terminal eingeben?
Dann besser nicht.

Es war nur als Hinweis darauf gemeint, dass ein »leerer Ordner«, oder einer, der im Finder leer angezeigt wird, nicht leer sein muss.
Im Terminal (es gibt auch Wege im Finder) lassen sich – nach Wechseln (change directory) in das betreffende Verzeichnis (cd /pfad/) dann auch alle Dateien auflisten (ls -a).

Die Ordner stammen von einem Windows-PC
So oder vom Mac aus: Ich meinte, aus welchen Verzeichnissen dort. Könnten am Quellort Einschränkungen gesetzt worden sein?
Wie – auf welche Weise – wurden die Daten übertragen?
 

KOJOTE

Aktives Mitglied
Dabei seit
06.11.2004
Beiträge
8.679
Punkte Reaktionen
2.516
Wenn es das Terminal nicht sein darf/soll, könnte man die im Papierkorb enthaltenen Ordner/Dateien auch erst mal wieder aus dem Papierkorb auf den Desktop ziehen und im Anschluss dann versuchen diese eine nach der anderen zu löschen.
 

Difool

Frontend Admin
Dabei seit
18.03.2004
Beiträge
15.265
Punkte Reaktionen
10.511
Ordner aus dem Papierkorb auf den Desktop ziehen und Rechts-Klick (ctrl-klick) > Kontext-Menü: "Ordnername komprimieren".
Dann in den Papierkorb und löschen [ggf. den komprimierten Ordner vor dem Löschen noch umbenennen.].

Alternativ den Stick oder Netzwerk mounten, wo der/die Ordner her kamen und dann löschen.
 

roger.rebel

Mitglied
Thread Starter
Dabei seit
15.10.2006
Beiträge
474
Punkte Reaktionen
38
Danke für den Tipp. 1. Teil habe ich mich getraut, hat aber nicht geholfen. Für den 2. Teil bin ich zu feige...

Das probiere ich heute noch aus..., vielleicht.

So oder vom Mac aus: Ich meinte, aus welchen Verzeichnissen dort. Könnten am Quellort Einschränkungen gesetzt worden sein?
Wie – auf welche Weise – wurden die Daten übertragen?
Die Daten wurden von einem USB-Stick übertragen. Die Dateien konnten alle gelöscht werden, die Ordner machen die Probleme.

Wenn es das Terminal nicht sein darf/soll, könnte man die im Papierkorb enthaltenen Ordner/Dateien auch erst mal wieder aus dem Papierkorb auf den Desktop ziehen und im Anschluss dann versuchen diese eine nach der anderen zu löschen.

Ich kann die Ordner vom Papierkorb wieder auf den Desktop ziehen, aber sie bleiben trotzdem im Papierkorb liegen. Wenn ich die Desktop-Ordner dann wieder in den Papierkorb ziehe, dann sind dort die Ordner 2x vorhanden. Den hinundher geschobenen Ordner kann ich normal löschen, der ursprüngliche kann nicht gelöscht werden.


Alternativ den Stick oder Netzwerk mounten, wo der/die Ordner her kamen und dann löschen.
Den Stick habe ich leider nicht mehr.


Trotzdem vielen Dank für Eure Tipps.
:clap:
 

roger.rebel

Mitglied
Thread Starter
Dabei seit
15.10.2006
Beiträge
474
Punkte Reaktionen
38
Es war nur als Hinweis darauf gemeint, dass ein »leerer Ordner«, oder einer, der im Finder leer angezeigt wird, nicht leer sein muss.
Im Terminal (es gibt auch Wege im Finder) lassen sich – nach Wechseln (change directory) in das betreffende Verzeichnis (cd /pfad/) dann auch alle Dateien auflisten (ls -a).

Das stimmt tatsächlich, die Ordner sind nicht leer. Habe viele _xxx Dateien gefunden, also Dateien, die mit dem Unterstrich beginnen.

Und wie kann ich diese nun löschen?
 

Marco7

Mitglied
Dabei seit
25.06.2020
Beiträge
398
Punkte Reaktionen
77
Bei mir klappte es, nachdem ich SIP im Terminal des Recoverymodus deaktiviert habe.
 

JARVIS1187

Mitglied
Dabei seit
26.08.2021
Beiträge
878
Punkte Reaktionen
851
Die Ordner stammen von einem Windows-PC, habe die Dateien auf den Mac übertragen.

Nur zur Sicherheit: Du hast sie auf eine HFS+ oder APFS-Partition übertragen? Oder hast du eine NTFS-Partition auf dem Mac erstellt (via Bootcamp oder so?), die dann via Windows draufgezogen und dann von der NTFS-Partition gelöscht? Das macht einen großen Unterschied, da macOS NTFS nicht ohne Zusatztools beschreiben kann
 

roger.rebel

Mitglied
Thread Starter
Dabei seit
15.10.2006
Beiträge
474
Punkte Reaktionen
38
Nur zur Sicherheit: Du hast sie auf eine HFS+ oder APFS-Partition übertragen? Oder hast du eine NTFS-Partition auf dem Mac erstellt (via Bootcamp oder so?), die dann via Windows draufgezogen und dann von der NTFS-Partition gelöscht? Das macht einen großen Unterschied, da macOS NTFS nicht ohne Zusatztools beschreiben kann
Habe auf meinem Mac auch NTFS for Mac installiert...
 

JARVIS1187

Mitglied
Dabei seit
26.08.2021
Beiträge
878
Punkte Reaktionen
851
Was genau ist SIP?
System Integrity Protection - Systemdateienschutz
Dafür startest du den Recoverymodus via CMD+R und öffnest darin ein Terminal und gibst den Befehl "csrutil disable" ein. Neustarten in macOS und die Dateien löschen (sofern dann möglich!), danach unbedingt wieder zurück in den Recoverymodus und im Terminal "csrutil enable" eingeben, wieder neustarten.
Auf keinen Fall SIP deaktiviert lassen! Nur, um das Löschen zu testen!

Habe auf meinem Mac auch NTFS for Mac installiert...
Dann ist meine Vermutung dahin :)
 

roger.rebel

Mitglied
Thread Starter
Dabei seit
15.10.2006
Beiträge
474
Punkte Reaktionen
38
Dafür startest du den Recoverymodus via CMD+R und öffnest darin ein Terminal und gibst den Befehl "csrutil disable" ein. Neustarten in macOS und die Dateien löschen (sofern dann möglich!), danach unbedingt wieder zurück in den Recoverymodus und im Terminal "csrutil enable" eingeben, wieder neustarten.
Habe ich versucht, klappt leider auch nicht. Es kommt wieder die Fehlermeldung, dass ich keine Rechte dazu habe.

Nicht zu glauben - ich bin der einzige User an dem Mac, habe ihn selber eingerichtet und jetzt sagt mir das System, dass ich keine Rechte habe???

:hamma:
 

Schiffversenker

Aktives Mitglied
Dabei seit
25.06.2012
Beiträge
13.463
Punkte Reaktionen
5.505
Hab ich das überlesen oder wissen wir überhaupt, welches System der TE benutzt?
Bei den neuesten Mac-Systemen hat tatsächlich auch root keine Rechte an den Kernbestandteilen des Systems.
Das abschalten von SIP gehört allerdings meines Wissens nicht dazu.
Vielleicht mal probieren mit
sudo csrutil disable
Passwort eingeben ohne auf den Bildschirm zu schauen (es verwirrt viele, die hinschauen und nichts sehen, aber das ist Absicht, es gibt bei der Eingabe kein Echo auf dem Schirm).
 

roger.rebel

Mitglied
Thread Starter
Dabei seit
15.10.2006
Beiträge
474
Punkte Reaktionen
38
Hab ich das überlesen oder wissen wir überhaupt, welches System der TE benutzt?
Bei den neuesten Mac-Systemen hat tatsächlich auch root keine Rechte an den Kernbestandteilen des Systems.
Das abschalten von SIP gehört allerdings meines Wissens nicht dazu.
Vielleicht mal probieren mit
sudo csrutil disable
Passwort eingeben ohne auf den Bildschirm zu schauen (es verwirrt viele, die hinschauen und nichts sehen, aber das ist Absicht, es gibt bei der Eingabe kein Echo auf dem Schirm).
Ich habe einen Mac Pro 5.1 mit Mojave-OS.

sudo csrutil disable hat er im Recovery Mode nicht akzeptiert; sudo unknown command

Habe dann nochmals csrutil disable eingegeben, das wurde bestätigt und einen Neustart empfohlen.

Die Ordner im Papierkorb scheint das nicht zu interessieren. Gehe ich nur auf löschen, dann kommt immer noch die Meldung, dass die Dateien in Gebrauch sind. Gehe ich auf sofort löschen, dann fehlen mir die Rechte.
 
Oben Unten