Darstellungsproblem beim IE auf dem PC

  1. unique23

    unique23 Thread StarterMacUser Mitglied

    Mitglied seit:
    03.03.2004
    Beiträge:
    754
    Zustimmungen:
    2
    Hallo community,

    meine Homepage konnte ich nun das erste mal aif einem PC mit IE begutachten
    und da gibt es nun aber leider Darstellungsprobleme in den Überschriften.
    Diese werden immer oben und unten abgeschnitten und ich weiß nicht woher
    das kommt. Hat jemand eine Ahnung?
    http://www.stilwiese.com

    Ich weiß ich bin hier nicht in der 100% richtigen Zielgruppe - alles Macianer -
    aber vielleicht treibt sich auch der eine oder andere Web-Entwickler herum,
    der sich dem Problem kurz annehmen könnte. Das wäre wirklich super.

    Die Seite ist xhtml-valid. und ich weiß leider nicht was das Problem ist.
    Weiß jemand was?
    Unter Safari und Firefox wird alles richtig angezeigt. Aber da die Mehrheit den
    IE installiert hat, kommt man wohl nicht um den Microsoft-Browser. :-/
     
    unique23, 03.01.2006
  2. ds007

    ds007MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    73
    Zustimmungen:
    0
    seit wann hält sich der IE denn an Standarts?

    Wie ist die Seite den aufgebaut, könnte sein, das die Tabellen für die IE Darstellung von den Höhen zu klein sind oder das du Schriften verwendest, die der IE (bzw. der andere Rechner) nicht kennt?
     
    ds007, 03.01.2006
  3. ds007

    ds007MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    73
    Zustimmungen:
    0
    vielleicht noch so als Ergänzung. Hatte bei meiner Seite auch extreme Darstellungsprobleme mit dem IE. Mit Safari und Mozilla lief dagegen alles Problemlos. war ne Menge Probieren und Optimieren notwendig.

    Eigentlich ist die Zeit dafür dann aber auch wieder zu schade ;-)

    Kann Deine Siete aber auch nicht mit nem IE sehen. Hab keinen.... :)
     
    ds007, 03.01.2006
  4. unique23

    unique23 Thread StarterMacUser Mitglied

    Mitglied seit:
    03.03.2004
    Beiträge:
    754
    Zustimmungen:
    2
    Der Bereich der abgeschnitten wird ist in einem eigenen div namens titel. Ich habe ihn nicht speziell deklariert, bzw auf eine bestimme Höhe limitiert.
    Leider kann ich mir das Resultat absolut nicht erklären. Nur dass es mies aussieht, das
    weiß ich,.. :)
     
    unique23, 03.01.2006
  5. theHobbit

    theHobbitMacUser Mitglied

    Mitglied seit:
    07.08.2005
    Beiträge:
    724
    Zustimmungen:
    6
    Hi! Dein .css-Code:

    Code:
    body {
    	font: bold 16px Arial, sans-serif;
    	text-align: center;
        line-height: 22px;
    	padding: 0px;
    	color: #ccc;
    	background: #444;
    }
    
    p {
    line-height: 22px;
    }
    
    
    .container {
    	width: 768px;
    	margin-top: 0px;
    	margin-right: auto;
    	margin-left: auto;
    	padding: 0px;
    	text-align:left;
    	}
    
    .titel {
    	font: bold 40px Arial, sans-serif;
    	color: #ccc;
    	background: #444;
    	position: absolute;
    	margin-top: 0px;
    	margin-left: 8px;
    
    }
    
    
    
    Dein .body. Tag hat ein line-height, aber Dein .container. und .titel. Tag nicht. Würde da mal ansetzen und bei einem der beiden mal den .line-height. erhöhen.

    Meine Vermutung: das .line-heihgt. aus dem .body. tag überschreibt die Einstellung .font bold 40px. aus dem .title. Tag.

    versuch's mal ...

    edit:
    und der Safari / Mozilla korrigieren das (vermutlich) großzügigerweise :D
     
    theHobbit, 03.01.2006
  6. unique23

    unique23 Thread StarterMacUser Mitglied

    Mitglied seit:
    03.03.2004
    Beiträge:
    754
    Zustimmungen:
    2
    das line-height tag habe ich jetzt überall eingefügt, allerdings funktioniert es
    nicht und hat keine veränderung gezeigt.
    ein height-tag bringtb esserung, aber leider fehlt immer noch etwas im oberen teil.

    bin immer noch ratlos....
     
    unique23, 03.01.2006
  7. ds007

    ds007MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    73
    Zustimmungen:
    0
    das sollte auch keine Änderung machen, da es eigentlich mitvererbt werden sollte, oder?

    aber spiel mal mit der höhe, vielleicht schneider der IE die 40px Schrift ".title" dann bei 22px ab.
     
    ds007, 03.01.2006
  8. theHobbit

    theHobbitMacUser Mitglied

    Mitglied seit:
    07.08.2005
    Beiträge:
    724
    Zustimmungen:
    6
    das ist auch meine Vermutung ... mal an der Höhe "herumstellen" :D
     
    theHobbit, 03.01.2006
  9. unique23

    unique23 Thread StarterMacUser Mitglied

    Mitglied seit:
    03.03.2004
    Beiträge:
    754
    Zustimmungen:
    2
    jetzt habe ich die line height nur noch so verwendet:

    p {
    line-height: 22px;
    }

    und in dem .titel tag einen neuen wert auf 150 gesetzt. nur so zum test, aber leider
    hat sich nichts getan,.. :-/
     
    unique23, 03.01.2006
  10. unique23

    unique23 Thread StarterMacUser Mitglied

    Mitglied seit:
    03.03.2004
    Beiträge:
    754
    Zustimmungen:
    2
    okay,. nun habe ich line-height nur für jedes einzelne div verwendet und nun geht die
    sache - nachdem ich etwas das layout verschoben habe, denn der gute ff zeigt
    es dann anders an,... aber letzten endes gehts :)

    vielen dank!
     
    unique23, 03.01.2006
Die Seite wird geladen...
Ähnliche Themen - Darstellungsproblem beim auf
  1. Barons
    Antworten:
    6
    Aufrufe:
    672
  2. JeDi150
    Antworten:
    2
    Aufrufe:
    1.807
    JeDi150
    29.07.2010
  3. boberl
    Antworten:
    2
    Aufrufe:
    1.267
  4. cube82
    Antworten:
    1
    Aufrufe:
    406
  5. sciuk
    Antworten:
    22
    Aufrufe:
    1.184
    Gassman
    18.10.2006