curl -0

  1. Cornholiooo

    Cornholiooo Thread StarterMacUser Mitglied

    Mitglied seit:
    17.01.2006
    Beiträge:
    1.259
    Zustimmungen:
    11
    Huhu

    Also ich habe da mal eine Frage zu curl.

    Wenn ich nun z.B.:

    PHP:
    curl -0 http://xxxx/Blub%20&%20Blub.m4a
    runderladen möchte, dann geschieht dies nicht. Ich glaube, dass er sich an dem & Zeichen in der Adresse stört. Gibt es eine Möglichkeit (eventuell mit einem anderen Attribut) dies zu umgehen? Auf http 1.0 bin ich angewiesen.

    Grüße
    Dennis
     
    Cornholiooo, 31.12.2006
  2. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.168
    Zustimmungen:
    3.887
    setz mal die url in "" ansonsten denkt die shell du will mit dem & das ganze in den hintergrund schicken
     
    oneOeight, 31.12.2006
  3. Cornholiooo

    Cornholiooo Thread StarterMacUser Mitglied

    Mitglied seit:
    17.01.2006
    Beiträge:
    1.259
    Zustimmungen:
    11
    mhhh das geht dann garnicht. dann liest das terminal die datei aus und produziert 1million kryptische zeichen :)
     
    Cornholiooo, 31.12.2006
  4. der_Kay

    der_KayMacUser Mitglied

    Mitglied seit:
    02.09.2004
    Beiträge:
    1.685
    Zustimmungen:
    8
    cURL schreibt alles in stdout. Entweder
    curl -0 "http://xxxx/Blub%20&%20Blub.m4a" > dingens.m4a

    oder bequemer:
    wget "http://xxxx/Blub%20&%20Blub.m4a"
     
    der_Kay, 31.12.2006
  5. Cornholiooo

    Cornholiooo Thread StarterMacUser Mitglied

    Mitglied seit:
    17.01.2006
    Beiträge:
    1.259
    Zustimmungen:
    11
    Ah doch...die erste Variante klappt wunderbar. Also sage ich ihm praktisch. "Hey, schau dir diese URL an und von dort aus lädst du dann "dingens.m4a" und dann in diesem Fall Blub%20&%20Blub.m4a runter" ?

    Wo speichert er nach dem Download die Datei eigentlich?
     
    Cornholiooo, 01.01.2007
  6. Cornholiooo

    Cornholiooo Thread StarterMacUser Mitglied

    Mitglied seit:
    17.01.2006
    Beiträge:
    1.259
    Zustimmungen:
    11
    Ah ja ich habs.... man muss "dingens.m4a" in diesem Fall bei mir ja "Blubblablablabla...." auch in "" setzen, da er sonst das & als Umbruch oder so ansieht :) Wunderbar es klappt nun alles...

    vielen lieben dank !
     
    Cornholiooo, 01.01.2007
  7. Dr_Nick

    Dr_NickMacUser Mitglied

    Mitglied seit:
    13.08.2005
    Beiträge:
    1.422
    Zustimmungen:
    25
  8. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Nein, mit der Option '-O' legt curl die Datei selbst an.
     
    maceis, 01.01.2007
Die Seite wird geladen...
Ähnliche Themen - curl
  1. alphaomega
    Antworten:
    2
    Aufrufe:
    890
    alphaomega
    13.01.2011
  2. grünspam
    Antworten:
    2
    Aufrufe:
    1.223
    grünspam
    05.12.2008
  3. promille
    Antworten:
    7
    Aufrufe:
    1.151
    oneOeight
    02.07.2008
  4. thelostrose
    Antworten:
    4
    Aufrufe:
    694
    thelostrose
    19.11.2003