CSV Datei mit Komma bei Excel 2004 ?

  1. Universum

    Universum Thread Starter MacUser Mitglied

    Mitglied seit:
    02.11.2003
    Beiträge:
    113
    Zustimmungen:
    0
    Hallo.
    Ich brauche CSV Dateien mit Komma-Trenner statt Semikolon aus meinem Excel 2004. Beim Erzeugen der CSV - Datei wird automatisch das Semikolon verwendet. Ich finde keine Auswahl. Gibt es eine ? Oder einen Trick?
    Ich möchte mir das nachträgliche Umwandeln der Satzzeichen ersparen.
    Jochen
     
    Universum, 11.01.2007
    #1
  2. falkgottschalk

    falkgottschalk MacUser Mitglied

    Mitglied seit:
    22.08.2005
    Beiträge:
    24.005
    Zustimmungen:
    1.599
    Hi,
    Du hast einen bemerkenswerten Widerspruch entdeckt.
    Lt. Hilfe werden beim CSV-Export Kommata verwendet und keine Semikolon:
    //cut
    • CSV (Trennzeichen getrennt)

    Beim Dateiformat "CSV (Trennzeichen getrennt)" werden nur der Text und die Werte, so wie sie in den Zellen im aktiven Arbeitsblatt angezeigt werden, gespeichert. Sämtliche Zeilen und Zeichen in den einzelnen Zellen werden gespeichert. ]Datenspalten werden durch Kommas getrennt[/B, und alle Datenzeilen werden durch eine Zeilenschaltung abgeschlossen. Wenn eine Zelle ein Komma enthält, wird der Zellinhalt in doppelte Anführungszeichen eingeschlossen…
    //cut

    Defakto sind aber Semikolon in der Datei und keine Kommata...
    Nanu?

    OK, meine Antwort hilft Dir jetzt nicht weiter, aber vielleicht regt es eine zielführende Diskussion an?
     
    falkgottschalk, 11.01.2007
    #2
  3. Universum

    Universum Thread Starter MacUser Mitglied

    Mitglied seit:
    02.11.2003
    Beiträge:
    113
    Zustimmungen:
    0
    Ja, es gibt noch etwas:
    In der US-Version werden CSV mit Komma erzeugt, in der Deutsch-Version die Semikolon.
    J.
     
    Universum, 11.01.2007
    #3
  4. KingKay

    KingKay MacUser Mitglied

    Mitglied seit:
    18.01.2005
    Beiträge:
    1.199
    Zustimmungen:
    8
    Klar, in den USA gilt ja auch der Punkt in einem Preis wie unser Komma. Die können also mit Komma trennen. Sollte die CSV mit Komma getrennt werden, werden Angaben von Preise mit Komma komplett verhackstückelt.

    Leider habe ich aktuell auch dieses Problem nur umgedreht. Ich will eine TXT Datei mit Preisangaben mit Punkt importieren. Und Excel 2004 wandelt es immer in Datumsangaben um. Ich finde einfach die Importierfunktion nicht mit der ich das im Vorfeld abstellen oder einstellen kann.
     
    KingKay, 22.05.2007
    #4
  5. peterg

    peterg MacUser Mitglied

    Mitglied seit:
    02.03.2005
    Beiträge:
    2.755
    Zustimmungen:
    184
    Hallo,

    die Export-Funktion von Excel nimmt ihre Landeseinstellungen (Komma oder Semikolon beim Export von CSV) aus den Landeseinstellungen von Excel - nicht des Systems. Deshalb gibt es immer ein Semikolon. Mir ist keine Möglichkeit bekannt, dieses Verhalten in excel:2004 für den Mac zu beeinflussen.

    Halbwegs gute Programme erlauben es jedoch, beim Import diese Parameter einzustellen. Deshalb macht dieses Verhalten in der Praxis selten Probleme.

    Beim Import kann man für jede Spalte einstellen, wie er Punkt bzw. Komma interpretieren soll. Dazu auf der letzten Seite des Import-Dialoges von Textdateien die Spalte(n) anklicken und die Eingaben vornehmen. Dann wird aus 175.13 richtig 175,13.

    Peter
     
    peterg, 22.05.2007
    #5
Die Seite wird geladen...
Ähnliche Themen - CSV Datei Komma
  1. DirtyWorld
    Antworten:
    17
    Aufrufe:
    410
    DerdenMacliebt
    16.07.2017 um 00:01 Uhr
  2. Sturmi12
    Antworten:
    7
    Aufrufe:
    410
    little_pixel
    15.10.2011
  3. Nili
    Antworten:
    10
    Aufrufe:
    1.452
    KingKay
    23.05.2007
  4. Bjoernyy
    Antworten:
    2
    Aufrufe:
    1.424
    Mike3172
    28.02.2007
  5. azmataz
    Antworten:
    1
    Aufrufe:
    941
    Mortiis
    12.04.2006