1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

CSS-Problem bei Safari

Dieses Thema im Forum "Web-Design" wurde erstellt von sunni, 14.12.2003.

  1. sunni

    sunni Thread Starter MacUser Mitglied

    Mitglied seit:
    06.03.2002
    Beiträge:
    761
    Zustimmungen:
    0
    Hallo,

    Ich möchte in Eingabe Feldern eine Hintergrundfarbe setzen. Das geht bei den meisten Browsern mit

    <input type="text" name="test" style="background-color: #00AA00">

    Leider wird bei Safari immer das normale weiße Feld angezeigt.
    Hat jemand eine Idee, warum das unter Safari nicht funktioniert?
    Also Beispiel könnt ihr meine Webseite hernehmen: http://www.bigbluesun.de

    Grüße
    sunni
     
  2. Stenz

    Stenz MacUser Mitglied

    Mitglied seit:
    11.06.2003
    Beiträge:
    673
    Zustimmungen:
    14
    Ich sehen weisse Schrift auf blauen Grund.
     
  3. sunni

    sunni Thread Starter MacUser Mitglied

    Mitglied seit:
    06.03.2002
    Beiträge:
    761
    Zustimmungen:
    0
    Auch bei den Eingabefeldern?
    Klick mal oben auf Guestbook und dort auf Beitrag schreiben...
    Schaut bei mir leider gar nicht mehr so schön aus :(
     
  4. Grady

    Grady MacUser Mitglied

    Mitglied seit:
    25.04.2003
    Beiträge:
    2.280
    Zustimmungen:
    1
    Safari scheint die Styles bei den Feldern nicht zu beachten. Das kann möglicherweise damit zu tun haben, dass Apple gerne dem User ein einheitliches Bild der Eingabefelder bieten will und nicht einsieht, warum man diese verändert.

    Hier mal ein Screenshot vom InternetExploder5
     

    Anhänge:

    • ie.jpg
      Dateigröße:
      8,8 KB
      Aufrufe:
      59
  5. Grady

    Grady MacUser Mitglied

    Mitglied seit:
    25.04.2003
    Beiträge:
    2.280
    Zustimmungen:
    1
    In Safari sieht das dann so aus (und zwar bei allen Usern ;)) :
     

    Anhänge:

    • safari.jpg
      Dateigröße:
      8,3 KB
      Aufrufe:
      57
  6. sunni

    sunni Thread Starter MacUser Mitglied

    Mitglied seit:
    06.03.2002
    Beiträge:
    761
    Zustimmungen:
    0
    Aber genau das sieht doch so *schdingsda* aus. Ich hoffe mal, daß Apple in der nächsten Safari-Version diesen Fehler behebt.
     
  7. manuel1000

    manuel1000 MacUser Mitglied

    Mitglied seit:
    20.11.2003
    Beiträge:
    611
    Zustimmungen:
    2
    &nbsp;

    Ja das hoffe ich auch. Find das ganze überhaupt besch..., wenn jeder browser ...ie5 oder 6, netscape, safari und wie so noch alles heissen, vieles und vorallem styles nicht richtig oder gar nicht darstellen können.
    jeder webmaster hat da zu kämpfen mit dem krampf. warum können sich die hersteller nicht auf den standard konzentrieren. jeder kocht sein eigenes süppchen. das kotzt mich an.

    also mach dir nix draus und lass es so, wies ist! hilft eh nicht!

    bist nicht alleine mit den problemen ...

    bis dann!
     
  8. lemonstre

    lemonstre MacUser Mitglied

    Mitglied seit:
    12.03.2003
    Beiträge:
    1.890
    Zustimmungen:
    106
    die style definitionen für formulare sind nicht standardisiert! weder der vom w3c herrausgegebene standard css 1.0 noch der neue css standard 2.0 enthalten styledefinitionen für formulare. daher ist es reines glücksspiel welcher browser was und wie unterstützt. am besten lässt man solche eyecatcher gimmicks bleiben und konzentriert sich mehr auf den inhalt ;)

    siehe auch:

    http://selfhtml.teamone.de/html/formulare/formatieren.htm#css

    gruss
    lemonstre
     
  9. sunni

    sunni Thread Starter MacUser Mitglied

    Mitglied seit:
    06.03.2002
    Beiträge:
    761
    Zustimmungen:
    0
    Na hey, Inhalt ist doch da :D
     
  10. drizzd

    drizzd MacUser Mitglied

    Mitglied seit:
    09.01.2003
    Beiträge:
    40
    Zustimmungen:
    0
    guck mal da, beschäftigt sich genau mit diesem problem.