Cocoaspell funktioniert nicht

helgeh

Mitglied
Thread Starter
Registriert
18.11.2004
Beiträge
533
Hallo!

Ich habe Cocoaspell 2.0.2 installiert. In der Systemsteuerung kann ich auch die Einstellungen vornehmen. Habe also das deutsche Wörterbuch eingefügt und den Latex-Filter eingeschaltet. Wenn ich jetzt aber in TexShop die Rechtschreibung nutze, dann meckert er immer noch bei jedem Latex-Befehl. Und was mich auch verwundert ist, dass ich alle möglichen Sprachen als Wörterbuch auswählen kann. Und zwar auch solche, die nicht bei Cocoaspell angezeigt werden. Daher denke ich, dass da immer noch die Apple eigene Rechtschreibkorrektur dran ist.
Ich benutze Mac Os X 10.4.3. TexShop ist 2.03.

Hat irgendwer eine Idee?
Kann man eigentlich die Files von dem Duden irgendwie mit Cocoaspell nutzen?

helgeh
 

oneOeight

Aktives Mitglied
Registriert
23.11.2004
Beiträge
58.063
ich glaub du musst das richtige wörterbuch über rechtschreibung auswählen, und zwar das von cocoaspell
 

helgeh

Mitglied
Thread Starter
Registriert
18.11.2004
Beiträge
533
Hm. Welches soll das denn sein? Dei Wörterbücher von Cocoaspell werden nicht direkt angezeigt. Was ich mir vorstellen könnte wäre Multilingual. Aber das klappt leider auch nicht.

helgeh
 

helgeh

Mitglied
Thread Starter
Registriert
18.11.2004
Beiträge
533
Jetzt klappt es endlich! Keine Ahnung warum vorher nicht. Die Wörterbücher werden angezeigt mit angefügten (Aspell). Super!
 

RuditheKranich

Mitglied
Registriert
10.01.2009
Beiträge
93
Hallo Leute,

habe cocoAspell installiert, um ein LaTeX unterstützendes Wörterbuch in TeXShop zur Verfügung zuhaben. Die Grundinstallation mit englischem Wörterbuch funktioniert auch. Wenn ich nun das deutsche Wörterbuch installiere und in TeXShop aktiviere - "Deutsch (Aspell)", funktioniert in TeXShop die Latexunterstützung, aber die deutschen Wörter kennt er nicht.
Über Tipps bin ich sehr dankbar.

Noch eine Frage: Man kann in OS X in den Systemeinstellungen unter: Tastatur -> Text "Automatisch nach Sprache" auswählen und im Menü "Konfigurieren" dann die Aspell-Bücher aktivieren. Wieso funktioniert aber, wenn ich die Option "Automatisch nach Sprache" im Rechtschreibmenü von TeXShop aufrufe, die Latex-Erkennung nicht?
 

RuditheKranich

Mitglied
Registriert
10.01.2009
Beiträge
93
Problem gelöst:

Die Wörterbücher muss man mithilfe der Konsole installieren, auch wenn auf der Website von cocoAspell was anderes steht. In der Readme der Wörterbücher steht es richtig.

1. Wörterbuch laden/entpacken und nach /Library/Application Support/cocoAspell verschieben (danach NICHT die Systemeinstellungen öffnen und das Wörterbuch auswählen)
2. in der Konsole in diesem Verzeichnis die folgenden Befehle ausführen: ./configure - make - sudo make install
3. Das Wörterbuch in den Systemeinstellungen mit dem LaTeX-Filter auswählen und FERTIG!

Natürlich wie im Beitrag zu vor nicht vergessen, dass richtige Wörterbuch im Editor auzuwählen.
 
Oben