CocoaMySQL: Umlaute werden seltsam dargestellt

Dieses Thema im Forum "Datenbanken und Archiv Software" wurde erstellt von Josh83, 30.12.2005.

  1. Josh83

    Josh83 Thread Starter MacUser Mitglied

    Beiträge:
    702
    Zustimmungen:
    2
    MacUser seit:
    29.11.2005
    Hallo alle

    Umlaute werden bei mir in MySQL sehr seltsam angezeigt. Ich habe schon mit diversen Zeichensätzen experimentiert, aber das hat bisher nichts gebracht...
    Kann mir wer einen Tipp geben, wie ich Umlaute korrekt dargestellt bekomme?

    Danke und Grüsse
    Josh
     
  2. neptun

    neptun MacUser Mitglied

    Beiträge:
    2.017
    Zustimmungen:
    22
    MacUser seit:
    28.09.2003
    Grrr - diese leidigen Umlautprobleme :motz Eben habe ich mich wieder geärgert.
    Statt CocoaMySQL habe ich Navicat in Betrieb.
    Eine korrekte Dartellung in Navicat gelingt: bei den Eigenschaften der "connection" wähle ich UTF-8 .
    Dann exportiere ich meine Daten (z.B. Adressen) als .txt-Datei; dieser Export sieht in SubEthaEdit immer noch gut aus (ggf. "reinterpret" -> UTF-8).
    Ärgerlich wird es dann, wenn ich die Adressen ins Etikettenprogramm (SOHO Labels and Envelopes) importiere: man ist umzingelt von ?© und ähnlichem Kauderwelsch. Und hier finde ich nirgends, wie ich das Format anpassen kann ...
    Ich freue mich auf den Tag, an dem ich das Problem von der Eingabe der Daten bis zur sauberen Darstellung im Griff habe, und schliesse mich zwischendurch den "Umlautgeschädigten" an :D
    Gruss, neptun
     
  3. Josh83

    Josh83 Thread Starter MacUser Mitglied

    Beiträge:
    702
    Zustimmungen:
    2
    MacUser seit:
    29.11.2005
    Werde wohl auch mal noch Navicat anschauen müssen... oder PHP installieren und phpMyAdmin verwenden... Damit war ich eigentlich ganz zufrieden. Allerdings wäre mir ein "richtiges" Programm schon lieber...
     
Die Seite wird geladen...

Diese Seite empfehlen