C compiler cannot create executables - HELP

  1. CrossBone

    CrossBone Thread Starter MacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    27
    Zustimmungen:
    0
    Hi
    also ich bin auf dem Gebiet MAC und GCC ein relativer neuling. Ich möchte unter MacOX 10 ein Programm compilieren. Ich bekomme leider immer folgende Fehlermeldung :

    Code:
    ./configure; 
    loading cache ./config.cache
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... yes
    checking for working aclocal... found
    checking for working autoconf... found
    checking for working automake... found
    checking for working autoheader... found
    checking for working makeinfo... found
    checking for gcc... gcc
    checking whether the C compiler (gcc  ) works... no
    configure: error: installation or configuration problem: C compiler cannot create executables.
    Was kann das Problem sein ? Ich habe die Dev Tools schon installiert.
    Das Programm was ich compilieren möchte ist nicht in XTools erstellt sondern besteht aus mehreren Dateien. Es ist die bb Demo von http://aa-project.sourceforge.net/ falls sie einer kennt. Auf nem Linux und nem Windows läuft sie wunderbar aber ich will sie unbedingt noch auf meinem Mac hinbekommen.

    Denke mal das es mit den Berechtigungen zusammen hängt.
    Habe zwar hier im Forum schon einen anderen Beitag zum ähnlichen Thema gefunden aber dort war keine wirklich Problemlösung zu finden.

    Bitte um hilfe

    CrossY
     
  2. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.157
    Zustimmungen:
    3.884
    configure versucht da ein kleines C prog zu compilieren, und kriegt dabei einen fehler.
    liegt wohl an falschen configure optionen bzw compiler switches...

    mach mal
    ./configure --help
    für die optionen
     
  3. janosch

    janosch MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    1.305
    Zustimmungen:
    6
    developer tools instalieren und dann geht das auch. ich glaube der kann den gcc nicht finden und bricht deshalb ab. Gib doch mal in der konsole gcc ein. da wirste wahrscheinlich einen fehler bekommen ala comand not found oder so.
     
  4. CrossBone

    CrossBone Thread Starter MacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    27
    Zustimmungen:
    0
    also gcc kennt er
    Dev Tools sind installiert
    Habe gerade festgestellt das er nichtmal ein einfache HalloWelt Prog startet.
    Er bringt den Fehler
    Code:
    gcc halllowelt.c
        ld: can't locate file for: -lcrt1.o
    Woran kann das liegen. Finde nirgends etwas dazu.
     
  5. oneOeight

    oneOeight MacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.157
    Zustimmungen:
    3.884
    das sollte in /usr/lib/ liegen. da scheinen deine pfade nicht zu stimmen...
     
  6. janosch

    janosch MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    1.305
    Zustimmungen:
    6
    so ein komische problem hat ich auch mal als ich mir das developer packet instaliert habe hatte ich das mac os x sdk abgewält hinter her ging kein programm mehr zu kompilieren
     
  7. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Ich hab Dich mal ins Entwicklerforum verschoben.
    Ich hoffe dort kann man Dir besser helfen.
     
  8. CrossBone

    CrossBone Thread Starter MacUser Mitglied

    Mitglied seit:
    17.04.2005
    Beiträge:
    27
    Zustimmungen:
    0
    Habe das wahrscheinliche Problem festgestellt
    Habe zwar die Dev Tools installiert habe aber vergessen nach dem Tiger Update neu zu installieren.
    habe zwar grad die Dev CD nich an der Hand aber ich hoffe das es nach der Neuinstallation wieder geht.

    many Thx for your help

    werde das geniale bb wenns geht hier mal zeigen
     
Die Seite wird geladen...