Bootcamp und Catalina - Fehler beim Starten

taxidriverpro

Mitglied
Thread Starter
Mitglied seit
23.02.2010
Beiträge
287
Hallo zusammen,

ich habe nach einer langen Zeit mal wieder versucht mittels Bootcamp Windows zu installieren.
Doch beim starten der App kommt bei ersten klicken auf Weiter nur eine Fehlermeldung:
Ein interner Fehler wäre aufgetreten...

Da ich auf die letzten 6 Versionen immer nur ein upgrade bis hin zu Catalina gemacht hatte, ging ich davon aus, dass sich hier das Problem befand.
Ich löschte also mit Ubuntu alle Portionen auf der internen Platte und installierte Catalina mittels Internet-Recovery neu. Doch das brachte auch keinen Erfolg...

Ich habe auch mehrere Stunden gegoogelt, aber es kommen immer dieselben Treffer, die nichts mit meinem Problem zu tun haben.

Kann es evtl. an der Festplatte liegen, da ich eine normale M2 SSD mittels Adapter in meinen 2017er iMac eingebaut habe oder an der CPU, die ich von der original verbauten i3 auf einen i7 getauscht habe?
Ich denke mal nicht, da sonst alles einwandfrei läuft... Ich hätte nur wirklich gerne wieder Windows auf dem Mac, da ich Sachen mit Excel machen muss, die Excel für Mac nicht beherrscht... und einen zweiten Rechner mit Monitor will ich nicht auch noch extra kaufen.

Habt ihr eine Idee?

Danke und Gruß
Fredy
 

Anhänge

walfreiheit

Aktives Mitglied
Mitglied seit
06.06.2004
Beiträge
27.479
Versuche es ggf. mit einer älteren Version von Windows, zum Beispiel 1803 oder 1809.
 

Froyo1952

Aktives Mitglied
Mitglied seit
14.10.2019
Beiträge
1.127
Crossover wäre eine Alternative, um mit MS-Excel auf dem Mac arbeiten zu können. Probiere doch mal die aktuelle Testversion aus.
 

LuckyOldMan

Aktives Mitglied
Mitglied seit
28.11.2015
Beiträge
1.051
... versucht mittels Bootcamp Windows zu installieren......
In welcher Form liegt Dir Win 10 zur Installation vor?
Schon versucht, ohne BC zu installieren? BC ist teilweise etwas restriktiv und auch nicht immer nötig - je nachdem, welche HW-Konstellation man hat.
 

taxidriverpro

Mitglied
Thread Starter
Mitglied seit
23.02.2010
Beiträge
287
Ich komme überhaupt nicht zur Windows-Installation, weil ich nach dem Starten von Bootcamp und einmal auf weiter klicken schon die Fehlermeldung habe. Ich kann somit weder die Platte Partitionieren, noch kann ich die aktuellsten Treiber installieren.

Die Idee mit ohne Bootcamp hatte ich auch schon, aber das haut irgendwie nicht hin, weil ich mit dem Windows-Setup nicht Partitionieren kann.
 

Zweene

Registriert
Mitglied seit
18.02.2020
Beiträge
4
Hallöchen, das selbe Problem habe ich auch. Ich besitze eine iMac 27 - 2017 und habe die interne HDD ausbauen lassen und eine 2 TB SSD einbauen lassen. Ich lasse die kleine nvme 28 GB und die neueingebaute 2 TB getrenne von einander laufen , also ohne FusionDrive, habe ich deshalb das Problem das Bootcamp nicht richtig funktioniert ?

Danach habe habe ich einen clean Install von Catalina durchgeführt und alles läuft prima ohne Probleme....

Wenn ich also Bootcamp starte bekommen ich die gleiche Fehlermeldung "Es ist ein interner Fehler aufgetreten",
ich habe also nicht die Möglichkeit irgendwelche Einstellungen an Bootcamp vorzunehmen.

Zwischenzeitlich hatte ich das alte OS "High Sierra" installiert......und siehe da man kommt jetzt schon einmal etwas weiter wo man auch die Windows iso Datei auswählen kann,
aber weiter als bis dahin ging es dann auch nicht. Also habe ich wieder Catalian neu installiert und probiere nun ein Weile Windows ohen Bootcamp zu installieren.
Zumindestens bin ich jetzt schon soweit, dass ich kurz davor stehe Windows 10 (1909) zu installieren. Da da gibt es noch kleinere Probleme was das Erstellen/Formatieren der Partition im Windows Setup angeht. Gestern bin ich auf eine Seite gestoßen wo ich denke, dass es sich dabei vielleicht um die Lösung handelt. Denn da geht es um die oder den Bootsektor den Windows zur Installation und Erstellung der Partitionen braucht. Da gibt es wohl eine Software Namens GPT fdisk mit der man den Bootsektor der zukünftigen Windowspartition neu anlegen kann da es wohl bei einem Hybrid MBR zu Fehlermeldungen kommt.

Ich werde mich die nächsten mal neu versuchen und werde dann berichten.

Hat denn irgendeiner die gleichen Probleme und hat neue Lösungsvorschläge oder konnte Windows bereits parallel zu MACOS Catalina installieren ?


Danke
 
Zuletzt bearbeitet:

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
54.735
Zumindestens bin ich jetzt schon soweit, dass ich kurz davor stehe Windows 10 (1909) zu installieren. Da da gibt es noch kleinere Probleme was das Erstellen/Formatieren der Partition im Windows Setup angeht. Gestern bin ich auf eine Seite gestoßen wo ich denke, dass es sich dabei vielleicht um die Lösung handelt. Denn da geht es um die oder den Bootsektor den Windows zur Installation und Erstellung der Partitionen braucht. Da gibt es wohl eine Software Namens GPT fdisk mit der man den Bootsektor der zukünftigen Windowspartition neu anlegen kann da es wohl bei einem Hybrid MBR zu Fehlermeldungen kommt.
eine fehlermeldung bekommst du da je nachdem in welchen modus du windows 10 installierst.
boot camp erstellt dir halt einen hybrid MBR, damit es windows im CSM legacy installieren kann.
das ist notwendig, damit auch alle treiber funktionieren.
wenn du win10 im EFI modus installierst (boot des win installers über den EFI_boot eintrag), dann darf es kein hybrid MBR sondern nur GPT mit dem leeren protective MBR sein.
sonst meckert der win installer es ist MBR.
im EFI modus kannst du natürlich auch installieren, aber teilweise funktionieren dann die boot camp treiber nicht.
ist bei jedem gerät anders, welche dann nicht funktionieren.
 

Zweene

Registriert
Mitglied seit
18.02.2020
Beiträge
4
eine fehlermeldung bekommst du da je nachdem in welchen modus du windows 10 installierst.
boot camp erstellt dir halt einen hybrid MBR, damit es windows im CSM legacy installieren kann.
das ist notwendig, damit auch alle treiber funktionieren.
wenn du win10 im EFI modus installierst (boot des win installers über den EFI_boot eintrag), dann darf es kein hybrid MBR sondern nur GPT mit dem leeren protective MBR sein.
sonst meckert der win installer es ist MBR.
im EFI modus kannst du natürlich auch installieren, aber teilweise funktionieren dann die boot camp treiber nicht.
ist bei jedem gerät anders, welche dann nicht funktionieren.
Also Boot Camp kann ich ja leider nicht nutzen, da ich sofort eine Fehlermeldung bekomme. Also würde ich mir selber eine Partition als fat32 für Windows anlegen und da den Bootsektor auf GPT stellen. Anschließend würde ich dann vom USB-Stick die Installation von Windows starten und während der Installation die Partition auf NTFS formatieren und dann die Installation fortsetzen ! Könnte das so funktionieren ?


Danke Dir schon einmal für die ganzen Tips !!!
 

Andi

Aktives Mitglied
Mitglied seit
16.05.2002
Beiträge
8.664
Ist das Ubuntu auch auf der SSD? Dann wird es eh nix mit MBR legacy.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
54.735
Also Boot Camp kann ich ja leider nicht nutzen, da ich sofort eine Fehlermeldung bekomme. Also würde ich mir selber eine Partition als fat32 für Windows anlegen und da den Bootsektor auf GPT stellen. Anschließend würde ich dann vom USB-Stick die Installation von Windows starten und während der Installation die Partition auf NTFS formatieren und dann die Installation fortsetzen ! Könnte das so funktionieren ?
wenn du boot camp eh nicht benutzt hast, musst du auch nichts umstellen.
dann hast du noch GPT mit protective MBR.

wenn du den win install stick über alt gedrückt bootest nimm wie gesagt den EFI_boot eintrag, nicht den windows.
 

Andi

Aktives Mitglied
Mitglied seit
16.05.2002
Beiträge
8.664
3 Partitionen! EFI Recovery Catalina. ;)
Ubuntu war der Kollege vor Dir sorry.
 

Zweene

Registriert
Mitglied seit
18.02.2020
Beiträge
4
Soooooo, nun ein kleines Fazit .....es hat mich eine Menge Nerven gekostet und ich war kurz davor aufzugeben ! Aber ich habe es nacht ca.5 Stunden doch endlich geschafft ! Wie ich das geschafft habe werde ich in den nächste Tagen bekanntgeben! Ich hatte eine Menge Fehlermeldung von wegen Partitionen können nicht erstellt werden bis zu EFI Boot ist nicht in NTFS formatiert usw. Zwischenzeitlich hatte ich bestimmt 10 Partitionen und habe diese dann mittels Paragon Festplatten Manager wieder gelöscht und damit die Funktion "Bootcamp Bootsektor korrigieren" ausgeführt. Und siehe da Windows (1909) hat sich tatsächlich installieren lassen.

Vielleicht lag es auch daran, dass ich die verbaute 28 GB nvme partition gelöscht hatte und ihr kein Dateisystem zugeordnet hatte, da Windows ja wohl immer ein Problem damit hat nicht auf die erste Festplatte zu installieren.

Ahja den Bootstick habe ich ganz alleine hergestellt : USB-Stick mit exFAT formatiert mit MBR und dann das ISO-File gemountet und einfach auf den Stick geschoben und gleich dazu noch das Bootcamp Windows Support Pack.

Danke erstmal für die vielen Tips ....diese haben mir auch irgendwie geholfen ... !
 
Zuletzt bearbeitet:

Schism

Registriert
Mitglied seit
22.07.2020
Beiträge
1
Soooooo, nun ein kleines Fazit .....es hat mich eine Menge Nerven gekostet und ich war kurz davor aufzugeben ! Aber ich habe es nacht ca.5 Stunden doch endlich geschafft ! Wie ich das geschafft habe werde ich in den nächste Tagen bekanntgeben! Ich hatte eine Menge Fehlermeldung von wegen Partitionen können nicht erstellt werden bis zu EFI Boot ist nicht in NTFS formatiert usw. Zwischenzeitlich hatte ich bestimmt 10 Partitionen und habe diese dann mittels Paragon Festplatten Manager wieder gelöscht und damit die Funktion "Bootcamp Bootsektor korrigieren" ausgeführt. Und siehe da Windows (1909) hat sich tatsächlich installieren lassen.

Vielleicht lag es auch daran, dass ich die verbaute 28 GB nvme partition gelöscht hatte und ihr kein Dateisystem zugeordnet hatte, da Windows ja wohl immer ein Problem damit hat nicht auf die erste Festplatte zu installieren.

Ahja den Bootstick habe ich ganz alleine hergestellt : USB-Stick mit exFAT formatiert mit MBR und dann das ISO-File gemountet und einfach auf den Stick geschoben und gleich dazu noch das Bootcamp Windows Support Pack.

Danke erstmal für die vielen Tips ....diese haben mir auch irgendwie geholfen ... !
Hallo Zweene, hallo an alle,

ich habe das selbe Problem. Habe in meinem iMac 21" 2019 die Fusion Drive durch eine 500GB SSD ersetzen lassen. Catalina inkl neuster Updates ist installiert. Nun möchte ich Bootcamp nutzen um Win10 zu installieren und es kommt die selbe Fehlermeldung: "ein interner Fehler ist aufgetreten".
Kann mir Jemand helfen? Hat es was damit zutun, dass die 28gb-SSD der FusionDrive noch verbaut ist? Ich kenne mich damit nicht sonderlich aus. Nutzen möchte ich die nicht - was soll man mit 28gb auch groß anfangen. Aber egal, ob ich sie im Festplattendienstprogramm aktiviere oder deaktiviere: die Fehlermeldung bleibt gleich.

Das ist eine ziemlich Katastrophe - ich bin seit vielen Jahren Mac-User - aber auch auf Windows angewiesen. Ich will auch kein zweites Gerät kaufen, denn bisher klappte mit Bootcamp stets alles wunderbar.
Ich hoffe, Jemand kann mir mit einer Lösung helfen.


Danke vorab und viele Grüße,
Sebastian
 

Anhänge