Boot Camp: Windows 10 stürzt bei Installation der Grafiktreiber ab

noodyn

Mitglied
Thread Starter
Mitglied seit
16.08.2008
Beiträge
12.198
Hallo zusammen,

Ich betreibe auf meinem 27" 5k iMac (Mid 2017, Mac OS 10.15.4) auch ein Windows 10 (1909 aktuellste Version) per Boot Camp. Ich habe schon bei der Installation bewusst auf die Apple eigenen Treiber verzichtet, da diese zu irreparablen Abstürzen führten und auf den von Windows gelieferten Treiber gesetzt.

Gestern habe ich versucht einen aktuellen Grafiktreiber für die Radeon Pro 575 von bootcampdrivers.com zu installieren. Das Ergebnis war leider identisch.
Sobald Windows den neuen Treiber aktiviert, flackert das Bild kurz, bekommt Streifen, der Ton hängt und der iMac bootet neu. Windows lässt sich nun nicht mehr starten. Daher habe ich die letzte Windows-Sicherung wieder zurückgespielt.
Ich hatte eigentlich gehofft, dass ein aktuellerer Treiber (der jetzige stammt von Windows selbst) evtl. eine bessere Leistung bringen könnte.
Der Betrieb unter Mac OS macht keinerlei Probleme, weder bei Spielen noch im Office Betrieb.
Teilt jemand dieses Problem? Kennt ihr eine Lösung?
 

hr47

Mitglied
Mitglied seit
29.03.2016
Beiträge
2.557
Hallo zusammen,

Ich betreibe auf meinem 27" 5k iMac (Mid 2017, Mac OS 10.15.4) auch ein Windows 10 (1909 aktuellste Version) per Boot Camp. Ich habe schon bei der Installation bewusst auf die Apple eigenen Treiber verzichtet, da diese zu irreparablen Abstürzen führten und auf den von Windows gelieferten Treiber gesetzt.

Gestern habe ich versucht einen aktuellen Grafiktreiber für die Radeon Pro 575 von bootcampdrivers.com zu installieren. Das Ergebnis war leider identisch.
Sobald Windows den neuen Treiber aktiviert, flackert das Bild kurz, bekommt Streifen, der Ton hängt und der iMac bootet neu. Windows lässt sich nun nicht mehr starten. Daher habe ich die letzte Windows-Sicherung wieder zurückgespielt.
Ich hatte eigentlich gehofft, dass ein aktuellerer Treiber (der jetzige stammt von Windows selbst) evtl. eine bessere Leistung bringen könnte.
Der Betrieb unter Mac OS macht keinerlei Probleme, weder bei Spielen noch im Office Betrieb.
Teilt jemand dieses Problem? Kennt ihr eine Lösung?
Hast du mal die Boot Camp-Treiber probiert, die AMD selbst zur Verfügung stellt? Könnte mir vorstellen, das die noch am ehesten funktionieren: https://www.amd.com/en/support/kb/release-notes/apple-boot-camp-previous

Treiber für den iMac 2017 sind in der dortigen Download-liste auch dabei. Oder ist das der Treiber, den du bereits installiert hattest? Ist von Januar 2019.
 

alterjager

Mitglied
Mitglied seit
06.12.2012
Beiträge
776
Hallo zusammen,

Ich betreibe auf meinem 27" 5k iMac (Mid 2017, Mac OS 10.15.4) auch ein Windows 10 (1909 aktuellste Version) per Boot Camp. Ich habe schon bei der Installation bewusst auf die Apple eigenen Treiber verzichtet, da diese zu irreparablen Abstürzen führten und auf den von Windows gelieferten Treiber gesetzt.

Gestern habe ich versucht einen aktuellen Grafiktreiber für die Radeon Pro 575 von bootcampdrivers.com zu installieren. Das Ergebnis war leider identisch.
Sobald Windows den neuen Treiber aktiviert, flackert das Bild kurz, bekommt Streifen, der Ton hängt und der iMac bootet neu. Windows lässt sich nun nicht mehr starten. Daher habe ich die letzte Windows-Sicherung wieder zurückgespielt.
Ich hatte eigentlich gehofft, dass ein aktuellerer Treiber (der jetzige stammt von Windows selbst) evtl. eine bessere Leistung bringen könnte.
Der Betrieb unter Mac OS macht keinerlei Probleme, weder bei Spielen noch im Office Betrieb.
Teilt jemand dieses Problem? Kennt ihr eine Lösung?
Gehe doch auf die AMD Treiberseite.

Wähle Graphics / Mac Graphics / Boot Camp und dann wähle auf der anschließend erscheinenden Treiberseite den Treiber für deinen Mac.

Damit hatte ich noch nie Probleme.

Grüße
 
  • Gefällt mir
Reaktionen: dg2rbf

noodyn

Mitglied
Thread Starter
Mitglied seit
16.08.2008
Beiträge
12.198
Probiere ich heute Abend mal aus. Danke schon mal für den Tipp. Ich finde die AMD Seite echt unübersichtlich.
 

alterjager

Mitglied
Mitglied seit
06.12.2012
Beiträge
776
Wenn das Bild direkt nach der Treiberinstallation seltsam aussieht, einfach mal neu starten und der neue Treiber ist aktiv.

Grüße
 

noodyn

Mitglied
Thread Starter
Mitglied seit
16.08.2008
Beiträge
12.198
Wenn das Bild direkt nach der Treiberinstallation seltsam aussieht, einfach mal neu starten und der neue Treiber ist aktiv.
Genau das funktioniert ja aber nicht. Er lässt sich danach nicht mehr neu starten, da Windows direkt den Start abbricht und ich nicht mal mehr das Anmeldefenster sehe. Windows ist nach der Installation direkt unbrauchbar. Neustart zwecklos. Schon probiert.

Ich teste nachher mal den Treiber von AMD.
 

hr47

Mitglied
Mitglied seit
29.03.2016
Beiträge
2.557
Genau das funktioniert ja aber nicht. Er lässt sich danach nicht mehr neu starten, da Windows direkt den Start abbricht und ich nicht mal mehr das Anmeldefenster sehe. Windows ist nach der Installation direkt unbrauchbar. Neustart zwecklos. Schon probiert.

Ich teste nachher mal den Treiber von AMD.
wenn du im abgesicherten Modus startest, kommst du aber "dran" und kannst das wieder rückgängig machen.
 
  • Gefällt mir
Reaktionen: dg2rbf

noodyn

Mitglied
Thread Starter
Mitglied seit
16.08.2008
Beiträge
12.198
Dran vielleicht. Nur startet Windows dann nicht mehr normal. Ich stelle dann einfach die letzte Sicherung wieder her, die ich vor der Installation angelegt habe. Ich möchte keine Treiberreste haben, die mich später ärgern können.
Gerade mal nachgeschaut:
Unbenannt.PNG
Es ist Treiberversion 25.20 vom 15.3.2019 installiert. Damit ist der installierte Treiber sogar neuer, als der von der AMD Webseite.
Ich entnehme dem, dass es keinen neueren Treiber mehr für die Radeon 575 gibt. Dann kann ich mir die Experimente sparen, denn der Treiber von der AMD Webseite wäre Version 18.40.
 

hr47

Mitglied
Mitglied seit
29.03.2016
Beiträge
2.557
Dran vielleicht. Nur startet Windows dann nicht mehr normal. Ich stelle dann einfach die letzte Sicherung wieder her, die ich vor der Installation angelegt habe. Ich möchte keine Treiberreste haben, die mich später ärgern können.
Gerade mal nachgeschaut:
Anhang anzeigen 291231
Es ist Treiberversion 25.20 vom 15.3.2019 installiert. Damit ist der installierte Treiber sogar neuer, als der von der AMD Webseite.
Ich entnehme dem, dass es keinen neueren Treiber mehr für die Radeon 575 gibt. Dann kann ich mir die Experimente sparen, denn der Treiber von der AMD Webseite wäre Version 18.40.
Für den Fall gibt es von AMD die Software "AMD Cleanup Utility", die einschließlich RegEditor restlos alles entfernt (nicht nur die Treiber, auch sämtliche Sub-Software). Windows verhält sich danach "Grafikkartentechnisch" wie nach einer Neuinstallation. Probier es spaßeshalber einfach mal aus, wenn du es nicht glaubst:) Du hast ja deine Sicherung.
 

noodyn

Mitglied
Thread Starter
Mitglied seit
16.08.2008
Beiträge
12.198
Nach dem Motto "Mut zur Lücke" hab ich mich an die Installation gemacht. Aber es bringt halt wirklich nichts, weil der aktuellste AMD Treiber scheinbar schon über Windowsupdates geliefert wird.
Die Version von AMD ist identisch mit dem Treiber, den Windows mitbringt. Installation zwecklos, es gibt keine neuere Version.
Unbenannt.PNG
 

hr47

Mitglied
Mitglied seit
29.03.2016
Beiträge
2.557
Nach dem Motto "Mut zur Lücke" hab ich mich an die Installation gemacht. Aber es bringt halt wirklich nichts, weil der aktuellste AMD Treiber scheinbar schon über Windowsupdates geliefert wird.
Die Version von AMD ist identisch mit dem Treiber, den Windows mitbringt. Installation zwecklos, es gibt keine neuere Version.
Anhang anzeigen 291253
OK, verstanden.
 

Shald

Mitglied
Mitglied seit
30.08.2008
Beiträge
356
Hey,
falls alle Stricke reißen, hätte ich einen Weg gefunden, den man probieren könnte... ich hoffe englisch macht keine Schwierigkeiten:

„download the latest version of the driver from bootcampdriver, disconnect any internet connection (and re-enable it only when you read it in these steps), restart in safe mode without a network, use the utility inserted in the drivers you just downloaded to remove the amd drivers, restart in windows normally, install the drivers you have downloaded, at the end restart your computer and you can also reactivate the internet.“

Habe mitbekommen, dass dieser Weg bei einigen Nutzern mit einem iMac 5k 2017 geklappt hat, viel Erfolg!

Grüße
 

fischerttd

unregistriert
Mitglied seit
07.11.2019
Beiträge
294
Bei dem Thema kann ich mich auch einklinken.

Ich habe 2 Installationen Windows 10 x64. Eine auf einem MacPro 4.1/5.1 mit NVIDIA GT120 und eine auf einem MacMini mit Nvidia GeForce320M.
Beide Installationen laufen/liefen per "autounattended". (spart einem ein externes Festplattentool)

Wenn man die Festplatte im MBR-Modus betreibt, lassen sich die NVIDIA-Treiber über die Homepage oder über die Bootcamptreiber installieren.
Nachteil: Die Bootverzögerung von ca. 30-35 Sekunden beim Systemstart.

Formatiert man die Festplatten im GPT-Modus, gibt es keine Bootverzögerung.
Dafür lassen sich mitunter die Grafikkartentreiber nicht installieren bzw. führen beim Neustart zu einer Bootschleife und "automatischer Reparatur", welche allerdings fehlschlägt.

Kleiner Tipp: Meine Datensicherung mache ich mit Macrium Reflect. Macrium Reflect biete die Möglichkeit einen EFI-fähigen Bootstick zu erstellen, der dann über ALT auch gestartet werden kann.
Somit kann man im Notfall auch seine Systemsicherung von Windows 7/10 bequem wieder herstellen.
 
  • Gefällt mir
Reaktionen: dg2rbf

Elebato

Mitglied
Mitglied seit
03.04.2017
Beiträge
696
Windows 10 mit GPT - und damit im EFI-Modus - zu installieren, birgt auf dem Mac Pro 4,1/5,1 die Gefahr, sich mit den Windows-Zerifikaten das NVRAM zu zerschießen.
 
  • Gefällt mir
Reaktionen: dg2rbf

Andreas2802

Mitglied
Mitglied seit
01.10.2016
Beiträge
885
Hast du die Windows Treiber mal so in Bootcamp geladen ? Hat bei meinem 2017er iMac wunderbar funktioniert !

Bildschirmfoto 2020-05-05 um 20.13.18.jpg
 

fischerttd

unregistriert
Mitglied seit
07.11.2019
Beiträge
294
Ich verwende beide Macs ohne Bootcamp. Muss ich Deine Frage also verneinen.
 

fischerttd

unregistriert
Mitglied seit
07.11.2019
Beiträge
294
Die beiden Windows 10- Installationen folgen eher dem IKEA-Grundsatz: "Entdecke die Möglichkeiten". Ein Produktivsystem mit W10 ist nicht vorgesehen. Gilt es doch nur die Frage zu beantworten "was machbar/sinnvoll ist". Da installiere ich mir lieber ein aktuelles Linux für ein Produktivsystem ;)
 
  • Gefällt mir
Reaktionen: dg2rbf
Oben