Monterey Bluetooth-Kopfhörer verbinden sich und trennen nach ca. 2 Sekunden wieder

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
Hallo zusammen,

mal wieder das leidige Bluetooth-Thema. Bei mir funktioniert es, jedoch macht mein BT-Kopfhörer Probleme.

Erst einmal ein paar Infos über meinen Mac.

Auf meinem iMac Late 2015 ist MacOS Monterey in der Version 12.0.1 installiert - bereits das zweite Mal da ich dachte, das Bluetooth-Problem damit eleminieren zu können. Leider besteht das Problem weiterhin. Nachfolgend noch ein paar weitere Infos:

- Die Datei "Library/Preferences/ByHost/com.apple.Bluetoothxxxxxxxxxxxxxxxxx.plist" ist bei mir nicht vorhanden
- Wenn ich mit mit gedrückter (Umschalt) und (Option)-Taste auf das Bluetooth-Symbol klicke erscheint kein Debug-Menü
- Nach Eingabe des Terminal-Befehls bluetoothd erscheint folgende Ausgabe:
Code:
com.apple.server.bluetooth: Bluetooth Super Server Robot Destroyer
could not find BT_DEVICE_ADDRESS env variable
com.apple.server.bluetooth: Server attached, going into msg loop.
zsh: abort      bluetoothd

Nun zu meinem Problem: Ich habe Bluetooth-Kopfhörer von DOOAUS, die sich zwar mit Bluetooth verbinden lassen, sich nach ca. 2 Sekunden aber wieder verabschieden. In diesen zwei Sekunden werden mir die Kopfhörer auch im Ton-Menü als Ausgabequelle angezeigt.
Nachdem ich dann 5-10mal im Bluetooth-Menü auf die Kopfhörer geklickt habe sind diese dann dauerhaft mit Bluetooth verbunden, werden aber im Ton-Menü nicht als Ausgabegerät angezeigt, so dass diese nicht benutzt werden können.

Hat jemand eine Idee, wie der Fehler zu lokalisieren und zu beseitigen ist?


Liebe Grüße, Frank.
 

MDmac64

Aktives Mitglied
Dabei seit
26.02.2006
Beiträge
1.193
Punkte Reaktionen
194
Hallo,
dein iMac Late 2015 hat Bluetooth Version 4.0. Deine Kopfhörer haben eventuell Bluetooth Version 5.0 ?
Vielleicht ist das der Grund; siehe auch KLICK
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
Hallo MDmac64,

stimmt, das wird wohl das Problem sein - da bin ich nicht drauf gekommen.

Ich habe mir mal von TP-Link ein USB Dongle mit Bluetooth 4.0 bestellt und teste das mal aus. Ansonsten muss ich mir Kopfhörer mit BT 4.0 anschaffen.

Vielen Dank für den Denkanstoss!!!


Mit freundlichen Grüßen, Frank.
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
Sorry, Schreibfehler :). Ich habe den Dongle natürlich mit Bluetooth 5.0 bestellt.
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
So, der Dongle ist heute angekommen. Eingesteckt und es tut sich nix. Ob mit aktiviertem oder deaktiviertem Bluetooth. Und nun? Falscher Dongle?
 

Hotze

Aktives Mitglied
Dabei seit
16.06.2003
Beiträge
15.004
Punkte Reaktionen
2.083
Taucht der Dongle in den Systeminformationen auf? Welcher genau? Braucht der Treiber?

Bluetooth ist eigentlich abwärtskompatibel. BT 5 Kopfhörer brauchen also nicht unbedingt BT 5 um zu funktionieren.

Schau mal ob es Firmwareupdates für den Kopfhörer gibt. Ist bei günstigen Geräten eher nicht so oft der Fall aber kann ja sein. Funktioniert der mit anderen Geräten problemlos?
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
Hallo Hotze!

Ja, den Dongle finde ich in den Systeminformationen. So steht's geschrieben:

Code:
TP-Link UB500 Adapter:
  Produkt-ID:    0x0604
  Hersteller-ID:    0x2357
  Version:    2.00
  Seriennummer:    E848B8C82000
  Geschwindigkeit:    Bis zu 12 MBit/s
  Hersteller:     
  Standort-ID:    0x14400000 / 4
  Verfügbare Stromstärke (mA):    500
  Zusätzlicher Betriebsstrom (mA):    0

Die Kopfhörer funktionierten problemlos unter Windows 10 und 11. Da ich umgestiegen bin steht mir nur noch ein iMac Late 2015 und ein MacBook Pro Early 2015 zur Verfügung. Aber ich kann ja mal nach einem Firmwareupdate für den Kopfhörer suchen.

Das Blöde ist, dass der Kopfhörer bei beiden Geräten von Monterey erkannt wird, sich auch verbindet aber die Verbindung sofort wieder abbricht.
 

Hotze

Aktives Mitglied
Dabei seit
16.06.2003
Beiträge
15.004
Punkte Reaktionen
2.083
Kann sein, dass der Handshake zwischen den Geräten nicht richtig funktioniert. Am Handy klappt es? Idealerweise ein iPhone?

Hast du eine BT Maus oder Tastatur dran?
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
Leider verfüge ich nicht über ein iPhone, am Huawei Android-Handy klappt es.

Tastatur und Maus von Apple funktionieren, Tastatur und Maus von Jelli Comb funktionieren über BT auch. Die habe ich jetzt mal über 2.4G angeschlossen (stehen 1x 2.4G und 2x Bluetooth 4.0 zur Verfügung), so dass auf dem Mac aktuell kein anderes Bluetooth-Gerät angeschlossen ist.
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
Moin, macOS 12.1 ist bereits seit Dienstag installiert. Gleiches Problem 😒
 

MDmac64

Aktives Mitglied
Dabei seit
26.02.2006
Beiträge
1.193
Punkte Reaktionen
194
Ist es dieser Adapter? KLICK
Wenn ja, dort steht: "Unterstütztes Betriebssystem – Windows 10/8.1/7"
 

MDmac64

Aktives Mitglied
Dabei seit
26.02.2006
Beiträge
1.193
Punkte Reaktionen
194
Sind es diese Kopfhörer? KLICK
Dort steht: "Wichtige Informationen, Warnhinweise
【Anleitung zurücksetzen】
Wenn Sie ein Problem mit dem System haben, versuchen Sie bitte, die Kopfhörer zurückzusetzen, um es zu beheben.
Die Reset-Taste ist in die AUX-Buchse integriert. Unter bestimmten unsicheren Bedingungen sind die Kopfhörer gestört und müssen aktiviert werden. Bitte verwenden Sie eine Schraube oder ein anderes kleines Ding, das in die AUX-Buchse eingesetzt werden kann, und drücken Sie die Reset-Taste im Inneren. Schalten Sie dann das Gerät wieder ein.
Wenn dies nicht geklärt werden kann, kontaktieren Sie uns bitte und wir werden Ihnen von ganzem Herzen dienen."
E-Mail: support@doqaus.com
 

Hotze

Aktives Mitglied
Dabei seit
16.06.2003
Beiträge
15.004
Punkte Reaktionen
2.083
Ist es dieser Adapter? KLICK
Wenn ja, dort steht: "Unterstütztes Betriebssystem – Windows 10/8.1/7"
Das heißt nix. Sind meistens doch universal für alle Betriebssysteme verwendbar. Außer man muss unter Windows schon explizit Treiber installieren. Aber bei solchen BT Adaptern kommt das eigentlich nie vor. Ausnahmen bestätigen die Regel, aber bei TP Link funktionieren die alle ohne irgendwas. Hatte noch keine Probleme.
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
So, nun habe ich die Zeit und habe mal wieder etwas rumgebastelt. Ich gebe Euch ein paar Infos über den Stand der Dinge:

- TP-Link UB500 funktioniert weder auf dem MacBook noch auf dem iMac. Der Dongle wird zwar im Systembericht angezeigt, aber sonst tut sich nix.
- Der Tipp mit dem Kopfhörer-Reset war nicht schlecht. Diese Funktion kannte ich noch nicht. Aber die Dinger funktionieren nach dem Reset auch nicht besser.

Also wieder auf Anfang. Ich habe das interne Bluetooth aktiviert, die Kopfhörer eingeschaltet und sie werden erkannt. Nach ca. 2 Sekunden bricht die Verbindung wieder ab. Wenn ich dann 3-6mal im Bluetooth-Menü auf den Kopfhörer klicke, sind sie irgendwann verbunden. Das würde mich nicht weiter stören, jedoch erscheinen die Dinger nicht im Ton-Menü, so dass sie nicht als Ausgabequelle ausgewählt werden können. Im Systembericht erscheinen die Kopfhörer (wie der TP-Link auch). Dort steht Folgendes:

Code:
Gekoppelte Bluetooth-Geräte:
  DOQAUS CARE 1:
  Adresse:    94:47:00:A7:9F:92
  Hersteller-ID:    0x05D6
  Produkt-ID:    0x000A
  Firmwareversion:    2.4.0
  Minor Type:    Headset
  RSSI:    -35

Und was jetzt? Anderen Dongle oder Kopfhörer mit BT 4.0 kaufen? Oder hat jemand noch eine Idee?


Liebe Grüße, Fank.
 

herberthuber

Aktives Mitglied
Dabei seit
04.11.2018
Beiträge
1.116
Punkte Reaktionen
958
@Frank44 : Falls Du einen Apple Developer Account haben solltest (ist meines Wissens nach kostenlos bei Apple erstellbar), dann könntest Du Dir das Apple Tool "Bluetooth Explorer" herunterladen. Damit sind weitere technischen Details der Bluetooth Verbindungen einsehbar und es wird ein Logfile erstellt. Darin könnten dann weitere Gründe für das ständige Disconnect aufgeführt sein.
 

Frank44

Neues Mitglied
Thread Starter
Dabei seit
13.12.2021
Beiträge
14
Punkte Reaktionen
6
@Frank44 : Falls Du einen Apple Developer Account haben solltest (ist meines Wissens nach kostenlos bei Apple erstellbar), dann könntest Du Dir das Apple Tool "Bluetooth Explorer" herunterladen. Damit sind weitere technischen Details der Bluetooth Verbindungen einsehbar und es wird ein Logfile erstellt. Darin könnten dann weitere Gründe für das ständige Disconnect aufgeführt sein.

Sorry, dafür das ich die beiden Macs erst 14 Tage besitze ist mir das zu aufregend. Schließlich bin ich durch das unausgereifte und mit Altlasten behaftete Windows 11 zu Apple gewechselt. Dachte nicht, dass ich vom Regen in die Traufe komme :)
 

herberthuber

Aktives Mitglied
Dabei seit
04.11.2018
Beiträge
1.116
Punkte Reaktionen
958
Irgendwie habe ich diesen Developer Account (_Nicht_ Developper Program) kostenlos anlegen können.
Aber egal, habe gerade nachgesehen und der Bluetooth Explorer scheint ab Big Sur nicht mehr problemlos zu funktionieren.... :(
 
Oben Unten