Bildschirmauflösung SUSE Linux 10.0 unter parallels

  1. der_ro

    der_ro Thread StarterMacUser Mitglied

    Mitglied seit:
    15.10.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Hallo zusammen!

    Ich möchte auf meinem MacBook unter parallels auch SUSE Linux 10.0 benutzen. Die Installation hat problemslos geklappt. Leider kann ich im Vollbildmodus nicht die optimalen 1280x800 Pixel einstellen; es kommt eine Fehlermeldung (-> siehe Anhang)

    Hat jemand Tipps zur Lösung dieses Problems?

    Gruß,

    Ro
     
    der_ro, 23.10.2006
  2. der_ro

    der_ro Thread StarterMacUser Mitglied

    Mitglied seit:
    15.10.2006
    Beiträge:
    29
    Zustimmungen:
    0
    oh Bild war glaub ich nicht dabei! jetzt aber!
     

    Anhänge:

    • suse_sax_parallels.jpg
      Dateigröße:
      43,5 KB
      Aufrufe:
      64
    der_ro, 23.10.2006
  3. walfrieda

    walfriedaMacUser Mitglied

    Mitglied seit:
    29.03.2006
    Beiträge:
    8.959
    Zustimmungen:
    1.133
    kein Anhang zu sehen...

    edit: jetzt schon...
     
    walfrieda, 23.10.2006
  4. walfrieda

    walfriedaMacUser Mitglied

    Mitglied seit:
    29.03.2006
    Beiträge:
    8.959
    Zustimmungen:
    1.133
    hatte letzthin das selbe Problem mit Kubuntu. Da war über die GUI nix zu machen, aber eine manuelle Konfiguration hat geholfen. Mit Suse kenn ich mich leider nicht aus, aber es gibt dort sicher auch ein Konsolenprogramm, mit dem Du den xserver (xorg?) manuell konfigurieren kannst, so wie dpkg-reconfigure beim (Debian-basierten) Kubuntu. Dort musst Du die möglichen Auflösungen eingeben, eben 1280x800. Restart des xservers - fertig.
     
    walfrieda, 23.10.2006
  5. der_ro

    der_ro Thread StarterMacUser Mitglied

    Mitglied seit:
    15.10.2006
    Beiträge:
    29
    Zustimmungen:
    0
    Erstmal vielen Dank für die schnelle Antwort!

    Die Konfiguration des XServers habe ich unter /etc/X11/xorg.conf gefunden.

    Dort scheinen die möglichen Video-Modi hinterlegt zu sein; also habe ich alle bis auf 1280x800 rausgelöscht. Das ändert leider nichts.

    Hab' ich was falsch gemacht?
     
    der_ro, 23.10.2006
  6. der_ro

    der_ro Thread StarterMacUser Mitglied

    Mitglied seit:
    15.10.2006
    Beiträge:
    29
    Zustimmungen:
    0
    der_ro, 23.10.2006
  7. walfrieda

    walfriedaMacUser Mitglied

    Mitglied seit:
    29.03.2006
    Beiträge:
    8.959
    Zustimmungen:
    1.133
    sollte ok sein, eigentlich. Hast Du Deinen xserver neu gestartet? Oder das Linux komplett? Eines von beidem mußt du auf jeden Fall machen, damit die Änderungen übernommen werden.

    Schau mal in die erste 10-20 kommentierten Zeilen der xorg.conf-Datei. Möglicherweise findest Du dort einen Hinweis, mit welchem Programm man den xserver konfigurieren kann. Bei Debian (und damit Kubuntu) ist das sudo dpkg-reconfigure xserver-xorg - aber das ist Debian-spezifisch und wird bei Suse nicht funktionieren. Die Datei selber zu editieren, so wie Du es gemacht hast, ist aber eigentlich auch ok.

    Die wichtigen Dinge fürs Display sind fast ganz unten in der Datei. Es sind die Sections "Device","Monitor" und "Screen". In der "Screen"-Section musst Du dann für jede Farbtiefe (1, 4, 8, 15, 16, 24 Bit) die Modes festlegen. Bei mir sind es "1280x800", "1024x768", "800x600" und "640x480". Die beiden niederauflösenden Modi sollten auf jeden Fall erhalten bleiben, als Rückfallstrategie des xservers.

    Der entsprechende Teil sieht bei mir so aus:

    Code:
    Section "Device"
    	Identifier	"Generic Video Card"
    	Driver		"vesa"
    	BusID		"PCI:0:2:0"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	28-64
    	VertRefresh	43-60
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Generic Video Card"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1280x800" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    	InputDevice     "stylus" "SendCoreEvents"
    	InputDevice     "cursor" "SendCoreEvents"
    	InputDevice     "eraser" "SendCoreEvents"
    EndSection
    

    edit: zu spät, hab dazwischen mal zu Abend gegessen ;)
     
    walfrieda, 23.10.2006
Die Seite wird geladen...
Ähnliche Themen - Bildschirmauflösung SUSE Linux
  1. HiQ
    Antworten:
    0
    Aufrufe:
    786
  2. swizz
    Antworten:
    21
    Aufrufe:
    4.919
  3. squa2503
    Antworten:
    11
    Aufrufe:
    1.024
    squa2503
    13.08.2008
  4. robert170
    Antworten:
    6
    Aufrufe:
    931
    robert170
    23.04.2008
  5. hagbard86
    Antworten:
    0
    Aufrufe:
    475
    hagbard86
    20.02.2008