Big Sur für ältere Macs?

Blackjack2020

Neues Mitglied
Registriert
15.11.2020
Beiträge
10
Hi
Habe ihr ein Macbook Ende 2009 , beim Patchen mit Bensova funktioniert alles bis zum Booten wenn das Auswahlmenü kommt zB. macOS inst. dann geht USB und Tastatur nicht mehr und ich komme nicht mehr weiter .
Wäre ja nicht schlimm wenn es nicht klappt war ein versuch oder habt ihr noch Tipps evtl Trier für das USB oder Tastatur .
Gruß
 

CwS 2021

Mitglied
Registriert
21.12.2020
Beiträge
221
Hi
Habe ihr ein Macbook Ende 2009 , beim Patchen mit Bensova funktioniert alles bis zum Booten wenn das Auswahlmenü kommt zB. macOS inst. dann geht USB und Tastatur nicht mehr und ich komme nicht mehr weiter .
Wäre ja nicht schlimm wenn es nicht klappt war ein versuch oder habt ihr noch Tipps evtl Trier für das USB oder Tastatur .
Gruß
Ich habe dasselbe problem mit VMware
 

wernichtfragt

Neues Mitglied
Registriert
05.02.2021
Beiträge
40
Hi
Habe ihr ein Macbook Ende 2009 , beim Patchen mit Bensova funktioniert alles bis zum Booten wenn das Auswahlmenü kommt zB. macOS inst. dann geht USB und Tastatur nicht mehr und ich komme nicht mehr weiter .
Wäre ja nicht schlimm wenn es nicht klappt war ein versuch oder habt ihr noch Tipps evtl Trier für das USB oder Tastatur .
Gruß
Ich habe ebenfalls das identische Problem.

Auf meinem iMac 21“ aus 2012 lief alles ohne Probleme - bei meinem MacBook Air 11“ aus 2010 habe ich mit unterschiedlichen Patchern exakt das selbe Phänomen:

Weder die interne Tastatur, noch das interne Trackpad und auch keine über USB angeschlossenen Eingabegeräte funktionieren.

Hat jemand hier einen Lösungsansatz?
 
Zuletzt bearbeitet:

Macschrauber

Aktives Mitglied
Registriert
08.02.2014
Beiträge
8.041
Manche haben Erfolg mit einem Hub dazwischen.

USB 1 Geräte sind immer noch zickig mit Big Sur.
 

Mel Linus

Mitglied
Registriert
17.11.2009
Beiträge
172
bei dem alten MacBook 13 (white 2009) von meiner Frau hatten wir ab Mojave (mit DosDude1s Patch) auch das Problem (eigentlich immer nach jedem größeren Update). Nochmal neu Patchen hat es aber jedesmal wieder repariert, ich habe für diesen und andere Zwecke eine externe Festplatte mit den (gepatchen) Installationsmedien.
 

thon

Mitglied
Registriert
02.05.2010
Beiträge
125
Hat grad ne neue Version mit besserer Benutzer Oberfläche rausgebracht
 

wernichtfragt

Neues Mitglied
Registriert
05.02.2021
Beiträge
40
Gibt es eigentlich Fortschritte im Bereich "Aktualisierung eines bereits erfolgreich gepatchten Systems"?

Oder ist immer noch der gesamte Workflow für ein Update zwingend notwendig?
 

Der Reisende

Aktives Mitglied
Registriert
27.12.2011
Beiträge
2.755
Ich nutze Patched Sur und kann seit der letzten Version Updaten. Muss danach die Kext Dateien neu patchen.
 

wernichtfragt

Neues Mitglied
Registriert
05.02.2021
Beiträge
40
Hört sich sehr gut an, danke.

Muss das System für Updates über Patched Sur zuvor auch mit Patched Sur installiert worden sein? Ich hatte hierfür

big-sur-micropatcher​

verwendet.
 

maccoX

Aktives Mitglied
Registriert
15.02.2005
Beiträge
13.147
Ist die Info noch aktuell, dass beim Mini 2012 damit kein W-LAN funktioniert?
 

ericsson

Mitglied
Registriert
19.11.2003
Beiträge
78
Habe an einem Mac mini Late 2012 mit BenSova-Patches-Sur Big Sur installiert.
Wollte mir mal anschauen, wie das neue System so aussieht, weil ich mit Mojave unterwegs bin.
Das W-LAN funktioniert, weil nach der Installation
KextPatches gemacht werden können. Was mir auffiel: Dass es ohne ein Catalina System nicht funktioniert hat. Das brauchte ich als Basis, um ein Installations-Startsystem zu erstellen. Es kann eine USB Platte statt eines Sticks benutzt werden. System Dateien konnte ich vorab bei mrmacintosh.com laden.Mit dem ccc Cloner, ließ sich das System auf eine andere USB-SSD Platte startfähig kopieren. Allerdings konnte ich beim Clone das Big Sur System über die Systemeinstellungen nicht als ständiges Startsystem auswählen. Fehlermeldung: Ausführen von Bless zum Platzieren der Bootdateien fehlgeschlagen. Der alte Lide 100 Canon Scanner funktioniert.
 

Grobi112

Aktives Mitglied
Registriert
11.04.2005
Beiträge
2.353
"Ausführen von Bless zum Platzieren der Bootdateien fehlgeschlagen"

Das klingt für mich nach einem aktiven SIP.
Boote mal in die Recovery-Umgebung, wähle oben in der Leiste "Terminal" aus und gib:

csrutil disable

gefolgt von der Eingabetate ein.

Danach einen neuen Versuch unternehmen ob der Bless Befehl danach funktioniert.
Wäre zumindest einen Versuch wert. :)
Eigentlich sollte da kein Problem auftreten, aber bei den gepatchten Sachen KÖNNTE eine Lösung sein.

Egal ob es klappt oder auch nicht, kannst Du SIP einfach wieder einschalten.
Gleicher Weg wie oben nur

csrutil enable

verwenden.
 

ericsson

Mitglied
Registriert
19.11.2003
Beiträge
78
SIP ist disabled, in dem System, dass ich per Clean Install erneut auf die Externe gespielt habe.
Das wird der Patcher so eingestellt haben. Hiermit ist das "Blessen" kein Problem.
Das Clone System ist schon wieder gelöscht. Mal schauen, wie es dort eingestellt ist,
wenn ich einen neuen CCC Versuch mache.
 
Oben