Benutzerdefinierte Suche

Benutzerrechte werden automatisch deaktiviert

  1. mac_Reini

    mac_Reini Thread StarterMacUser Mitglied

    Mitglied seit:
    28.08.2004
    Beiträge:
    18
    Zustimmungen:
    0
    Hallo allerseits, ich bin ein Neuling und habe leider ein selsames Verhalten an meinem schönen neuen eMac festgestellt. Die von apple konnten mir leider nicht ad hoc ein Lösung für mein Problem sagen.
    Ich habe mich als Admin angemeldet und gehe dann in die Systemeinstellung, um dort einen "normalen" Benutzer einzurichten. Das funktioniert alles im Prinzipt, aber wenn der Benutzer zugriff auf alle Programme bekommen soll, dann funktioniert das eben nicht mehr. Ich habe z.B. dvdbackup installiert und dieses Programm kann ich nur als Admin starten. Als einfacher User bekomme ich die Meldung, das ich nicht die nötigen Rechte hierzu besitze.
    Ihr könnt das bei euren System nachfahren, die von apple haben auch gestaunt. Einfach für den Benutzer ale Programme aktivieren, dann die Maske verlassen, also z. B. zum Admin wechseln, dann wieder in den User und wie von geisterhand sind einige Programme nicht mehr selektiert.
    Kann mir vielleicht jemand hirzu einen Rat geben.
    Ich habe 10.3.5 mit alle Updates geladen.
    Danke für die Hilfe
    Reini
     
    mac_Reini, 27.10.2004
  2. Placebo

    PlaceboMacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    210
    Zustimmungen:
    0
    Wenn du einen neuen User anlegst, mußt du die Option <Keine Einschränkungen> in den Systemeinstellungen wählen wenn er alle Programme ausführen soll. Und wenn der User zusätzlich Administrative Fähigkeiten besitzen soll, braucht er zusätzlich auch noch das Häkchen unten > daß der User den Computer verwalten darf.

    Viele Programme greifen auf das System zu. Diese Zugriffe werden untersagt wenn man dem User die Programme unter der Option <Bestimmte> oder <Einfachen Finder> zuordnet. Diese Benutzer dürfen dann nur die Programme öffnen, aber wenn diese auf Librarys des Systems zugreifen werden sie geblockt.

    Falls es bei dir eine andere Ursache gibt, repariere die Zugriffsrechte mit deinem Diskutil, möglichst mit der Start-CD deines Rechners. Überprüfe auch die Rechte deines Programmordners, gegebenfalls fehlen dir auch Ressourcen und du mußt etwas neu installieren. Achte auch darauf, daß die Daten im Bereich /Library/Receipts alle korrekt abgelegt und vollzählig sind. Ohne diese können deine wichtigen Programmpackete und Systemdaten nicht mehr korrekt repariert werden.
     
    Placebo, 28.10.2004
  3. abgemeldeter Benutzer

    abgemeldeter Benutzer

    Schmeiß mal die Datei /Library/Managed Preferences/Benutzername/com.apple.applicationaccess.plist in den Müll und mach die Einstellungen neu. (Oder halt "Keine Einschränkungen" auswählen, wenn es eh alle Programme sein sollen.)
     
    abgemeldeter Benutzer, 28.10.2004
  4. Placebo

    PlaceboMacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    210
    Zustimmungen:
    0
    Also ._ut fährt hier möglicherweise schon System 10.3.6 oder noch höher, nehme ich mal an. Bei OS X, 10.3.5 gibt es nämlich noch kein Verzeichnis >Managed Preferences< im Library-Ordner.

    Aber das erfahren wir ja gleich jeden Moment womit das genau zusammenhängt ???
     
    Placebo, 28.10.2004
  5. abgemeldeter Benutzer

    abgemeldeter Benutzer

    Den gab es sogar schon in Jaguar.
    Der Ordner /Library/Managed Preferences wird angelegt, sobald man für einen Benutzer unter "Bestimmte" oder "Einfacher Finder" Einstellungen vergibt bzw. sobald sich solch ein Benutzer anmeldet.
     
    abgemeldeter Benutzer, 28.10.2004
  6. mac_Reini

    mac_Reini Thread StarterMacUser Mitglied

    Mitglied seit:
    28.08.2004
    Beiträge:
    18
    Zustimmungen:
    0
    Vielen Dank für die vielen guten Ratschläge.
    Wenn ich "keine" im Ordner der Systemsteuerung selktiere, dann funktioniert es, no problem.
    Den Ordner /Library/Managed Preferences/Benutzername/com.apple.applicationaccess.plist muß ich erst mal suchen ich melde mich dann wieder.
    Danke
    Reini der Glückliche
     
    mac_Reini, 29.10.2004
  7. mac_Reini

    mac_Reini Thread StarterMacUser Mitglied

    Mitglied seit:
    28.08.2004
    Beiträge:
    18
    Zustimmungen:
    0
    @._ut
    Leider hat Placebo wohl recht, ich hatte mich nun kurz als Admin eingelogt um den Systemordner "Managed Preferences" zu suchen, leider ohne Erfolg, slch einen Ordner gibt es auf meinem Mac nicht.
    Das Sytem ist noch sehr jungfreudig, da ich den Rechner erst 2 Monate habe.
    Die Erklärung von Placebo scheint mir auch seh plausibel, den gerade das Tool dvdbackup kopiert ja eine dvd auf die Festplatte, und da ist es aus meiner Sicht sehr wahrscheinlich, dass man auf Funktion des Systems zugreift.
    Reini
     
    mac_Reini, 29.10.2004
  8. abgemeldeter Benutzer

    abgemeldeter Benutzer

    ... und der Ordner verschwindet unter Panther (unter Jaguar war das noch nicht so), sobald sich der Benutzer mit Einschränkungen wieder abmeldet.
    Die eigentlichen Einstellungen werden aber in der Netinfo-Datenbank gespeichert und dann beim Anmelden in die besagte Datei übertragen.
    Daher ist mein Tip von oben irrelevant.

    Die Systemprogramme befinden sich in der besagten Datei im Key "AllwaysAllowedList", welcher automatisch mit angelegt wird. Außerdem gibt es noch einen Wert "ApprovedAppLaunchesOthers", der normalerweise auf "true" gesetzt ist. Die freigegebenen Programme dürfen also andere Programme, wie Hilfsprogramme oder Systemprozesse etc., starten. Daran liegt es also höchstwahrscheinlich nicht.
     
    abgemeldeter Benutzer, 29.10.2004
Die Seite wird geladen...
Ähnliche Themen - Benutzerrechte werden automatisch
  1. Neons111
    Antworten:
    1
    Aufrufe:
    92
    Schiffversenker
    08.07.2017
  2. LowFlow

    Benutzerrechte

    LowFlow, 13.12.2016, im Forum: Mac OS
    Antworten:
    4
    Aufrufe:
    207
    LowFlow
    13.12.2016
  3. chaase
    Antworten:
    1
    Aufrufe:
    352
    Olivetti
    08.10.2016
  4. rideboarder
    Antworten:
    0
    Aufrufe:
    311
    rideboarder
    01.02.2013
  5. Herr Kolb
    Antworten:
    4
    Aufrufe:
    371
    Herr Kolb
    01.01.2013