Benutzerdefinierte Suche

Benutzer spurlos verschwunden !!!

  1. Katheta

    Katheta Thread StarterMacUser Mitglied

    Mitglied seit:
    23.08.2003
    Beiträge:
    171
    Zustimmungen:
    0
    so jetzt wird komisch.
    Ich habe auf meinem MacBookPro bis gestern prima und glücklich gearbeitet.
    Nachdem allerdings dem guten Stück der Saft ausgegangen ist, und ich nach einem Neustart mittels BootCamp in Windows gearbeitet habe, tritt nun folgendes Problem auf.....

    Wenn ich OSX wieder starten will, kommt der Anmeldescreen (den ich nie aktiviert habe) und ich tippe brav meinen Namen und Passwort ein.
    Aber OSX sacht: NEIN - falsch - Nein - nein.

    Schade dachte ich mir - dann startest du mal von CD (bzw. DVD) und überprüfst alle Rechte etc. und setzt das Passwort einfach wieder zurück. Wird schon klappen.

    Pustekuchen - Wenn ich das Passwort zurück setzten will, kann ich in der üblichen Liste nicht einen einzigen Benutzer sehen - werder admin noch meine Wenigkeit. Alle wech ?!

    Hat jemand eine Idee wie ich mich wieder ganz normal auf meinem System anmelden kann ?!


    Besten Dank

    K.
     
    Katheta, 14.07.2006
  2. xr2-worldtown

    xr2-worldtownMacUser Mitglied

    Mitglied seit:
    29.12.2005
    Beiträge:
    3.366
    Zustimmungen:
    131
    Start mal von CD und öffne das Festplattendienstprogramm. Dort kannst du dann die Rechte reparieren lassen. Wenn du Glück hast, bringt es was. ;)
     
    xr2-worldtown, 14.07.2006
  3. Katheta

    Katheta Thread StarterMacUser Mitglied

    Mitglied seit:
    23.08.2003
    Beiträge:
    171
    Zustimmungen:
    0
    Naja - das hab ich ja geschrieben, dass ich genau das schon gemacht habe. Hat gar nix gebracht :-(
     
    Katheta, 14.07.2006
  4. xr2-worldtown

    xr2-worldtownMacUser Mitglied

    Mitglied seit:
    29.12.2005
    Beiträge:
    3.366
    Zustimmungen:
    131
    Sorry, das hab ich wohl überlesen. :(
     
    xr2-worldtown, 14.07.2006
  5. Gerundium

    GerundiumMacUser Mitglied

    Mitglied seit:
    22.10.2005
    Beiträge:
    1.997
    Zustimmungen:
    69
    Die Benutzer sind mit Sicherheit noch da. Es hat den Anschein, als wäre deine NetInfo-Datenbank defekt. Mir ist nicht bekannt, wie man die Datenbank reparieren kann. Dennoch lässt sich das Problem lösen. Die Frage ist: Wie sehr bist du dem Terminal zugetan?

    Auf jeden Fall ist ein Backup deiner Daten sinnvoll. Dazu schließt du dein Book mittels Target-Disk-Modus an einen anderen Mac an und sicherst dann die Daten auf den diesen Mac. So präpariert laufen alle folgenden Aktionen ungenierter.
     
    Gerundium, 14.07.2006
  6. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Wenn man ein funktionsfähiges Backup der Netinfo Datenbank hat, kann man si im Single User Modus reparieren (bzw. zurücksichern).
    Mit den periodic Jobs wird die Netinfo Datenbank täglich gesichert (alte Backups werden dabei überschrieben).

    Das Backup befindet sich in der Datei "/var/backups/local.nidump".
    Es empfielt sich, ein Kopie dieser Datei an einen anderen Ort zu verschieben, um das tägliche Überschreiben zu verhindern.

    Du könntest nun in den SU-Modus booten und nachsehen, ob Du ein solches Backup hast und wie alt es ist (hoffentlich nicht mit der defekten Datenbank bereits überschrieben).
     
    maceis, 14.07.2006
  7. design11

    design11MacUser Mitglied

    Mitglied seit:
    09.01.2005
    Beiträge:
    1.132
    Zustimmungen:
    48
    Danke für den wertvollen Tip!!
    Wo finde ich die betreffende Datei? Über Ablage>Suche bin ich unter keinem der Worte fündig geworden. Oder erst ab Tiger (habe 10.3.9) ?
     
    design11, 14.07.2006
  8. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Das war auch unter 10.3 und früher schon so.

    Die Datei ist allerdings nur für root lesbar.
    Mir ist nicht ganz klar, wie Du nach "Ablage > Suche" kommst, wenn Du Dich nicht anmelden kannst.

    Wenn Du in den Single User Modus bootest, kannst Du folgendes eingeben, um zu sehen, ob ein backup da ist und wie alt es ist.
    Code:
    ls -la /var/backups/local.nidump
    HTH
     
    maceis, 14.07.2006
  9. Katheta

    Katheta Thread StarterMacUser Mitglied

    Mitglied seit:
    23.08.2003
    Beiträge:
    171
    Zustimmungen:
    0
    Ok das Backup ist da - und das ganze Ding ist vom 28.06.06.
    Also alt genung um noch zu funktionieren - wie bekomme ich es denn nu zurück gesichert !?
     
    Katheta, 14.07.2006
  10. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Hier gibt es eine ältere Anleitung.
    Den Schritt Nummer 8 musst Du ersetzen durch das Kommando
    Code:
    sh /etc/rc
    Vierl Erfolg!
     
    maceis, 14.07.2006
Die Seite wird geladen...
Ähnliche Themen - Benutzer spurlos verschwunden
  1. Sparrow-White
    Antworten:
    2
    Aufrufe:
    82
  2. Lamina
    Antworten:
    12
    Aufrufe:
    384
  3. niggy
    Antworten:
    6
    Aufrufe:
    184
  4. wenevercomeback
    Antworten:
    10
    Aufrufe:
    227
    wenevercomeback
    28.04.2017
  5. raeng01
    Antworten:
    9
    Aufrufe:
    689
    raeng01
    21.02.2014
Benutzerdefinierte Suche