`´ bei LaTeX

Diskutiere das Thema `´ bei LaTeX. Wenn ich in meiner Diplomarbeit unter anderem diese Akzente verwende, kommt als Ausgabe immer...

Friedemann

Mitglied
Thread Starter
Mitglied seit
19.10.2003
Beiträge
3.052
Wenn ich in meiner Diplomarbeit unter anderem diese Akzente verwende, kommt als Ausgabe immer ein O mit einem Kringel drüber, aber nicht z.B. das von mir gewünschte é. Mit welchem Paket ändere ich dieses Problem?

Dankeschön..
 

Spacemojo

Mitglied
Mitglied seit
16.05.2004
Beiträge
624
Welches Encoding verwendest du?

Mein Tipp: verwende XeTeX, das kann Unicode.
 

Friedemann

Mitglied
Thread Starter
Mitglied seit
19.10.2003
Beiträge
3.052
Okay, Minimalbeispiel:

\documentclass[
DIV11 % automatische Berechnung einer guten Zeilenl‰nge
,abstracton % Zentrierte ‹berschrift bei der Zusammenfassung
,titlepage % extra Titelseite
,a4paper % DIN A4
,pointlessnumbers % Keine Punkte hinter Abschnittsziffern wenn noch weitere Abschnitte folgen
,11pt % Schriftgroesse 11 Punkt
,halfparskip % Halbzeiliger Abstand zwischen Absaetzen anstelle einer Einrueckung
,headsepline % Trennlinie zwischen Kopfzeile und Text
,headexclude % Kopfzeile nicht in die Satzspiegelberechnung einbeziehen
,smallheadings % "kleine" ‹berschriften
,bibtotoc % Literaturverzeichnis ins Inhaltsverzeichnis
,idxtotoc % Symbolverzeichnis ins Inhaltsverzeichnis
,liststotoc % Abbildungs- und Tabellenverzeichnis ins Inhaltsverzeichnis
]
{scrartcl} % KOMA-Script-Report-Klasse


%% ----- Konfiguration 8 bit / Deutsch -----
\usepackage[english, ngerman]{babel} % NDS / Silbentrennung / Und weitere "Eindeutschungen"
\usepackage[T1]{fontenc} % Schriften T1 "encoden", sonst gibt es z.B. Probleme beim kopieren von Umlauten.

\usepackage{graphicx}
\usepackage[ngerman]{babel}
\usepackage{natbib}
\usepackage{setspace}
\usepackage{longtable}
\usepackage{listings}
\usepackage{textcomp}
\usepackage{wasysym}
\usepackage[paper=a4paper,left=30mm,right=20mm,top=25mm,bottom=25mm]{geometry}
\usepackage{hyperref}
%Neue Befehle
\newcommand{\grad}{\mbox{\(\mathsurround=0pt{}^\circ\)}}

\pagestyle{headings}
\onehalfspacing

%Hier beginnt das Dokument
\begin{document}

Ich gèhe nach Hausé mit’m Aufzug.

\end{document}
 

Friedemann

Mitglied
Thread Starter
Mitglied seit
19.10.2003
Beiträge
3.052
Den Kopf habe ich beigefügt, weil dieser bei meiner Diplomarbeit benutzt wird.
 

tasha

Mitglied
Mitglied seit
06.08.2002
Beiträge
3.740
Naja,

minimal ist das Beispiel nicht, aber sei’s drum.

Das Problem: Du teilst LaTeX nicht mit, mit welcher Kodierung Dein File abgespeichert ist. Das Paket inputenc mit der passenden Option hilft.

Grüße,

tasha
 

uselessuser

Mitglied
Mitglied seit
11.09.2005
Beiträge
447
Wenn du die Akzente unbedingt direkt reinschreiben willst, musst du das Encoding verändern. Also etwa \usepackage[applemac]{inputenc} oder so.
 

Friedemann

Mitglied
Thread Starter
Mitglied seit
19.10.2003
Beiträge
3.052
Wenn du "unbedingt direkt reinschreiben" sagst - wie würdest du es machen?
 

minilux

unregistriert
Mitglied seit
19.11.2003
Beiträge
14.264
ich kenn jetzt deine Akzente nicht, aber wenn du \usepackage[applemac]{inputenc} verwendets schreibst du einfach "ö", verwendest du das nicht schreibst du "\"o" (funktioniert dafür auf allen Systemen)
 

Friedemann

Mitglied
Thread Starter
Mitglied seit
19.10.2003
Beiträge
3.052
Ja, dass ist richtig. Und das mit den Akzenten hat auch geklappt. Das mit den Umlauten hat aber auch schon bei ngerman-babel geklappt.

Danke dennoch.
 

tasha

Mitglied
Mitglied seit
06.08.2002
Beiträge
3.740
ich kenn jetzt deine Akzente nicht, aber wenn du \usepackage[applemac]{inputenc} verwendets schreibst du einfach "ö", verwendest du das nicht schreibst du "\"o" (funktioniert dafür auf allen Systemen)
Ich finde es nur begrenzt sinnvoll, sich bei der Eingabe unnötig Arbeit zu machen, wenn ein anständiger Editor, der wenigstens mit den gängigen Kodierungen umgehen kann, auch weiter helfen würde. Aber das nur am Rande.

Jedenfalls bin ich mir nicht ganz sicher, ob dem Threadersteller klar ist, dass nur dann die Option applemac die richtige ist, wenn er seine Dateien auch in Mac OS Roman abspeichert.

Grüße,

tasha
 

moses_78

Mitglied
Mitglied seit
08.04.2005
Beiträge
1.299
Ich finde es nur begrenzt sinnvoll, sich bei der Eingabe unnötig Arbeit zu machen, wenn ein anständiger Editor, der wenigstens mit den gängigen Kodierungen umgehen kann, auch weiter helfen würde. Aber das nur am Rande.

Jedenfalls bin ich mir nicht ganz sicher, ob dem Threadersteller klar ist, dass nur dann die Option applemac die richtige ist, wenn er seine Dateien auch in Mac OS Roman abspeichert.

Grüße,

tasha
Richtig, bei mir funktioniert Latex in UTF-8 mit tetex und TexShop
auch einwandfrei.

Das Paket "ucs" hier herunterladen, installieren, und dann hat sich
die Sache...
 

uselessuser

Mitglied
Mitglied seit
11.09.2005
Beiträge
447
Ich finde es nur begrenzt sinnvoll, sich bei der Eingabe unnötig Arbeit zu machen, wenn ein anständiger Editor, der wenigstens mit den gängigen Kodierungen umgehen kann, auch weiter helfen würde. Aber das nur am Rande.
Hm, TeXShop ist bei mir so eingestellt, dass er automatisch alle relevanten Dinge ersetzt. Mir ist es einfach lieber so, und Arbeit macht es auch nicht mehr. Old School und so. ;)
 

moses_78

Mitglied
Mitglied seit
08.04.2005
Beiträge
1.299
Vim-LaTeX ist in der Tat ziemlich cool :eek:

Vor allem das Code-Folding und das Syntax Highliting sehen klasse
aus.

Der Nachteil: Keine UTF8-Unterstützung.
 
Oben