Autovervollständigung bei Excel

  1. McMuhaus

    McMuhaus Thread StarterMacUser Mitglied

    Mitglied seit:
    22.12.2003
    Beiträge:
    555
    Zustimmungen:
    16
    Wie kann ich es bei Excel erreichen, dass Excel, wenn ich z.B. E13 schreibe, automatisch die Namen die mit der Nummer verbunden sind angezeigt werden?
    Es ist etwas schwierig zu erklären. Aber kann man nicht irgendwo eingeben, dass Excel mit bestimmten Nummern oder Zeichenfolgen, bestimmte Namen verbindet, dass wenn man die Nummer schreibt, die Namen eingefügt werden.
    Geht das?

    Gruß
     
    McMuhaus, 27.08.2004
  2. mackay

    mackayMacUser Mitglied

    Mitglied seit:
    05.01.2003
    Beiträge:
    2.435
    Zustimmungen:
    7
    Moin
    du kannst so etwas über AutoKorrektur anlegen :)

    aber ob das der eleganteste Weg ist, weiß ich nicht :D

    Kay ;)
     
    mackay, 27.08.2004
  3. Jabba

    JabbaMacUser Mitglied

    Mitglied seit:
    21.11.2003
    Beiträge:
    4.458
    Zustimmungen:
    109
    Hallo, ääh, Du! (den Nick lass ich mal, das kannst Du mit Deinem Busenkumpel Lynni ausmachen... :D)

    Du meinst Auto-Ersetzen. Willst Du z.B. in Zelle A1 den Wert "E13" eingeben und dieser soll dann in derselben Zelle A1 durch den Namen X ersetzt werden?
    Schwierig.
    a. VBA Makro
    b. mackays Lösung, ist aber sehr umständlich, und führt bei vielen Ersetzungen zwangsweisen zu unerwünschten Erstzungen innerhalb anderer Begriffe.

    Vorschlag:
    Arbeite mit einer Hilfs-Spalte.
    A1 die Eingabe "E13" und in A2 steht das Ergebnis.
    Wie:
    Du benutzt in der Zelle A2 die Formel SVERWEIS, die zeigt Dir den "E13" entprechenden Namen an.
    Bedingung:
    Du MUSST einmal eine Tabelle mit allen Entsprechungen anlegen!

    Bsp:
    Schreibe mal in eine neue, leere Tabelle:
    A1 erst mal leerlassen!
    A2 reinschreiben: =SVERWEIS(A1;F1:G10;2; )
    (du erhälst eine Fehlermeldung, ok!)
    F1 reinschreiben: E13
    G1 reinschreiben: SWORDFISH

    Dann tippe in A1 E13 ein, und oh Wunder, in A2 steht die Lösung.
    Das sollte als Ansatz genügen, es ist viel einfacher als es aussieht!

    HTH
     
    Jabba, 27.08.2004
  4. mackay

    mackayMacUser Mitglied

    Mitglied seit:
    05.01.2003
    Beiträge:
    2.435
    Zustimmungen:
    7
    @th3sw0rdf!$h

    der von Jabba vorgeschlagene SVerweis ist die eleganteste Lösung :)

    damit kannst du ganze Adress-Felder ausfüllen lassen.

    Am besten wäre du versuchst zu schildern was passieren soll, wenn du E13 eingibts.

    Kay ;)
     
    mackay, 27.08.2004
Die Seite wird geladen...
Ähnliche Themen - Autovervollständigung bei Excel
  1. Dark Rose
    Antworten:
    10
    Aufrufe:
    201
  2. LostWolf
    Antworten:
    7
    Aufrufe:
    289
    LostWolf
    11.07.2017
  3. pergynt
    Antworten:
    2
    Aufrufe:
    100
    pergynt
    21.06.2017
  4. Appelmus
    Antworten:
    4
    Aufrufe:
    210
    Appelmus
    13.06.2017
  5. Dieschonwieder
    Antworten:
    0
    Aufrufe:
    123
    Dieschonwieder
    24.05.2017