Appstore Verbindung nicht möglich - Uhrzeitproblem

qaloo

Neues Mitglied
Thread Starter
Dabei seit
04.01.2022
Beiträge
5
Punkte Reaktionen
1
Servus,

ich habe mein Macbook (Pro 13“ late 2013) auf Werkseinstellungen zurückgesetzt, die SSD formatiert und das OS neu installiert. Nun bin ich wieder beim alten OS X 10.8.5.

Ich wollte die Software wieder auf den neuesten Stand bringen - aber ich bekomme keine Verbindung zum Appstore und kann somit keine Softwareaktualisierung vornehmen.

Natürlich habe ich schon nach Lösungen gesucht und bereits folgendes probiert:

-DNS Server auf 8.8.8.8 und 8.8.4.4 gestellt

-zuerst hatte ich ein Problem in der Einstellung „Datum & Uhrzeit“. Die Zeitzone ließ sich nicht automatisch einstellen (Ortungsdienste aktiviert). Nachdem ich die Datei localtime unter /private/etc gelöscht habe funktionierte die Zeitzone wieder. Uhrzeit habe ich auf automatisch (Apple Europa) und diese wird auch korrekt angezeigt. Habe es mit der Atomuhr verglichen.
Allerdings bekomme ich in Chrome bei manchen Seiten die Fehlermeldung „Ihre Uhr geht vor“ NET::ERR_CERT_DATE_INVALID.
In Safari kann ich einige Seiten auch nicht öffnen. Wahrscheinlich liegt hier iwo der Fehler warum der Appstore keine Verbindung herstellen kann…

-WLAN Verbindung habe ich auch schon deaktiviert und wieder aktiviert. Fritzbox neu gestartet usw. -keine Veränderung
Mit anderen Geräten gibt es keinerlei Probleme mit dem WLAN.

Habe gelesen, dass es auch mit Problemen vom Schlüsselbund zusammenhängen könnte - kenne mich Zertifikaten usw. allerdings nicht aus.
Anzumerken ist, dass ich bis auf Chrome noch keine Veränderungen/ Installationen vorgenommen habe. Auch keine Browser-Erweiterungen o.ä. Alles auf Werkseinstellungen.
Weiß nicht mehr weiter. Vllt kann mir ja ein Apfelexperte weiterhelfen :)
 

Difool

Frontend Admin
Dabei seit
18.03.2004
Beiträge
15.297
Punkte Reaktionen
10.549
Zertifikate sind abgelaufen.

Alternativ und als schnelle Lösung:

DST Root CA X§ - Fix.png
 

qaloo

Neues Mitglied
Thread Starter
Dabei seit
04.01.2022
Beiträge
5
Punkte Reaktionen
1
Danke für die Antwort. Habe die Schritte befolgt, leider hat es keine Änderung vollbracht
 

qaloo

Neues Mitglied
Thread Starter
Dabei seit
04.01.2022
Beiträge
5
Punkte Reaktionen
1
Leider kann ich die Datei nicht runterladen da Safari die Seite nicht öffnen kann…

Kurze Korrektur: Das Macbook ist von Ende 2012 mit Retina (nicht wie zuvor angegeben von 2013)
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
64.021
Punkte Reaktionen
13.141
Öffne mal das Terminal gib dort
Code:
curl -k -O https://letsencrypt.org/certs/isrgrootx1.der
ein.
Dann sollte die Datei bei dir im Home liegen
 

qaloo

Neues Mitglied
Thread Starter
Dabei seit
04.01.2022
Beiträge
5
Punkte Reaktionen
1
Dann gibt‘s im Terminal die Fehlermeldung: curl: (35) Unknown SSL protocol error in connection to letsencrypt.org:443
 

tocotronaut

Aktives Mitglied
Dabei seit
14.01.2006
Beiträge
29.842
Punkte Reaktionen
9.459
Mit den Zertifikaten wird es trotzdem nicht richtig funktionieren, da die alten systeme auch alte installer laden...

Du willst ja nicht nur dein 10.8 auf dem (damals) neuesten Stand halten, du willst ja wieder ein aktuelles System drauf haben, oder?

Als erstes 10.12 (macOS Sierra) herunterladen und installieren.
Dann geht der App-Store wieder und du kannst das System deiner wahl draufziehen.


Alternativ den Rechner statt mit cmd+r mit cmd+alt+r starten, dann sollte dir ein aktuelleres System installiert werden.

cmd+r installiert das älteste mögliche System (10.8)
cmd+alt+r installiert das neueste für den Rechner verfügbare System. (10.15 Catalina?)

Wenn du auf 10.8 bist musst du mit einem Zwischenschritt erst auf den neuen App-Store Kommen, den es mit 10.11(+App-Store Update) oder 10.12 gab.
 
Zuletzt bearbeitet:

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
64.021
Punkte Reaktionen
13.141
Dann versuch mal
Code:
curl -k --tlsv1 -O https://letsencrypt.org/certs/isrgrootx1.der
Aber eventuell kann das olle 10.8.5 kein TLS.
 

qaloo

Neues Mitglied
Thread Starter
Dabei seit
04.01.2022
Beiträge
5
Punkte Reaktionen
1
ERFOLG

Ich habe nun zum 3. mal versucht den Mac neu aufzusetzen mit cmd+alt+R und siehe da, nun hat er sofort Catalina installiert.
Woran es jetzt gelegen hat weiß ich nicht. Bei meinen vorherigen Versuchen habe ich ebenfalls nach dem Start cmd+alt+R gedrückt - er zeigte auch an, dass er per Internet-Recovery das System aufspielt, aber trotzdem wurde OSX 10.8.5 installiert. Vielleicht Verbindungsprobleme während des Aufspielens?

Sei es drum…bin glücklich, dass es nun funktioniert. Vielen Dank für eure Hilfe!!! :)
 

tocotronaut

Aktives Mitglied
Dabei seit
14.01.2006
Beiträge
29.842
Punkte Reaktionen
9.459
Nein, Verbindungsprobleme sind im grunde ausgeschlossen.
Da hat er beim ersten mal starten das "alt" drücken nicht erkannt und du hast unbewusst mit cmd+r gestartet.
 
Oben Unten