App Fotos Datenbank defekt?

PeZwo

Neues Mitglied
Thread Starter
Registriert
19.08.2010
Beiträge
17
Hallo.

Ich habe beim Arbeiten mit der Fotos-App ein Problem und hoffe, dass mir jemand helfen kann wie ich das wieder in den Griff bekomme. Ich versuche zu erklären, welcher Effekt auftritt (das gar nicht so einfach zu erklären)

Ich habe die Fotos von meiner letzten Reise wie immer als RAW in der App Fotos gespeichert. Dort rufe ich die Bilder einzeln auf und bearbeite sie mit diversen Programmen nach. Wenn man in der Vorschau in ein bearbeitetes Foto später wieder einsteigt, sieht man die bearbeitete Version und kann es per Button "bearbeiten" noch weiter bearbeiten oder man kann per Klick wieder zum Original-Bild ggf. zurückkehren. Soweit ist das alles normales Business as usual ... und das war es bis jetzt für mich auch.

Aber nun tritt folgender Effekt auf: ich sehe in der Vorschau das bearbeitete Bild. Ich klicke auf den Button "Bearbeiten" und plötzlich sehe ich nicht mehr wie sonst das bearbeitete Bild sondern das unbearbeitende RAW-Bild (ohne dass ich den Button "zurück zum Original" betätigt habe). Gehe ich wieder zurück zur Vorschau, sehe ich wieder die bearbeitete Version. Es sieht fast danach aus, als gäbe es in der Datenbank keine Verbindung mehr zwischen dem RAW und der Bearbeitung.

Dummerweise wird auch beim Exportieren die unbearbeitete Version genommen, d.h. ich sehe zwar in der Vorschau noch meine bearbeitete Version, habe aber ansonsten keinen Zugriff mehr darauf. Da ich in die Bearbeitungen schon jede Menge Zeit und Energie investiert habe, ist das natürlich gar nicht gut.

Hat irgendjemand eine Idee, wie ich das Problem in den Griff bekommen könnte?
 

Kuddl

Mitglied
Registriert
09.01.2018
Beiträge
206
Was heißt: „Aber nun tritt…“ auf, genau?

Neuerdings? Nach längerer Nutzungspause? Nach irgendeinem (System-)Update? Aus heiterem Himmel?

Welches macOS ist im Spiele?
 

PeZwo

Neues Mitglied
Thread Starter
Registriert
19.08.2010
Beiträge
17
Was heißt: „Aber nun tritt…“ auf, genau?

Neuerdings? Nach längerer Nutzungspause? Nach irgendeinem (System-)Update? Aus heiterem Himmel?

Welches macOS ist im Spiele?
Ich nutze ein MBP15 Mid 2015 und habe MacOs Catalina installiert (bezüglich sämtlicher Updates bin ich am letzten Stand).

Seit wann? Tja, das kann ich leider nicht genau sagen. Dieser Fehler fällt ja nicht sofort auf, man bemerkt ihn nur, wenn man manche (es betrifft ja nicht alle) bearbeitete Fotos aus irgendwelchem Grund neu bearbeiten will und auf "Bearbeiten" klickt oder sie exportieren will ... und das passiert eben nicht so oft. Ich habe daher keine Ahnung, seit wann das Problem genau besteht. Ich denke, dass es wahrscheinlich zwischen Mitte Oktober und Mitte November geschehen sein muss, denn ich führte betroffenen Nachbearbeitungen Mitte Oktober durch und auf einer Sicherung, die ich am 19.11.2018 gemacht habe, existiert der Fehler schon.

Ich habe das Update auf Catalina Anfang November 2018 gemacht. Der Umstieg verlief zwar augenscheinlich problemlos, aber vielleicht ist da etwas unbemerkt im Hintergrund geschehen.
 
Zuletzt bearbeitet:
Oben