App baut nicht für das iPad2

Maximilian2010

Neues Mitglied
Thread Starter
Mitglied seit
07.09.2010
Beiträge
38
Hey zusammen,
ich habe eine App, die auf dem iPad immer lief... jetzt habe ich mein iPad gegen ein iPad2 (4.3.2) ausgetauscht und ich bekomme immer folgenden Fehler:
Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/gcc-4.2 failed with exit code 1
und unter meiner App stand zunächst 1target, missing baseSDK...
dann habe ich diese in den Eigenschaften auf 4.3 gestellt und iOS Deployment Target ebefalls auf 4.3 gestellt...
Der Fehler tritt jedoch trotzdem auf - die Meldung missing baseSDK ist nun jedoch behoben!

Im Simulator 4.3 baut die App problemlos... Woran kann das liegen? Habe Xcode heute noch aktualisiert auf 4.0.2 and ios sdk 4.3 :(

Habe keine Ahnung was ich noch ausprobieren kann!!!
Vielen Dank für eure Tipps!
Max
 

below

Aktives Mitglied
Mitglied seit
15.03.2004
Beiträge
13.564
Xcode 3? Xcode 4?

Du kannst das Base SDK im Target und im Projekt einstellt. Wenn Du also im Projekt das Base SDK auf 4.3 gestellt hast, aber im Target immer noch 4.2 steht, wird 4.2 genommen. Diese Einstellungen können dann auch für Simulator und Device unterschiedlich sein.

HTH

Alex
 

Maximilian2010

Neues Mitglied
Thread Starter
Mitglied seit
07.09.2010
Beiträge
38
das hatte ich engestellt... hab aber durch ausprobieren die Lösung gefunden! Sollte noch jmd. das Problem haben:
Man muss die Architecture auf Optimized (armv7) stellen - Standard (armv6 armv7) reicht wohl nicht aus
Aber Danke für den Tipp!
Viele Grüße
 

below

Aktives Mitglied
Mitglied seit
15.03.2004
Beiträge
13.564
Nein, das kann es nicht sein. Auch das iPad 2 muss ARMv6 verarbeiten können.

Gruss

Alex
 

Maximilian2010

Neues Mitglied
Thread Starter
Mitglied seit
07.09.2010
Beiträge
38
mh also ich hab nur das umgestellt und dann hat es funktioniert...
bin mir eigenttlich sehr sicher, dass ich sonst nix nderes mehr verstellt hatte!
Viele Grüße
Max
 
Oben