Apache2, Hosteurope & mod_rewrite == false

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von Rabe, 31.08.2006.

  1. Rabe

    Rabe Thread Starter MacUser Mitglied

    Beiträge:
    36
    Zustimmungen:
    0
    MacUser seit:
    24.05.2004
    Hallo!

    Habe einen VPS M bei Hosteurope mit Linux. Ich möchte nun meinen Blog, der da gehostet ist, auf mod_rewrite mit tollen und schönen urls umbauen.

    Und genau da fängt natürlich direkt mal das Problem an. Laut php_info() ist mod_rewrite installiert, steht auch unter APACHE_MODULES mit "rewrite" drin und in der loadmodules.conf ist auch der Load-Eintrag korrekt. Werkseinstellungen quasi.

    Habe versucht AllowOverride in die .htaccess zu schreiben (der Mensch, der die httpd.conf geschrieben hat riet mir dazu in einem Kommentar in der Datei), was natürlich nur einen 500er produzierte.

    Dann habe ich in die httpd.conf den Eintrag AllowOverride FileOption etc eingesetzt und bekommen immer noch vom mod_rewrite_tester gesagt, dass alles ausser mod_rewrite funktioniert.

    Jetzt hab ich grob gesagt mal keine Lust mehr, Google gibt auch nichts mehr her und hoffe, dass mir hier jemand helfen kann.

    Gruß,

    Seb
     
    Zuletzt bearbeitet: 31.08.2006
  2. msslovi0

    msslovi0 MacUser Mitglied

    Beiträge:
    2.713
    Zustimmungen:
    115
    MacUser seit:
    20.03.2005
    Warum versuchst du nicht einfach, mal deine RewriteRules in die Datei zu schreiben?

    Matt
     
  3. wegus

    wegus MacUser Mitglied

    Beiträge:
    14.713
    Zustimmungen:
    1.348
    MacUser seit:
    13.09.2004
    mod_rewrite erzeugt Last und wird daher von manchen Providern geblockt!
    Hast Du denn eine Bestätigung das mod_rewrite zur Verfügung steht!?
     
Die Seite wird geladen...

Diese Seite empfehlen