1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Apache und PHP funktionieren nicht mehr richtig anch Update

Dieses Thema im Forum "Mac OS" wurde erstellt von Bamboozle, 03.05.2005.

  1. Bamboozle

    Bamboozle Thread Starter MacUser Mitglied

    Mitglied seit:
    26.12.2004
    Beiträge:
    117
    Zustimmungen:
    2
    Hallo,

    ich bin total verzweifelt, weil ich den Fehler nicht finde. Seit dem Update auf Tiger heute Morgen will PHP nicht mehr funktionieren. Klicke ich auf eine lokale .php Seite, bekomme ich den Inhalt der Datei im Browser angezeigt, ausgeführt wird da wohl nichts.

    Also habe ich mich in /Library/Apache2 auf die Suche nach httpd.conf gemacht. (Warum eigentlich Apache2 wenn dann letztendlich nur 1.3 läuft?). Dort finde ich am Schluss

    LoadModule php4_module modules/libphp4.so
    AddType application/x-httpd-php .php

    so dass ich eigentlich der Meinung bin, es müsste funktionieren. Was geht denn hier schief.
     
  2. Bamboozle

    Bamboozle Thread Starter MacUser Mitglied

    Mitglied seit:
    26.12.2004
    Beiträge:
    117
    Zustimmungen:
    2
    Ok, jetzt ist meine Verwirrung vollständig:

    /Library/StartupItems/Apache2

    und

    /System/Library/StartupItems/Apache

    kann es sein, dass hier nun 2 Apache installiert sind und der "alte" in /System.." gestartet wird?
     
  3. heldausberlin

    heldausberlin MacUser Mitglied

    Mitglied seit:
    01.05.2004
    Beiträge:
    13.832
    Zustimmungen:
    302
    hatte das gleiche Problem und einen Fehler in der httpd.conf entdeckt.

    da war in Zeile 1080 eine Erklärung ohne "#" ausgeklammert.

    Tipp mal "apachectl configtest" im Terminal ein.
     
  4. Bamboozle

    Bamboozle Thread Starter MacUser Mitglied

    Mitglied seit:
    26.12.2004
    Beiträge:
    117
    Zustimmungen:
    2
    Liefert keinen Fehler. Es werden aber auch nur

    Processing config directory: /private/etc/httpd/users/*.conf

    getestet. Die httpd.conf in /Library/Apache2 scheint ihn nicht zu interessieren. Langsam habe ich echt den Eindruck, ich habe hier nach dem Update 2 Installationen.

    Wie bekomme ich die 1.3 version los und die 2. zum Laufen?
     
  5. heldausberlin

    heldausberlin MacUser Mitglied

    Mitglied seit:
    01.05.2004
    Beiträge:
    13.832
    Zustimmungen:
    302
    ok, ich weiß was ich gemacht hatte.
    Ich hatte ein Backup der alten httpd.conf unter Panther aktiviert.
    Und in der die PHP-Freigaben nochmal vorgenommen.
    Schick mir ne PM, dann kann ich dir die Datei ja mailen.