Apache spuckt 403 Forbidden aus.

  1. Bl4cKbIrD

    Bl4cKbIrD Thread StarterMacUser Mitglied

    Mitglied seit:
    09.09.2004
    Beiträge:
    86
    Zustimmungen:
    0
    Hi

    Wenn ich http://localhost/ aufrufe bringt mir mein apache immer
    Code:
    Forbidden
    You don't have permission to access / on this server.
    
    Apache/1.3.29 Server at blackbird.local Port 80
    
    Hab in der httpd.conf so eingestellt, dass der DocumentRoot /Volumes/Daten/Sites ist, da ich 2 Partitionen habe. Es hat auch schon mal funktioniert aber jetzt klappt es auf einmal nicht mehr.

    kann mir jemand helfen?

    Danke im Voraus
    Bl4cKbIrD
     
    Bl4cKbIrD, 22.09.2004
  2. [TB]Lucky

    [TB]LuckyMacUser Mitglied

    Mitglied seit:
    17.11.2003
    Beiträge:
    769
    Zustimmungen:
    0
    Stimmen die Userrechte auf dem Verzeichnis? Ich denke mal das wird der Fehler sein.

    - björn
     
    [TB]Lucky, 22.09.2004
  3. Bl4cKbIrD

    Bl4cKbIrD Thread StarterMacUser Mitglied

    Mitglied seit:
    09.09.2004
    Beiträge:
    86
    Zustimmungen:
    0
    die Rechte sehen so aus:
    Code:
    drwxrwxrwx  16 domfor  domfor   544 14 Sep 20:32 Sites
     
    Bl4cKbIrD, 22.09.2004
  4. [TB]Lucky

    [TB]LuckyMacUser Mitglied

    Mitglied seit:
    17.11.2003
    Beiträge:
    769
    Zustimmungen:
    0
    Und wie sehen die Rechte auf dem Ordner, der normalerweise der Webordner ist, aus?

    - björn
     
    [TB]Lucky, 22.09.2004
  5. Bl4cKbIrD

    Bl4cKbIrD Thread StarterMacUser Mitglied

    Mitglied seit:
    09.09.2004
    Beiträge:
    86
    Zustimmungen:
    0
    auf /Users/domfor:
    drwxr-xr-x 4 domfor domfor 136 22 Sep 20:28 Web-Sites

    auf /Library/WebServer:
    drwxrwxr-x 36 root admin 1224 6 Mar 2004 Documents
     
    Bl4cKbIrD, 22.09.2004
  6. [TB]Lucky

    [TB]LuckyMacUser Mitglied

    Mitglied seit:
    17.11.2003
    Beiträge:
    769
    Zustimmungen:
    0
    Also nu weiß ich auch nicht mehr weiter....

    - björn
     
    [TB]Lucky, 22.09.2004
  7. Bl4cKbIrD

    Bl4cKbIrD Thread StarterMacUser Mitglied

    Mitglied seit:
    09.09.2004
    Beiträge:
    86
    Zustimmungen:
    0
    habe nun einmal das ganze zurückgeändert, dass er mit localhost wieder auf /Library/WebServer/Documents geht und so funktioniert es... er zeigt die apache testseite an.
    wenn ich nun jedoch http://localhost/~domfor aufrufen will, kommt
    Code:
    Not Found
    The requested URL /~domfor was not found on this server.
    
    Apache/1.3.29 Server at blackbird.local Port 80
    
     
    Bl4cKbIrD, 22.09.2004
  8. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    was sagt:
    tail /var/log/httpd/error_log
    ? (im Terminal)
     
    maceis, 22.09.2004
  9. Bl4cKbIrD

    Bl4cKbIrD Thread StarterMacUser Mitglied

    Mitglied seit:
    09.09.2004
    Beiträge:
    86
    Zustimmungen:
    0
    ok das ganze geht nun wieder... Vielen Dank!

    ich hatte keine rechte um die dateien aufzulisten, weil ich keine index.htm hatte.

    Weiss jemand gerade, wie ich einstellen kann, dass alle dateien und ordner aufgelistet werden?
     
    Bl4cKbIrD, 22.09.2004
  10. aguilera

    aguileraMacUser Mitglied

    Mitglied seit:
    09.03.2004
    Beiträge:
    48
    Zustimmungen:
    0
    Bei den Verzeichnisoptionen "+Indexes" hinzufügen.

    Wie z.B.
    <Directory /path/to/dir>
    Options +Indexes
    </Directory>

    Grüße
    agui
     
    aguilera, 22.09.2004
Die Seite wird geladen...
Ähnliche Themen - Apache spuckt Forbidden
  1. malah
    Antworten:
    3
    Aufrufe:
    1.154
    beatles
    10.02.2017
  2. Jackson100
    Antworten:
    7
    Aufrufe:
    1.645
    Jackson100
    15.04.2012
  3. neech
    Antworten:
    18
    Aufrufe:
    1.344
    ratzefatze
    25.01.2012
  4. mawa
    Antworten:
    5
    Aufrufe:
    1.613
  5. obi
    Antworten:
    23
    Aufrufe:
    1.522
    salome.p
    12.05.2009