Apache antwortet mit "forbidden"

Petejo

Mitglied
Thread Starter
Registriert
23.04.2003
Beiträge
226
Hallo,
ich habe folgendes Problem: Wir haben auf einem Rechner die Web-Dienste aktiviert und 3 User angelegt, die ihre Webseite ablegen sollen. Ruft man die Webseite des Rechners auf, erscheint die fröhliche Meldung "Es funktioniert", geht man stattdessen auf den Bereich des Users: 192.168.123.101/~user/, erscheint die Meldung 403, Access forbidden, nachdem wir seine Standardwebseite durch die eigene ersetzt haben.

Ich habe schon mit Batchmod an den Rechten gedreht, mal auf www, mal auf guest und auf nobody gesetzt, ohne ERfolg.

Überhaupt würde ich gerne wissen, wie man den Apache klassisch einsetzt und nicht über den Useraccount, schliesslich soll am Server kein User entstehen, der Rechte und eine eigene Umgebung erhält, weil keiner ausser mir lokal was an dem Rechner zu suchen hat.

Ich hatte schon mal Dokumente unter .../httpd/htdocs abgelegt und in der httpd.conf einen virtuellen host definierrt, das scheint OS X aber nicht zu akzeptieren, irgendwo muss die Umleitung auf den user dazwischen funzen. Wer weiss Abhilfe?

Danke, Petejo
 

Paefchen

Mitglied
Registriert
04.05.2003
Beiträge
145
Ist das ein 10.1 oder 10.2 System, normal oder Server ?

Gruß Paefchen
 

Petejo

Mitglied
Thread Starter
Registriert
23.04.2003
Beiträge
226
Hallo,

es ist v10.2 auf dem Mac, keine Serversoftware.

Grüsse,
Petejo
 

Delmar

Mitglied
Registriert
28.09.2002
Beiträge
830
Überprüf' mal die Rechte der Website Ordner der einzelnen User und poste mal, wie sie eingestellt sind.


Gruß
Delmar
 

MacErik

Mitglied
Registriert
06.09.2002
Beiträge
633
Hallo,
wenn du Apache ohne Verweis auf einen bestimmten User einsetzen willst, gehören die Dateien in den Ordner /Library/WebServer/Documents/.
Erik
 

joedelord

Mitglied
Registriert
12.12.2002
Beiträge
492
ich hatte so etwas anhliches auch ein mal. es kann sein das er ein bischen sensibel auf die endungen reagiert. der unterschiede zwischen .htm und .html kostete mich schon einmal viel zeit und ein paar anrufe beim suport.

vieleicht hifts, joedelord
 

Paefchen

Mitglied
Registriert
04.05.2003
Beiträge
145
Du kannst eigentlich schon virtuellehost anlegen. Nur must du in der httpd.conf die letzte zeile: "include: /private/etc/httpd/users" ausmarkern (#).
ich habe dan, obwohl es eigentlich nicht gehen soll. IP Host genutzt. Dazu must du natürlich in den Systemeinstellungen -> Netzwerk die IP-Adressen hinzufügen.

Desweitern sollten die Ordner mit dem Inhalt die rechte "eingentümmer: www" oder "gast auf lesen" stehen.

Gruß Paefchen
 

Petejo

Mitglied
Thread Starter
Registriert
23.04.2003
Beiträge
226
Hi,
und vielen Dank erst einmal für die vielen Tipps, die allerdings leider keinen Erfolg brachten.
Es sieht so aus: Der OS X - Mac soll für verschiedene WebDesign-Studenten als WebServer fungieren. Dazu soll jeder Student die entworfenen Seiten per FTP rüberschicken können. Er soll keinen wie auch immer gearteten lokalen Zugang zum Rechner bekommen, also verbietet sich das anlegen eines USERs, was ich zunächst aber einmal so vorgenommen habe, bis das mit den virtuellen Hosts klappt. Beim ausprobieren Eurer Tricks ist aufgefallen, dass die Rechte des Studentenrechners wohl mit übertragen werden. Am Server hatte ich die Rechte auf 777 gesetzt, sodass alles funktionieren müsste. Hatt ein Student seine fertige Seite per FTP auf den WebServer gesendet, war wieder die Meldung FORBIDDEN zu lesen. Als FTP-client wurde die interne funktion von Dreamweaver 4 genutzt, die Studenten arbeiten unter OS 9.2.
Wo sind da die Zusammenhänge?

Vielen Dank und viele Grüsse,

Petejo: confused:
 

Kiri-san

Neues Mitglied
Registriert
08.07.2003
Beiträge
35
Diese forbidden Meldung erscheint auch, wenn du die Listendarstellung (Indexes) ausgeschaltet hast.

Wenn Du also z.B. http://foo.bar.com/~username/ eingibst, und in dem Verzeichnis "username" gibt es keine Datei mit dem Namen "index.html", "index.htm", "index.shtml" oder was auch immer Du in den Preferences sonst noch als Default festgelegt hast, gibt dir Apache einen forbidden error, wenn du die Listendarstellung (Indexes) in den Preferences für diese(s) Verzeichnis(se) deaktiviert hast.
 
Zuletzt bearbeitet von einem Moderator:

Petejo

Mitglied
Thread Starter
Registriert
23.04.2003
Beiträge
226
Vielen Dank,
das mit den Preferenzen werde ich überprüfen, dennoch, die index.html-Datei gibt es ja. Sie wird per ftp vom Teilnehmer auf den Server kopiert, wenn er seine Webseite fertig hat. Danach erscheint im Browser 403, wenn sie unter 192.168.0.x./~user aufgerufen wird.

Grüsse, PeteJo
 

Paefchen

Mitglied
Registriert
04.05.2003
Beiträge
145
Was hat den der Ordner "~user" für rechte ? Und wer ist der Eigentümmer ?
 

Petejo

Mitglied
Thread Starter
Registriert
23.04.2003
Beiträge
226
Hi,

der Eigentumer ist der USER, die Rechte habe ich mit BatchMod auf 777 gesetzt, damit müsste jeder alles dürfen. Kannst mir gerne mal Deine httpd.conf. senden,
eMail ist petejo@entertraining.net

Danke,
Petejo
 

starknights

Mitglied
Registriert
31.05.2004
Beiträge
211
ebenfalls ein forbidden

Hallo,

ich habe so ziemlch das gleice Problem.

wenn server läuft, localhostist da, aber wennich auf
127.0.0.1/~starknights/ zugreifen will:

You don't have permission to access /~starknights/ on this serv

seltsamerweise klappt es wenn ich aus die seiten von meinem mitbenutzern gehe,

also zb,
127.0.0.1/~filip/

irgendwer ein idee?


_____
PS.
ach ja, ich vergaß:

ich nutze panther, habe das problem glaube ich auch seit ich auf panther geupdated habe, vorher liefs mal.

ich habe auch schon in
/private/etc/httpd/users/

die einstellungen für die benutzer verglichen, ist alles ok,
auch wenn ich die datei direkt aufrufen will klappt es aber nicht
(http://localhost/~starknights/index.html)
habe sogar die standart dateien von panther wieder drin :(
nix.

jeder andere user klappt, nur meiner nicht...

Danke im Voraus ;)

_____
PPS.

diese zeile hab ich aus der error log von apache...
[Mon May 31 15:07:01 2004] [error] [client 127.0.0.1] (13)Permission denied: access to /~starknights/index.html failed because search permissions are missing on a component of the path
ich hoffe, ihr könnt damit was anfangen...
 
Zuletzt bearbeitet:

Hairfeti

Mitglied
Registriert
08.11.2003
Beiträge
464
Original geschrieben von Petejo
Hi,

der Eigentumer ist der USER, die Rechte habe ich mit BatchMod auf 777 gesetzt, damit müsste jeder alles dürfen. Kannst mir gerne mal Deine httpd.conf. senden,
eMail ist petejo@entertraining.net

Danke,
Petejo
 

Du bist hier beschäftigt oder arbeitest dort? http://www.training.entertraining.net/

Und dann bekommst du keinen Zugriff auf den Web-Content des Web-Servers gebacken?

Kann ich jetzt nicht ernsthaft glauben.

Wenn du weiterhin noch diese Probleme hast, bitte mal hier an dieser Stelle zurückmelden.

In den nächsten Tagen wollte ich eh eine nächste FAQ im Forum erstellen. Die soll heißen: "Konfiguration des Apache-Webservers in OS X". Wenn du willst machen wir das beide gemeinsam und dein Server läuft danach ohne Probleme. Das heißt: Die FAQ ist eigentlich schon da, ich möchte sie nur um einige Punkte erweitern.
 

Registrierung oder Anmeldung bei MacUser.de

Du musst bei uns Mitglied sein, um einen Beitrag schreiben zu können.

Benutzerkonto erstellen

Erstelle ein kostenloses Benutzerkonto für Macuser.de

Log in

Besitzt du schon ein Benutzerkonto? Hier anmelden.

Oben