Alten, verschobenen Blog in iWeb zurückholen? Experten benötigt!

Konrad Zuse

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2006
Beiträge
3.633
Moin,

habe seit einiger Zeit ein etwas merkwürdiges Problem in iWeb. Selbst der Apple-Support konnte nicht helfen, deshalb frage ich nun mal das allwissende Forum. Ich habe in iWeb drei verschiedene Webseiten angelegt. Die oberste in der linken Spalte wird auf Mobile.me gehostet, die zweite ist nur "versuchstechnisch", die dritte wird auf einen FTP-Server geladen. Es geht um die, die auf Mobile.me hochgeladen wird. Die Seite ist quasi eine persönliche Fundstatistik für's Geocachen, d.h. dort schreibe ich auf einer Blogseite jeden einzelnen meiner Cachefunde auf und lade ein entsprechendes Foto hoch.
Nun hat iWeb vom einen auf den anderen Tag rumgesponnen und immer wieder Fehler beim Hochladen gemacht, bzw. jedesmal den gesamten Blog hochgeladen (was bei meiner besch*****en DSL-Leitung jedes Mal 6 Stunden dauerte), obwohl ich auf "nur Änderungen hochladen" gegangen bin, wie immer. Es hatte schon fast den Anschein, als ob "der Blog voll" ist und Mobile.me bei einer bestimmten Anzahl an seine Grenzen stößt, was ich mir bei ca. 300 Blogeinträgen eigentlich nicht vorstellen kann,oder?
Um diesem Problem aus dem Weg zugehen, habe ich für die neueren Funde nun einen zweiten Blog erstellt. Trotzdem wird der erste Blog, auch wenn ich dort keine Änderungen vorgenommen habe, jedesmal komplett neu hochgeladen (6 Stunden!).Nun habe ich, um die Aufzeichnungen nicht zu verlieren, den ersten Blog von der obersten Webseite in die unterste verschoben. Ging komischerweise.
Nun möchte ich ihn wieder zurückschieben, was aber leider nicht funktioniert.
Auch zeigt die "Bloghauptseite" noch die ersten fünf Einträge an, aber auf den "Unterseiten" -> "Einträge" und "Archiv" ist nichts mehr vorhanden.
Ich kann über Timemaschine die Einträge und das Archiv wieder herstellen, aber wie bekomme ich es wieder in meine "Mobile.me-Seite"? Offensichtlich reicht es nicht den gesamten Ordner über den Finder in die Webseite zu integrieren.
Muß ich da irgendetwas mit einer Plist-Datei machen? Wenn ja was? Ich möchte mir aber auch ungern die neuere Seite "zerschießen", noch möchte ich alles neu abtippen.
Ich hoffe, ich habe mein Problem einigermaßen verständlich geschildert und hoffe auf eure Hilfe!
Danke!
 

falkgottschalk

Aktives Mitglied
Mitglied seit
22.08.2005
Beiträge
24.083
afaik schließen sich die Begriffe "iWeb" und "importieren" leider gegenseitig aus...
 

Konrad Zuse

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2006
Beiträge
3.633
Ja, aber importieren wäre ja vielleicht der falsche Ausdruck,oder?
Ich kann ja den alten Blog in der Library oder auch in die Websites verschieben. Aber braucht iWeb dann nicht zusätzlich irgendeine (Plist?) Datei, um zu "merken", "aha, ich soll diese Seite jetzt mit veröffentlichen"?
Faktisch ist der komplette "alte" Blog ja noch vorhanden, aber die dazugehörige Plistdatei kennt ja logischerweise den "neuen" Blog nicht. Merkwürdigen Shiet!:mad:
 

Konrad Zuse

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2006
Beiträge
3.633
Tja, vielen Dank euch beiden.
Habe jetzt zum letzten Mittel gegriffen und die wiederhergestellte Datei auf die andere Domain per FTP hochgeladen.
Nun muß ich halt die anderen Seiten ein wenig verändern, aber ich habe wenigstens den ersten Teil des Blogs wieder online. (Liest zwar eh keine Sau, aber für mich ist es halt 'ne gute Erinnerung).
Um diese "alte" iWebseite nun wieder bearbeiten zu können, muß ich mir ja logischerweise auch die domain.sites von diesem Datum wiederherstellen.
Kann man diese .sites-Dateien eigentlich gefahrlos umbennen, damit man nicht durcheinanderkommt, oder müssen die den Namen behalten?
 

Konrad Zuse

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2006
Beiträge
3.633
Ich kann da nur bedingt helfen. Da Du Timemaschine nutzt, mußt Du ja ein Backup der Domain Datei von iWeb haben. Damit hast Du doch alles wieder wie vorher.....
Ja, aber ich habe ja dann quasi eine domain.sites-Datei bis zum 24.04.2011 und dann eine neue ab 25.04.2011.
Da ich ja den Blog in einem zweiten Teil weitergeführt habe. Und diese zwei domain.sites-Dateien lassen sich ja offensichtlich nicht zusammenführen.
 

Rul

Aktives Mitglied
Mitglied seit
16.10.2009
Beiträge
11.806
Ich habe auch eine kleine Seite mit iWeb erstellt (teilweise zwischen 1 und 5 Seiten) Je nach Lust und Laune, wie mir gerade ist. Aber zum Thema: Wenn ich innerhalb von iWeb etwas verändere, eine Seite lösche, verschiebe oder Ähnliches und die Seite dann per "Änderungen an der Website veröffentlichen" online stelle, kann es schon einmal vorkommen, dass die aktualisierte Seite ein paar Stunden braucht, um zu erkennen, dass etwas geändert wurde.

Das scheint aber nur ein Teil des Problems zu sein. Abhilfe schafft hier, den Cache aus Safari zu löschen. Des weiteren hilft es auch, zumindest war / ist es bei mir so, stets die komplette Website zu veröffentlichen, nicht nur die Änderungen. Und was noch schneller geht, da du hier Zugriff auf die Dateien hast, wäre ein FTP-Anbieter, wie webftp.de. Da kannst du deine Daten eingeben und die vermurksten Daten per Hand löschen und deinen Webspace bereinigen. Dann lädst du deine Website wieder hoch und alles sollte funktionieren.
 

Rul

Aktives Mitglied
Mitglied seit
16.10.2009
Beiträge
11.806
Danke für die Belehrung.
 

Konrad Zuse

Aktives Mitglied
Thread Starter
Mitglied seit
15.02.2006
Beiträge
3.633
...Nee, zusammenführen geht nicht. Aber ich denke die neuere Version ist TRASH ?.
Also ab in den Müll...................
????? Wo habe ich das denn gesagt?
Die ist nicht Trash, sondern die eine Webseite (die wiederhergestellte) beinhaltet de Blog bis zu einem bestimmten Datum und die n eue Seite beinhaltet halt Blog2, ab einem bestimmten Datum.
 

PDM

Mitglied
Mitglied seit
03.10.2010
Beiträge
270
Lieber Konrad,
eigentlich wollte ich behilflich sein. Du reagierst hier aber überempfindlich.
Dann nicht.
 
Oben