Alle Accounts weg. Nur "Andere" Account auf dem iMac vorhanden

Weiyi

Mitglied
Thread Starter
Mitglied seit
18.01.2006
Beiträge
355
Hallo,
Wie im Titel angegeben habe ich plötzlich beim Starten meines iMacs gemerkt, dass alle Accounts weg waren und nur ein "Anderes" Account angezeigt wird, das mir verdächtig nach einem root Account aussah. Aber ich bin mir sicher, dass ich in dieser Richtung nichts verstellt habe und auch nichts merkwürdiges beim Arbeiten vorher feststellen konnte... Alle Benutzername und Passwort Kombinationen scheiterten. Aber ich habs trotzdem hinbekommen mit ein paar Zeilen Terminal Befehle im Singleuser Modus, einen neuen Admin Account zu erstellen und die alten verlorenen wiederherzustellen, indem ich dem iMac so eingestellt habe, dass nach einem Neustart das Mac OS X Konfigurationsprogramm erscheint, das man sich als Erstes zu Gesicht bekommt, wenn man einen neuen gelieferten Mac einschaltet.

Nur die Frage: Was kann das gewesen sein? Virus? Oder Hardware Defekt? Bin ziemlich Ratlos. Ich hatte das Problem noch nie vorher gehabt. Weiß jemand vielleicht mehr?

Danke
 

Weiyi

Mitglied
Thread Starter
Mitglied seit
18.01.2006
Beiträge
355
Danke erstmal für den Link. :) Leider beschreibt der Themenstarter nur das Problem, aber nicht die Ursache. Würde trotzdem gerne wissen was das war, zumal das Wiederherstellen der Accounts viel Terminal Fummelei beinhaltet, wenn man keine DVD zur Verfügung hat. Das möchte ich gerne vermeiden, indem ich weiß wie das Problem entstanden sein könnte. Hat sonst noch jemand eine Idee?
 

bernie313

Aktives Mitglied
Mitglied seit
20.08.2005
Beiträge
23.496
zuerst müsstest du in der Konsole überprüfen, ob du überhaupt von dem "external Account Fehler" betroffen bist, das kannst du wie gesagt in der Konsole überprüfen, ob du dort ähnliche Einträge findest:
com.apple.loginwindow[42] 2010-12-15 09:54:15.005 ManagedClient[233:903] -xaDiskDisappeared: removing external account "DeinUserName" with home "/Users/DeinUserName" from DSLocal because disk disappeared.
Denn in diesem Fall hält OS X die lokalen Accounts für externe und löscht diese(die Daten sind allerdings nach wie vor vorhanden).
Den Grund dafür müsste man dann suchen, in den Apple Diskussions wird es häufig einem Bug zugesprochen, der innerhalb von 10.6.x sein Unwesen betreibt
 

29032010

Registriert
Mitglied seit
29.03.2010
Beiträge
3
klick im Anmeldefenster auf Andere und gib dort deinen Benutzernamen und das Kennwort ein.
Wenn das nicht klappt, bin ich leider auch überfragt. Notfalls das System vom letzten TimeMachine Backup wiederherstellen.

Gruß, ChameleonHacker
 

29032010

Registriert
Mitglied seit
29.03.2010
Beiträge
3
sorry, ich hatte nicht richtig gelesen. aber mein tipp funktioniert trotzdem! :)

Gruß, ChameleonHacker
 
Oben