AFP-Verzeichnis verschwunden

  1. Nullkommanix

    Nullkommanix Thread StarterMacUser Mitglied

    Mitglied seit:
    14.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Ich habe ein dubioses Problem mit OS X 10.4.8 Server. Im Server befindet sich eine Platte, auf der sich drei Directories befinden, die jeweils als AFP- und SMB-Volumes freigegeben sind. Seit heute werden im Finder des Servers nur noch zwei dieser Volumes angezeigt, das dritte - nennen wir es mal "laufwerk_3" - ist verschwunden. Die Daten des nicht mehr angezeigten Volumes sind allerdings noch auf der Platte vorhanden, wie sowohl df als auch ein Blick in /Volumes/laufwerk_3 zeigen. Ein rsync-Backup, das heute nacht gelaufen ist, hat ebenfalls die komplette Datenmenge auf eine Externplatte geschrieben. Auch auf dieser zeigt der Finder des Servers das Verzeichnis bzw. den Share nicht an, wohl aber der Blick /Volumes/backup/laufwerk_3.

    An den angeschlossenen Clients ist die Situation so, dass die OS9-Kisten laufwerk_3 problemlos erkennen und mounten, die OSX-Rechner mounten korrekt wie ein Blick in die Volumes-Verzeichnisse der Clients zeigen; in den Findern der Clients erscheint der Mount-Punkt allerdings nicht. Über SMB lässt sich das Volume hingegen problemlos mounten. DIe Clients, auf denen ein PathFinder läuft, zeigen den Share im Gegensatz zum OSX-Finder an.

    War jemand schon mal mit dem selben Problem konfrontiert und/oder hat einen Lösungsansatz?
     
    Nullkommanix, 14.11.2006
  2. slowfranklin

    slowfranklinMacUser Mitglied

    Mitglied seit:
    28.11.2005
    Beiträge:
    233
    Zustimmungen:
    5
    Sind das jetzt drei Ordner in einer Platte/Volume oder was? Dein zweiter Satz sagt "Seit heute werden im Finder des Servers nur noch zwei dieser Volumes angezeigt,..." was gewaltige Verwirrung stiftet. Davon abgesehen: evtl. einen automount record für die fragliche Freigabe angelegt?

    Meine Bitte: präzisiere deine Beschreibung und schau am Server ins Terminal und nimm das als Referenz für den Status Ordner existiert/existiert nicht. Dann schaun mer weiter.

    Ralph
     
    slowfranklin, 15.11.2006
  3. Nullkommanix

    Nullkommanix Thread StarterMacUser Mitglied

    Mitglied seit:
    14.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Es handelt sich um ein Volume namens "volume-3" auf dem sich drei Folder namens "A", "B" und "volume-3" befinden. Jeder der Folder ist eine Netzwerkfreigabe, so dass es für diesen Server im Netz drei Volumens names "A", "B" und "volume-3" gibt. Der Ordner "volume-3" ist (für den Finder) verschwunden, aber in /Volumes vorhanden. Die UNIX-Ordnerattribute "777" sowie Owner und Group sind bei allen drei Ordner identisch. Zwischenzeitlich habe ich versucht, im lokalen Finder mit "Go To Folder" auf den "nicht vorhandenen" Ordner zuzugreifen. Der erscheint daraufhin auch kurzfristig, hat aber nicht das normale Folder-Icon sondern das Icon für einen Netzwerk-Share. Sobald der Finder die Ordnerliste neu einliest, ist "volume-3" wieder weg. Wohlgemerkt, nur für OSX, die OS9-Rechner haben keinerlei Probleme. Das riecht deshalb nach irgendeinem krummen Zustand in den erweiterten Attributen für OS X.
     
    Nullkommanix, 20.11.2006
  4. slowfranklin

    slowfranklinMacUser Mitglied

    Mitglied seit:
    28.11.2005
    Beiträge:
    233
    Zustimmungen:
    5
    Hm. Nur zwei vage Ideen:

    a) Ordner hat das unsichtbar flag
    -> osxutils per z.B. macports.org besorgen
    -> setfile aus den DeveloperTools besorgen bzw. aus den Receipts klauben mit:
    Code:
    find /Library/Receipts -iname setfile -print
    b) automounts definiert?
    am Server:
    Code:
    lookupd -q mount
    Ralph
     
    slowfranklin, 20.11.2006
  5. Nullkommanix

    Nullkommanix Thread StarterMacUser Mitglied

    Mitglied seit:
    14.11.2006
    Beiträge:
    5
    Zustimmungen:
    0
    Danke für den Tipp!

    Fehler mit setFile behoben. Jetzt ist alles wieder schön. Vielen Dank für die kompetente Hilfe!
     
    Nullkommanix, 22.11.2006
Die Seite wird geladen...
Ähnliche Themen - AFP Verzeichnis verschwunden
  1. drpiety
    Antworten:
    0
    Aufrufe:
    331
    drpiety
    09.08.2015
  2. leo-magic
    Antworten:
    8
    Aufrufe:
    1.474
  3. Tim01
    Antworten:
    0
    Aufrufe:
    494
  4. Thomas82
    Antworten:
    4
    Aufrufe:
    991
    Johanna K
    03.12.2012
  5. huber99
    Antworten:
    1
    Aufrufe:
    2.259
    Smilie71
    14.01.2013