zugriff auf server erst nach anmeldung eines lokalen benutzers?

Dieses Thema im Forum "Mac OS X" wurde erstellt von bot, 03.04.2007.

  1. bot

    bot Thread Starter MacUser Mitglied

    Beiträge:
    315
    Zustimmungen:
    20
    MacUser seit:
    03.11.2006
    guten tag!

    wir nutzen einen g4 da 667 unter 10.4.8 als fileserver für unsere arbeitsgruppe. afs und smb sind aktiviert. es gibt einen admin-user und einen standard-user auf dem rechner, die jedoch nur bei bedarf benutzt werden, wenn jemand etwas direkt an der maschine tun will.

    seit vorgestern hat sich merkwürdigerweise etwas geändert: die afs- und smb-user kommen nur noch auf den server, wenn ein lokaler benutzer angemeldet ist. weiß jemand, woran das liegen könnte?

    vorher war der zugriff problemlos möglich, ohne daß ein lokaler user angemeldet war. nein, ein update ist in der fraglichen zeit nicht passiert.

    ratlos

    bot
     
  2. awado

    awado MacUser Mitglied

    Beiträge:
    355
    Zustimmungen:
    19
    MacUser seit:
    30.03.2007
    Wie wurde denn der Rechner dann betrieben? Habt Ihr ihn laufen lassen, während er den Login-Schirm zeigt?
     
  3. bot

    bot Thread Starter MacUser Mitglied

    Beiträge:
    315
    Zustimmungen:
    20
    MacUser seit:
    03.11.2006
    ja. oder, um genauer zu sein: er war so eingestellt, daß der angemeldete user nach einer halben stunde inaktivität automatisch abgemeldet wurde.

    das habe ich vor einer woche ändern müssen, um einen rsync-cronjob laufen lassen zu können, für den ein volume eines externen rechners gemountet sein muß. parallel dazu habe ich eingestellt, daß das gerät jeden morgen um acht neugestartet wird - wenn wir anfangen zu arbeiten, steht er also mit login-screen da und der zugriff von außen ist nicht möglich. bis vorgestern kein problem ...

    bot
     
  4. awado

    awado MacUser Mitglied

    Beiträge:
    355
    Zustimmungen:
    19
    MacUser seit:
    30.03.2007
    Vielleicht ist afs und smb unter dem Standard-User aktiviert worden und somit an dessen Login gebunden? Ergibt zwar keinen Sinn, aber inzwischen glaub ich an alles. Wenn Du es als Admin versuchst: beides mal aus, Preferences schließen und wieder ein?
     
  5. bot

    bot Thread Starter MacUser Mitglied

    Beiträge:
    315
    Zustimmungen:
    20
    MacUser seit:
    03.11.2006
    nein, ergibt keinen sinn, sorry.

    wenn ich die services starten oder beenden will, muß ich ohnehin das admin-paßwort eingeben. serverdienste sollten bei benutzerabmeldung anders als programme nicht beendet werden. aber ich lasse mich jederzeit eines besseren belehren! ehrlich!

    sehnsüchtig der belehrung harrend

    bot
     
  6. awado

    awado MacUser Mitglied

    Beiträge:
    355
    Zustimmungen:
    19
    MacUser seit:
    30.03.2007
    Ich fürchte, da ist dann irgendwo der Wurm in launchd drin. Damit kenn ich mich aber nicht wirklich gut aus, um Dir eine kompetente Hilfe zu sein. Ich übergebe an den nächsten... ;-)
     
  7. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Das hätt's eigentlich nicht gebraucht, das rsync auch über ssh läuft. Hilft Dir aber jetzt leider auch nicht wirklich weiter.

    Hast Du mal einen Portscan auf den Server gemacht, wärend kein Benutzer angemeldet ist?

    Ausßerdem würde ich mal den Netzwerkverkehr mitschnieden, wärend sich ein Client gerade anmelden möchte. Das geht z.B. mit wireshark, oder - falls Du wireshark nicht hast - mit tcpdump im Terminal.
     
  8. maceis

    maceis MacUser Mitglied

    Beiträge:
    16.645
    Zustimmungen:
    596
    MacUser seit:
    24.09.2003
    Das hätt's eigentlich nicht gebraucht, das rsync auch über ssh läuft. Hilft Dir aber jetzt leider auch nicht wirklich weiter.

    Hast Du mal einen Portscan auf den Server gemacht, wärend kein Benutzer angemeldet ist?

    Ausßerdem würde ich mal den Netzwerkverkehr mitschnieden, wärend sich ein Client gerade anmelden möchte. Das geht z.B. mit wireshark, oder - falls Du wireshark nicht hast - mit tcpdump im Terminal.
     
  9. bot

    bot Thread Starter MacUser Mitglied

    Beiträge:
    315
    Zustimmungen:
    20
    MacUser seit:
    03.11.2006
    naja, der externe rechner läuft unter xp und ist weder rsync-server noch -client und zudem muß ich durch die firewall - mounten kann ich das ding nur per webdav usw.usf. ...

    meine diesbezüglichen fragen habe ich übrigens hier gestellt.

    Code:
    	 Open TCP Port: 	139		netbios-ssn
    	 Open TCP Port: 	427		svrloc
    	 Open TCP Port: 	445		microsoft-ds
    	 Open TCP Port: 	497		dantz
    	 Open TCP Port: 	548		afpovertcp
    
    leider - eigentlich ist es kein "leider" - hat sich das problem erledigt und ich kann es auch nicht reproduzieren. nun läuft alles wieder so wie es soll.

    der tip mit dem tcpdump klingt aber interessant, werde ich auf jeden fall machen, um was dazuzulernen.

    danke

    bot
     
    Zuletzt bearbeitet: 04.04.2007
  10. bot

    bot Thread Starter MacUser Mitglied

    Beiträge:
    315
    Zustimmungen:
    20
    MacUser seit:
    03.11.2006
    das problem ist wieder da ...

    änderungen seit dem letzten mal: update von 10.4.8 auf 10.4.9.

    bot
     
Die Seite wird geladen...
Ähnliche Themen - zugriff auf server
  1. makrovic
    Antworten:
    1
    Aufrufe:
    174
    Olivetti
    27.11.2015
  2. Mojive
    Antworten:
    6
    Aufrufe:
    388
    Mojive
    12.12.2013
  3. special08
    Antworten:
    0
    Aufrufe:
    1.402
    special08
    04.03.2012
  4. Illidan
    Antworten:
    10
    Aufrufe:
    2.434
    Illidan
    03.02.2012
  5. Toasta
    Antworten:
    0
    Aufrufe:
    478
    Toasta
    14.03.2010