Xcode Debugger?

Dieses Thema im Forum "Mac OS X Entwickler, Programmierer" wurde erstellt von dexter, 08.04.2004.

  1. dexter

    dexter Thread Starter MacUser Mitglied

    Beiträge:
    3
    Zustimmungen:
    0
    MacUser seit:
    11.09.2003
    hAI........

    Ich habe da mal 2 Fragen zum Xcode Debugger ...

    1) Wie kann ich richtig durch meinen Code steppen? Wenn der Code noch kleiner ist mag das ja gehen, aber sobald es etwas größer wird springt er nur noch in irgentwelche noch nie gesehenden Unterklassen und anderen Code. Ein richtiges steppen ist so nicht mehr möglich. Ich habe mir sagen lassen das man das bei anderen Umgebungen ausstellen kann. Geht das auch beim Xcode?


    2) Die Anzeigen der Variablen sind sehr unschön finde ich. Einmal zeigt er mir nicht alle an! (z.B. die Variablen aus den Headern fehlen komplett) und bei den Variablen die er mir anzeigt, zeigt er mir nur irgent welche komischen Informationen an, die mich eigentlich überhaubt nicht interessieren! Kann man das auch ändern?
     
  2. Scyx

    Scyx MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Vielleicht bin ich einfach zu doof dafür, aber kann mir bitte einer sagen, wie ich 'ne .cpp Datei builden/debuggen kann?
    Bei mir sind diese Aktionen inaktiv, ich kann sie also leider nicht ausführen.
    Der Quelltext funktioniert, das weiss ich, allerdings würd ich trotzdem mal gern sehen, ob ich Verbesserungsvorschläge angezeigt bekomme...
     
  3. TerminalX

    TerminalX MacUser Mitglied

    Beiträge:
    1.800
    Zustimmungen:
    108
    MacUser seit:
    12.01.2004
    @ Scyx
    Hast du ein Projekt erstellt? Soweit ich weiß kann man keine einzelne .cpp Datei compilieren und debuggen.

    @ dexter
    Sorry auf deine Frage hab ich weiß ich keine Antwort. Bin kein Profiprogrammierer.
     
  4. Scyx

    Scyx MacUser Mitglied

    Beiträge:
    133
    Zustimmungen:
    0
    MacUser seit:
    26.02.2004
    Ja, hatte ein Projekt erstellt und dann auf Datei hinzufuegen, aber leider hat das auch nichts geändert...

    [edit]
    Schade dass mir keiner geraten hat, es mal als Admin zu machen, bzw. den aktuellen User in die Gruppe zu setzen, denn daran hat's gelegen. Ich hatte nicht die Rechte zum ausführen... Wär dann nämlich um einiges leichter gewesen :)

    Naja, aber jetzt funktioniert's soweit...
     
    Zuletzt bearbeitet: 11.05.2004
Die Seite wird geladen...

Diese Seite empfehlen